Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th April 2007, 01:39
markg85 markg85 is offline
Junior Member
 
Join Date: Jan 2007
Posts: 18
Thanks: 0
Thanked 4 Times in 3 Posts
Default Sharp fonts for Fedora How-To?

Hey,

i just saw the how to fir the sharp fonts on ubuntu but it doesn`t really work on fedora.. i`m getting close though.
the only problem i still have is that the fonts are looking good and sharp in the windows but text that is being displayed isn`t looking good at all.

with some parts it looks like they are still aliased..

i hope you (falko?) can make the tutorial for fedora as well.
thanx in favor.
Reply With Quote
Sponsored Links
  #2  
Old 7th April 2007, 14:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by markg85
Hey,

i just saw the how to fir the sharp fonts on ubuntu but it doesn`t really work on fedora.. i`m getting close though.
the only problem i still have is that the fonts are looking good and sharp in the windows but text that is being displayed isn`t looking good at all.
In which applications? This works only with GNOME applications.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 7th April 2007, 17:54
markg85 markg85 is offline
Junior Member
 
Join Date: Jan 2007
Posts: 18
Thanks: 0
Thanked 4 Times in 3 Posts
Default

does firefox count as a gnome application
but gnome itself is also not looking the same like in your screenshots.. so a howto for fedora would be nice.
Reply With Quote
  #4  
Old 8th April 2007, 15:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by markg85
does firefox count as a gnome application
No, Firefox is no GNOME application. The same goes for OpenOffice and lots of other applications.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 8th April 2007, 15:51
markg85 markg85 is offline
Junior Member
 
Join Date: Jan 2007
Posts: 18
Thanks: 0
Thanked 4 Times in 3 Posts
Default

sorry.. i thought you meant the language that gnome was written in.
however i`ve meda a little progress in the fonts. it turns out that the fonts are getting ugly when i use: "Subpixel smoothing (LCDs)" and are looking better when i use: ""Best shapes" and i do have a LCD monitor!!

but i have no idea how to do those font hints that you describe in the howto.. that doesn`t work the same in fedora as in Ubuntu.. same with the fonts.conf file.. i can`t even adjust it because X won`t start when i do adjust it.
Reply With Quote
  #6  
Old 9th April 2007, 17:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by markg85
i can`t even adjust it because X won`t start when i do adjust it.
X doesn't start when you modify ~/.fonts.conf? Maybe there's a syntax error in your file?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 10th April 2007, 19:30
markg85 markg85 is offline
Junior Member
 
Join Date: Jan 2007
Posts: 18
Thanks: 0
Thanked 4 Times in 3 Posts
Default

yea.. and the file had the exact same contents as in your howto.
Reply With Quote
  #8  
Old 11th April 2007, 16:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Strange...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 11th April 2007, 21:10
markg85 markg85 is offline
Junior Member
 
Join Date: Jan 2007
Posts: 18
Thanks: 0
Thanked 4 Times in 3 Posts
Default

i now have it all in a good looking way. i didn`t even used the fonts config stuff.
this is what i did:

1. install ALL microsofts fonts
2. go to gnome`s font preferences and ONLY change the fonts.. no other changes at all. so only change all fonts to Tomoha and your done

i also "tweaked" firefox.
here is how you can get good looking fonts in firefox:
1. boot in windows, start Firefox, open the preferences, open all the font settings and make a screenshot of it.
2. send the screenshot to your mail (unless you can mount your drive)
3. boot in linux
4. enter the exact same font settings of that screenshot in linux.

i now have normal looking fonts.. it all seems to be a little fatter than windows but that`s probably just the way fedora/linux renders fonts.

now i would like to know how i can apply this in fedora:
Code:
category truetype
begin /usr/share/fonts/truetype/custom/tahoma.ttf
  Family = Tahoma
  FontName = Tahoma-Regular
  Encoding = Unicode
  Location = Magyar Dutch Spanish Czech Russian English Catalan Slovak Italian Turkish Danish Slovenian Basque Portuguese German Polish Swedish Norwegian French Finnish Greek
  Charset = ISO8859-1 ISO8859-2 ISO8859-3 ISO8859-4 ISO8859-5 ISO8859-7 ISO8859-9 ISO8859-10 ISO8859-13 ISO8859-14 ISO8859-15 KOI8-R KOI8-U CP1251 VISCII1.1-1 TCVN-5712 ISO10646-1
  UniCharset = ISO8859-1 ISO8859-2 ISO8859-3 ISO8859-4 ISO8859-5 ISO8859-7 ISO8859-9 ISO8859-10 ISO8859-13 ISO8859-14 ISO8859-15 KOI8-R KOI8-U CP1251 VISCII1.1-1 TCVN-5712
  GeneralFamily = SansSerif
  Weight = Medium
  Width = Variable
  Shape = NoSerif Upright
  Foundry = Microsoft
  Priority = 20
end
begin /usr/share/fonts/truetype/custom/tahomabd.ttf
  Family = Tahoma
  FontName = Tahoma-Bold
  Encoding = Unicode
  Location = Magyar Dutch Spanish Czech Russian English Catalan Slovak Italian Turkish Danish Slovenian Basque Portuguese German Polish Swedish Norwegian French Finnish Greek
  Charset = ISO8859-1 ISO8859-2 ISO8859-3 ISO8859-4 ISO8859-5 ISO8859-7 ISO8859-9 ISO8859-10 ISO8859-13 ISO8859-14 ISO8859-15 KOI8-R KOI8-U CP1251 VISCII1.1-1 TCVN-5712 ISO10646-1
  UniCharset = ISO8859-1 ISO8859-2 ISO8859-3 ISO8859-4 ISO8859-5 ISO8859-7 ISO8859-9 ISO8859-10 ISO8859-13 ISO8859-14 ISO8859-15 KOI8-R KOI8-U CP1251 VISCII1.1-1 TCVN-5712
  GeneralFamily = SansSerif
  Weight = Bold
  Width = Variable
  Shape = NoSerif Upright
  Foundry = Microsoft
  Priority = 20
end
and how i can apply this:
Code:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>

<!-- Give all fonts light hinting and subpixel smoothing -->
<!--
<match target="font">
    <edit mode="assign" name="rgba">
        <const>rgb</const>
    </edit>
    <edit mode="assign" name="hinting">
        <bool>true</bool>
    </edit>
    <edit mode="assign" name="hintstyle">
        <const>hintslight</const>
    </edit>
    <edit mode="assign" name="antialias">
        <bool>true</bool>
    </edit>
</match>
-->

<!--
     <match target="font">
        <test qual="all" name="rgba"><const>unknown</const></test>
           <edit name="rgba" mode="assign"><const>rgb</const></edit>
     </match>
-->

<!--  Do not smooth Fixedsys  -->
<match target="font">
    <test name="family">
        <string>FixedsysTTF</string>
    </test>
    <edit name="antialias">
        <bool>false</bool>
    </edit>
</match>

<!--  Do not smooth Tahoma 8pt and under  -->
<match target="font">
    <test name="family">
        <string>Tahoma</string>
    </test>
    <test compare="less" name="size" qual="any">
        <double>9</double>
    </test>
    <edit name="antialias">
        <bool>false</bool>
    </edit>
</match>

<!--  Do not smooth Times New Roman or Courier New for 12pt and under  -->
<match target="font">
    <test name="family">
        <string>Times New Roman</string>
    </test>
    <test compare="less" name="size" qual="any">
        <double>13</double>
    </test>
    <edit name="antialias">
        <bool>false</bool>
    </edit>
</match>

<match target="font">
    <test name="family">
        <string>Courier</string>
        <string>Courier New</string>
        <string>Courier 10 Pitch</string>
    </test>
    <test compare="less" name="size" qual="any">
        <double>11</double>
    </test>
    <edit name="antialias">
        <bool>false</bool>
    </edit>
</match>

<!-- Do not autohint Courier New, Fixedsys, Tahoma, or Times New Roman -->
<match target="font">
    <test name="family">
        <string>Courier New</string>
        <string>Times New Roman</string>
        <string>Tahoma</string>
        <string>FixedsysTTF</string>
    </test>
    <edit mode="assign" name="hintstyle">
        <const>hintslight</const>
    </edit>
    <edit mode="assign" name="autohint">
        <bool>false</bool>
    </edit>
</match>

<match target="pattern">
            <test qual="any" name="family">
                    <string>Bitstream Vera Sans</string>
            </test>
            <edit name="family" mode="assign">
                    <string>Arial</string>
            </edit>
</match>
    <match target="pattern">
            <test qual="any" name="family">
                    <string>Helvetica</string>
            </test>
            <edit name="family" mode="assign">
                    <string>Arial</string>
            </edit>
</match>
<match target="pattern">
            <test qual="any" name="family">
                    <string>Palatino</string>
            </test>
            <edit name="family" mode="assign">
                    <string>Georgia</string>
            </edit>
</match>
</fontconfig>
EDIT:://
the fonts.conf edits belong in /etc/fonts/local.conf on fedora.
i`m now having "sharp" fonts though i still have aliased fonts in firefox!!

the sharp fonts look good in most parts but less good in tabs and address bars..
look:

Last edited by markg85; 11th April 2007 at 21:49.
Reply With Quote
The Following 2 Users Say Thank You to markg85 For This Useful Post:
falko (12th April 2007), sardaukar (17th April 2007)
  #10  
Old 17th April 2007, 15:05
sardaukar sardaukar is offline
Junior Member
 
Join Date: Apr 2007
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
 
Question A more general note?

Hello!

Your guide rocks, but alas it is too Tahoma-centric. Can one create the hinting files for other fonts? I rather like the default Gnome font, but I would like to see it sharper too.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig Fonts problem Lars van der Made Installation/Configuration 1 30th January 2007 12:41
MS true type fonts in Fedora domino Installation/Configuration 2 28th October 2005 20:59


All times are GMT +2. The time now is 17:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.