Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th April 2007, 23:10
testset testset is offline
Member
 
Join Date: Mar 2007
Posts: 33
Thanks: 8
Thanked 0 Times in 0 Posts
Default standard "show directory" mode and error pages

how can i set up following:

f.e. we have the domain domain.tld with dir /images

when i open domain.tld/images i see only "error 404" (or something).
can i activate the old
Quote:
"you are in dir /images and we have here the following files...
file1.jpg
file2.jpg
file3.jpg

this server is running apache 2 with php foobar on linux foo
?

I have another problem: i haven't activated "own error pages", but the users can create own and there is an /web/error at every user dir... what to do?

can i change all error pages per webinterface? (the "not own error pages" user have the old pages and not my edited versions)

Thanks! :-)
Reply With Quote
Sponsored Links
  #2  
Old 6th April 2007, 00:01
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,033
Thanks: 260
Thanked 145 Times in 127 Posts
Default

re: directory browsing
http://www.howtoforge.com/forums/showthread.php?t=10149

Basically, you will need to add the following in the ISPconfig domain(s) Apache Directives (change the "/var/www/web28/images" to your settings)

Code:
<Directory "/var/www/web28/web/images">
Options +Indexes
</Directory>
You can do this in ISP Management > domain-in-question > Apache Directives box (it's at the bottom)
Make sure that there is NO index.html in the images dir!
__________________
Never execute code written on a Friday or a Monday.

Last edited by edge; 6th April 2007 at 00:03.
Reply With Quote
  #3  
Old 6th April 2007, 10:35
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

Quote:
I have another problem: i haven't activated "own error pages", but the users can create own and there is an /web/error at every user dir... what to do?

can i change all error pages per webinterface? (the "not own error pages" user have the old pages and not my edited versions)
First, it does not harm if users have their own error pages as this affects only their own website or userwebsite. If you want prevent this, chown the error directory to root and give all other users onyl read permissions to the directories.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 7th April 2007, 23:03
testset testset is offline
Member
 
Join Date: Mar 2007
Posts: 33
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by edge
re: directory browsing
http://www.howtoforge.com/forums/showthread.php?t=10149

Basically, you will need to add the following in the ISPconfig domain(s) Apache Directives (change the "/var/www/web28/images" to your settings)

Code:
<Directory "/var/www/web28/web/images">
Options +Indexes
</Directory>
You can do this in ISP Management > domain-in-question > Apache Directives box (it's at the bottom)
Make sure that there is NO index.html in the images dir!
my control panel says:
Quote:
Sie können diesem Web keine Apache-Direktiven zuordnen.
that means something like "you cannot add apache directives to this web".

i have only check ftp access above the directives box - is this the problem?

@till: great idea - i was not shure if i should do it. i will try it in a few days. :-)
Reply With Quote
  #5  
Old 8th April 2007, 13:12
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

Quote:
that means something like "you cannot add apache directives to this web".

i have only check ftp access above the directives box - is this the problem?
The problem is that you did not allow apache directives in the limits of the reseller. Please enable it there and you should be able to add apache directives.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 8th April 2007, 13:29
testset testset is offline
Member
 
Join Date: Mar 2007
Posts: 33
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
The problem is that you did not allow apache directives in the limits of the reseller. Please enable it there and you should be able to add apache directives.
i tried to add the directives via "admin" and via a reseller - both didn't work. I searched where i can edit the limits of the reseller, but i haven't found the form for edit the limits. when i click on the pencil which is before the resellers name nothing happens. i only see my ISP Server Status.
Is there anything what i could do?
Reply With Quote
  #7  
Old 8th April 2007, 21:35
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

I guess you are mixing up the reseller folder which has a pencil with the reseller itself. Or dont you created a reseller?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 9th April 2007, 00:53
testset testset is offline
Member
 
Join Date: Mar 2007
Posts: 33
Thanks: 8
Thanked 0 Times in 0 Posts
 
Default

hm... i thought that i have created one... but what have i done when this is no reseller?

i've created a reseller now - hope that it will work.

Edit: Oh, now i know what i have done. i moved my reseller in dir /admin/Anbieter (= ger. reseller). now i can correct my settings - thanks a lot!
Attached Images
 

Last edited by testset; 9th April 2007 at 00:58.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 00:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.