Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 28th March 2006, 20:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

It must be
Code:
mysql -u webx_u1 -p
(with space between -u and the username).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #12  
Old 30th March 2006, 11:49
geek.de.nz geek.de.nz is offline
Member
 
Join Date: Feb 2006
Posts: 65
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via ICQ to geek.de.nz Send a message via MSN to geek.de.nz
Exclamation

No, unfortunately this didn't work. As, I said, the users I create in ISPConfig do not appear in my MySQL database under mysql.user.

So, when I do
Code:
#mysql -uroot -p
mysql> select user.User from user;
I only get
Code:
+------------------+
| User                   |
+------------------+
| ispconfiguser        |
| root                   |
| *other non ISPConfig users*      |
+------------------+
3 rows in set (0.00 sec)
I tried creating one with/without remote access I did enter a password and the user appeared in the ISPConfig panel).

Both didn't work from the shell login. Is it maybe a bug like I mentioned before with the general MySQL/Shell setup? Have you tried that possibility?
__________________
Always mention at least your distribution/version! You can add it in your signature if you don't want to always type it. ;-)

Distributions:
Ubuntu 5.10 with custom kernel (2.6.16-suspend2),
Debian Sarge 3.1 and Etch

Please submit your ISP or Webhost to (free)
http://www.ihostnz.com
Reply With Quote
  #13  
Old 30th March 2006, 12:32
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,380
Thanks: 833
Thanked 5,480 Times in 4,314 Posts
Default

If you create for example a new email account, that works?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #14  
Old 30th March 2006, 12:37
geek.de.nz geek.de.nz is offline
Member
 
Join Date: Feb 2006
Posts: 65
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via ICQ to geek.de.nz Send a message via MSN to geek.de.nz
Default

Yes it does. I just created a new email user webx_test under that site and it worked. It appeared in /etc/postfix/virtusertable at the bottom.
__________________
Always mention at least your distribution/version! You can add it in your signature if you don't want to always type it. ;-)

Distributions:
Ubuntu 5.10 with custom kernel (2.6.16-suspend2),
Debian Sarge 3.1 and Etch

Please submit your ISP or Webhost to (free)
http://www.ihostnz.com
Reply With Quote
  #15  
Old 30th March 2006, 15:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Can you check again with phpMyAdmin if the databases and users are really missing?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #16  
Old 1st April 2006, 04:57
geek.de.nz geek.de.nz is offline
Member
 
Join Date: Feb 2006
Posts: 65
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via ICQ to geek.de.nz Send a message via MSN to geek.de.nz
 
Default

I finally figured out what the problem was. It was not a bug. When I installed, I created a user for ispconfig, who did not have enough rights on mysql databases.

This did it for me:
Code:
#mysql -uroot -p
mysql> GRANT ALL PRIVILEGES ON *.* TO 'ispconfig'@'localhost'
    ->     IDENTIFIED BY 'some_password' WITH GRANT OPTION;
Now, users are created and can log in which are created with ispconfig (webx_u1 etc.).

Hope that helps people having the same problem.
__________________
Always mention at least your distribution/version! You can add it in your signature if you don't want to always type it. ;-)

Distributions:
Ubuntu 5.10 with custom kernel (2.6.16-suspend2),
Debian Sarge 3.1 and Etch

Please submit your ISP or Webhost to (free)
http://www.ihostnz.com
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with postfix-mysql Pelle Installation/Configuration 39 13th November 2005 23:25
Removed PostFix, Now MySql Problems!!! sapient Installation/Configuration 10 24th October 2005 07:11
Problem installing ISPConfig, then with MySQL... ctroyp Installation/Configuration 7 26th September 2005 16:37
MySQL issue during install of ISPConfig ricbax Installation/Configuration 4 16th September 2005 09:41
Mysql ejs Installation/Configuration 5 12th August 2005 07:01


All times are GMT +2. The time now is 15:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.