Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th November 2005, 11:31
rayit rayit is offline
Member
 
Join Date: Nov 2005
Posts: 93
Thanks: 0
Thanked 2 Times in 2 Posts
Default problems mysql

I have problems with mysql


Is it possible to copy all files in:
/var/lib/mysql/web20_db1 to a new server /var/lib/mysql/web2_db1
without problems


The problem now is that no users can connect to the database etc..
I did an upgrade of mysql and that did not work with 42go
now I downgraded but all is mixed up..

greetings
Raymond
Reply With Quote
Sponsored Links
  #2  
Old 9th November 2005, 11:52
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,395
Thanks: 833
Thanked 5,492 Times in 4,323 Posts
Default

Quote:
Originally Posted by rayit
I have problems with mysql


Is it possible to copy all files in:
/var/lib/mysql/web20_db1 to a new server /var/lib/mysql/web2_db1
without problems
Yes.

Quote:
The problem now is that no users can connect to the database etc..
I did an upgrade of mysql and that did not work with 42go
now I downgraded but all is mixed up..
Have you changed the file permissions to the mysql user and group on the new server?
Reply With Quote
  #3  
Old 10th November 2005, 14:38
rayit rayit is offline
Member
 
Join Date: Nov 2005
Posts: 93
Thanks: 0
Thanked 2 Times in 2 Posts
Default

yes copying works super..

The old server will be einstalled.
I think mysql users got deleted etc..


thanks

RayIT
Reply With Quote
  #4  
Old 27th March 2006, 13:52
geek.de.nz geek.de.nz is offline
Member
 
Join Date: Feb 2006
Posts: 65
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via ICQ to geek.de.nz Send a message via MSN to geek.de.nz
Default Different problem

MySQL is not working properly in ISPConfig for me!

I cannot enable any databases for a site or client! So, if I go to
ISP Manager --> <a site> --> Basis

I cannot even see the option MySQL option.

When I create a new site, I can see that option, but when I create the site I get:

Error:
You cannot assign MySQL databases to this website.

Next >>

Why is that? Am I missing something or why would it not work? Does installing PHPMyAdmin like described elsewhere in the forum solve the problem?

Also, the SSH login does not work from within ISPConfig. Is that because I'm running my sshd on a different port? Can I still run sshd on a different port, because of security? Also, here I have the same. When I create a new site I can see the option but not when I edit a site.

Error:
You cannot assign shell access to this website.

Next >>

Last edited by geek.de.nz; 27th March 2006 at 13:56.
Reply With Quote
  #5  
Old 27th March 2006, 14:47
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Are you creating this web site under a reseller? Then make sure the reseller has the correct settings regarding databases, etc.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 28th March 2006, 10:47
geek.de.nz geek.de.nz is offline
Member
 
Join Date: Feb 2006
Posts: 65
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via ICQ to geek.de.nz Send a message via MSN to geek.de.nz
Default

Yeah apparently that was the problem. Thank you. So obvious but I just didn't think of it.

Shell access still doesn't work for that user though, although I checked the SSL option in the site as well as the user. I had a look at /etc/passwd and at the end of the line it says for the user:
Code:
...
webx_xxx:x:10002:10002:Full Name:/home/www/webx:/bin/false
...
Doesn't that mean there is no shell for the user? Why does ISPConfig not change this? I thought it's based on the /etc/passwd file???
__________________
Always mention at least your distribution/version! You can add it in your signature if you don't want to always type it. ;-)

Distributions:
Ubuntu 5.10 with custom kernel (2.6.16-suspend2),
Debian Sarge 3.1 and Etch

Please submit your ISP or Webhost to (free)
http://www.ihostnz.com
Reply With Quote
  #7  
Old 28th March 2006, 10:55
geek.de.nz geek.de.nz is offline
Member
 
Join Date: Feb 2006
Posts: 65
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via ICQ to geek.de.nz Send a message via MSN to geek.de.nz
Default

OK, I tried something else:

1. Added user webx_test
2. checked the Shell Access (as I did before for the other user but that one existed before I added shell access for him)

Shell access for webx_test works!

The Shell access check box is active in the user webx_xxx but it doesn't work and also /etc/passwd doesn't indicate it should. Is it maybe a subtle bug?
__________________
Always mention at least your distribution/version! You can add it in your signature if you don't want to always type it. ;-)

Distributions:
Ubuntu 5.10 with custom kernel (2.6.16-suspend2),
Debian Sarge 3.1 and Etch

Please submit your ISP or Webhost to (free)
http://www.ihostnz.com
Reply With Quote
  #8  
Old 28th March 2006, 11:15
geek.de.nz geek.de.nz is offline
Member
 
Join Date: Feb 2006
Posts: 65
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via ICQ to geek.de.nz Send a message via MSN to geek.de.nz
Default

OK, this is weird. I unchecked the check box for that user, saved, and checked it again, saved, and it works.

Still it might be a very subtle bug in the code, maybe you should check this. But then it isn't that big a problem.

So, to repeat what I did:

1. Create reseller without MySQL and Shell access
2. Create Client under this reseller
3. Create website under this client
4. Create user under this site (without MySQL and without Shell)
5. Modify reseller to have MySQL dbs and Shell access
6. Modify site to have shell and mysql
7. Modify user to have mysql and shell, but shell and actually mysql as well didn't work

Yeah, now that I go through it, how do I access mysql with a user that has shell access (or otherwise)? It doesn't seem to work with
Code:
webx_xxx@www#mysql
or
Code:
webx_xxx@www#mysql -p
(with entering the users password)
?

Also, if I enter mysql with my root user I cannot see any entry in the mysql.user table for webx_xxx or anything. How does this part work, because I didn't see any option in ISPConfig about enabling mysql access for users or similar?
__________________
Always mention at least your distribution/version! You can add it in your signature if you don't want to always type it. ;-)

Distributions:
Ubuntu 5.10 with custom kernel (2.6.16-suspend2),
Debian Sarge 3.1 and Etch

Please submit your ISP or Webhost to (free)
http://www.ihostnz.com
Reply With Quote
  #9  
Old 28th March 2006, 11:27
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by geek.de.nz
Yeah, now that I go through it, how do I access mysql with a user that has shell access (or otherwise)? It doesn't seem to work with
Code:
webx_xxx@www#mysql
or
Code:
webx_xxx@www#mysql -p
(with entering the users password)
?

Also, if I enter mysql with my root user I cannot see any entry in the mysql.user table for webx_xxx or anything. How does this part work, because I didn't see any option in ISPConfig about enabling mysql access for users or similar?
http://www.ispconfig.org/downloads/m..._src.htm#4_2_5
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 28th March 2006, 11:49
geek.de.nz geek.de.nz is offline
Member
 
Join Date: Feb 2006
Posts: 65
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via ICQ to geek.de.nz Send a message via MSN to geek.de.nz
 
Default

Hm, OK. Thanks, but the user does not appear in mysql when I log in as root. Also, I cannot log in with the database user (webx_u1), using:
Code:
#mysql -uwebx_u1 -p
and entering the password. I saved and everything.

Thanks for you instant replies anyway.
__________________
Always mention at least your distribution/version! You can add it in your signature if you don't want to always type it. ;-)

Distributions:
Ubuntu 5.10 with custom kernel (2.6.16-suspend2),
Debian Sarge 3.1 and Etch

Please submit your ISP or Webhost to (free)
http://www.ihostnz.com

Last edited by geek.de.nz; 28th March 2006 at 11:57.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with postfix-mysql Pelle Installation/Configuration 39 13th November 2005 23:25
Removed PostFix, Now MySql Problems!!! sapient Installation/Configuration 10 24th October 2005 07:11
Problem installing ISPConfig, then with MySQL... ctroyp Installation/Configuration 7 26th September 2005 16:37
MySQL issue during install of ISPConfig ricbax Installation/Configuration 4 16th September 2005 09:41
Mysql ejs Installation/Configuration 5 12th August 2005 07:01


All times are GMT +2. The time now is 09:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.