Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th November 2005, 02:40
Nu2Linux Nu2Linux is offline
Junior Member
 
Join Date: Oct 2005
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default Syntax error on line 205 of /root/ispconfig/httpd/conf/httpd.conf

1.how do i fix this error? i'd like to use https to access ispconfig.
2.could i delete the directories and database and run the install again and choose http instead of https as a possible workaround?
================================================== =========
Please select the protocol (http or https (SSL encryption)) to use to access the ISPConfig system:
1) HTTPS
2) HTTP
Your Choice: 1

Connected successfully to MySQL server
Restarting some services...
Shutting down postfix: [ OK ]
Starting postfix: [ OK ]
Shutting down proftpd: [ OK ]
Starting proftpd: [ OK ]
Starting ISPConfig system...
Syntax error on line 205 of /root/ispconfig/httpd/conf/httpd.conf:
Cannot load /root/ispconfig/httpd/libexec/libphp5.so into server: /root/ispconfig/httpd/libexec/libphp5.so: cannot restore segment prot after reloc: Permission denied
/root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
ISPConfig system is now up and running!
Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.

[root@localhost install_ispconfig]#
Reply With Quote
Sponsored Links
  #2  
Old 5th November 2005, 14:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Seems to be a problem with ISPConfig's PHP5. Do you use a 64bit Linux or a 32bit one? If you use a 64bit Linux that could be the problem.

On the other hand, it could also be a hardware problem (RAM, hard disk), but I don't think so right now.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 7th November 2005, 03:45
Nu2Linux Nu2Linux is offline
Junior Member
 
Join Date: Oct 2005
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default using linux 32 bit

using linux 32 bit
Reply With Quote
  #4  
Old 7th November 2005, 22:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

What's the output of
Code:
ls -l /root/ispconfig/httpd/libexec/libphp5.so
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 9th November 2005, 03:24
Nu2Linux Nu2Linux is offline
Junior Member
 
Join Date: Oct 2005
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default output is....

root@localhost install_ispconfig]# ls -l /root/ispconfig/httpd/libexec/libphp5.so
-rwxr-xr-x 1 root root 7850036 Nov 4 19:01 /root/ispconfig/httpd/libexec/libphp5.so
Reply With Quote
  #6  
Old 9th November 2005, 10:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
 
Default

That's fine, too.
If I were you, I'd simply install ISPConfig again (but do not delete the current ISPConfig installation, the installer will then realize that it's an update).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Important: Unix line breaks falko Developers' Forum 4 4th March 2011 15:21
Could not make OpenSSL yontengyatso Installation/Configuration 3 3rd November 2005 11:50
Install stop at uuwish, UUDeview SeaWolf Installation/Configuration 6 5th October 2005 00:53
Bind stops and cannot be restarted after a slave domain is added jason Installation/Configuration 20 19th August 2005 09:16
Creating website - nothing happens hagel Installation/Configuration 13 7th August 2005 19:12


All times are GMT +2. The time now is 19:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.