#1  
Old 30th April 2007, 22:30
heinerlamprecht heinerlamprecht is offline
Member
 
Join Date: Apr 2007
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Default Can not access new mail

Hi all,

I've a new ISPConfig installation (on openSuSE 10.2) and created a domain and an email adress for this domain. I can send mails to that adress, but it is not possible to access the mail via POP3. According to the mail-log, the message has been received and delivered to the mailbox. I can also see the POP3-login, but I don't get the mail.

Any hints, what might goes wrong or where to look at?


Thanks,

Heiner
Reply With Quote
Sponsored Links
  #2  
Old 30th April 2007, 22:50
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 265
Thanked 151 Times in 131 Posts
Default

Did you maybe enable "Maildir" in ISPconfig?
If so, dissable and try again. (ISPconfig > Managment > Settings > Email)
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
  #3  
Old 1st May 2007, 08:43
mlz mlz is offline
Senior Member
 
Join Date: Dec 2006
Posts: 189
Thanks: 16
Thanked 9 Times in 9 Posts
Default

Do you have chroot enabled?
Reply With Quote
  #4  
Old 1st May 2007, 10:20
heinerlamprecht heinerlamprecht is offline
Member
 
Join Date: Apr 2007
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I did some more investigations. There also exist a "normal" shell user account, which I configured before creating the email adress. This user has the same local name ("heiner") as the email adress, and the mail is stored in his mailbox in /var/spool/mail. The user name of the email account is different, and this mailbox is still empty.

After that, I changed the email adress ("test@...), but than the mail is rejected: "User unknown in local recipient table".

@edge: I disabled Maildir-format, but it didn't changed anything. In general, I'd prefere Maildir, as it is more save. But are there any problems with ISPConfig when using this format?

@mlz: I'm not aware of having enabled chroot. How/where can I check this? And for which processes should it be configured?


Thanks,

Heiner
Reply With Quote
  #5  
Old 1st May 2007, 12:36
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,768
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

Quote:
@edge: I disabled Maildir-format, but it didn't changed anything. In general, I'd prefere Maildir, as it is more save. But are there any problems with ISPConfig when using this format?
No, it is the opposite You should use maildir with ISPConfig. But you must have a maildir capable pop3 / imap daemon installed. e.g. dovecot or courier.

Quote:
@mlz: I'm not aware of having enabled chroot. How/where can I check this? And for which processes should it be configured?
If you followed the perefct setup, you do not have a chroot capable SSH daemon, so chrooting must be disabled. This is the default, so you do not have to change anything.

- Which pop3 / imap daemon do you have installed?
- Did you follow the perfect setup guide?
- Is the email address listed in the postfix virtusertable file?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 1st May 2007, 12:55
heinerlamprecht heinerlamprecht is offline
Member
 
Join Date: Apr 2007
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
No, it is the opposite You should use maildir with ISPConfig. But you must have a maildir capable pop3 / imap daemon installed. e.g. dovecot or courier
Okay. I'm using courier.

Quote:
Originally Posted by till
- Which pop3 / imap daemon do you have installed?
- Did you follow the perfect setup guide?
- Is the email address listed in the postfix virtusertable file?
Yes, I followed the setup guide.

At the moment, the situation is as follows:
  • I have configured two domains, each with one email adress.
  • When sending an email to the virtual email adress ("test1@domain1.tld"), the mail is rejected due to "User unknown in local recipient table".
  • When sending to the "real" email adress ("web1_test1@domain1.tld"), the mail is accepted and stored locally, but only for the first configured domain. For the other domain, it is still rejected.
  • I can access the correct stored mail via POP3.

So, there seems to be something screwed up with the virtual adresses. The virtusertable looks okay. At least, I can't see a difference between the two sets of lines:

Code:
###################################
#
# ISPConfig virtusertable Configuration File
#         Version 1.0
#
###################################
test@www.heiner-lamprecht.eu    web1_test
web1_test@www.heiner-lamprecht.eu    web1_test
test@heiner-lamprecht.eu    web1_test
web1_test@heiner-lamprecht.eu    web1_test
hallo@www.heinerlamprecht.net    web2_hallo
web2_hallo@www.heinerlamprecht.net    web2_hallo
hallo@heinerlamprecht.net    web2_hallo
web2_hallo@heinerlamprecht.net    web2_hallo
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
Reply With Quote
  #7  
Old 1st May 2007, 13:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,768
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

The virtusertable is fine. As you use courier, the maildir checkbox in ISPConfig must be enabled. I guess that the virtusertable file is not part of your postfix configuration.

Do you have these two lines in your postfix main.cf:

virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names

The path to the virtusertable file might differ a bit, thy must match the actual location on your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 1st May 2007, 14:31
heinerlamprecht heinerlamprecht is offline
Member
 
Join Date: Apr 2007
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Do you have these two lines in your postfix main.cf:

virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names
Yes, I have them. But when I look at the output of "postconf -n", I do not see the entry for the virtual_maps. Now, I understand, why postfix ignores the new settings. But what am I supposed to do now?
Reply With Quote
  #9  
Old 1st May 2007, 15:00
heinerlamprecht heinerlamprecht is offline
Member
 
Join Date: Apr 2007
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I made a big step forward: First of all, I added a line in the main.cf for using virtual_alias_maps instead of virtual_maps. Secondly, I noticed a warning of postfix, when he is restarted by ISPConfig. He complains about a missing /etc/postfix/virtusertable.db file. But when I call

Code:
postmap virtusertable
afterwards, the mail gets through.

Is this problem known? Is there something to do against it? I cannot do this manually after each change and I don't want to make a cronjob for this.
Reply With Quote
  #10  
Old 2nd May 2007, 08:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,768
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
 
Default

There is no known problem with this in ISPConfig. ISPConfig calls the postmap script automatically avter every change in the virtusertable file.

Please have a look at the file /home/admispconfig/ispconfig/ispconfig.log for errors. Or another script on your server or another controlpanel like webmin has removed the virtusertable.db file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix reject connections gabrix Server Operation 27 25th January 2007 08:37
postfix-tls sasl2 mysql courier-authmysql gabrix Server Operation 4 12th January 2007 22:09
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 12:16
Questions in regards to ISP-Server Setup - Ubuntu 5.10 "Breezy Badger" rbrantley HOWTO-Related Questions 16 10th April 2006 18:26
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 11:47


All times are GMT +2. The time now is 09:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.