#1  
Old 3rd April 2007, 02:02
TinkerAllison TinkerAllison is offline
Junior Member
 
Join Date: Sep 2006
Posts: 14
Thanks: 6
Thanked 0 Times in 0 Posts
Unhappy Postfix relayhost issue

I have read as many post in these forums an on the internet as I can find. But I can't get past my relayhost issue. If I get the server to authenticate it times out. If I connect without timing out, it does not authenticate. This is my main.cf:

queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
mail_owner = postfix
inet_interfaces = all
unknown_local_recipient_reject_code = 550
relayhost = [outbound.mailhop.org]:2525
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
debug_peer_level = 2
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.3.3/samples
readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options =
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
broken_sasl_auth_client = yes
smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination, reject_invalid_hostname, reject_unauth_pipelining, reject_unauth_destination, reject_rbl_client relays.orbd.org, reject_rbl_client opm.blitzed.org, reject_rbl_client sbl.spamhaus.org, reject_rbl_client blackholes.easynet.nl, reject_rbl_client cbl.abuseat.org, permit

mynetworks = 192.168.1.0/28, 127.0.0.0/8
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
smtp_tls_session_cache_database = btree:/var/run/smtp_tls_session_cache
tls_random_source = dev:/dev/urandom
virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names

And my sasl_passwd looks like:

[outbound.mailhop.org]:2525 usernameassword

An suggestions would be greatly appreciated.


Last edited by TinkerAllison; 3rd April 2007 at 02:11.
Reply With Quote
Sponsored Links
  #2  
Old 3rd April 2007, 04:47
TinkerAllison TinkerAllison is offline
Junior Member
 
Join Date: Sep 2006
Posts: 14
Thanks: 6
Thanked 0 Times in 0 Posts
Default Installing A LAMP System With Fedora Core 6

I started with the "Installing A LAMP System With Fedora Core 6" Howto and installed ISPConfig after that. the relayhost issue is really the only known problem that I have left. If I can't get it fixed by Tuesday evening, I think I'll format and start over to see if I missed a major step a long the way.
Reply With Quote
  #3  
Old 3rd April 2007, 19:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Did you have a look here? http://www.howtoforge.com/postfix_re...her_mailserver
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
TinkerAllison (3rd April 2007)
  #4  
Old 3rd April 2007, 20:01
TinkerAllison TinkerAllison is offline
Junior Member
 
Join Date: Sep 2006
Posts: 14
Thanks: 6
Thanked 0 Times in 0 Posts
Default

yes, however this does not address the port issue. I've looked all over and I cann't find a specific refferance for the port information. Do you have a howto for the port change?
Reply With Quote
  #5  
Old 4th April 2007, 14:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
 
Default

I think this is your third thread dealing with this topic. I've answered in the other two threads.

Please don't double-post.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Issues with Postfix using "Virtual Users And Domains With Postfix, Courier And MySQL" Kyse HOWTO-Related Questions 15 6th January 2007 15:35
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36
Postfix Issue thetekgeek Server Operation 18 25th October 2006 16:44
Mail issue with Postfix + Amavis + Spamassassin mhxy594 Server Operation 3 21st August 2006 06:50


All times are GMT +2. The time now is 17:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.