Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 2nd April 2007, 06:02
catalyst catalyst is offline
Member
 
Join Date: Mar 2007
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Have you tried something like this too?

mkdir("test");
chmod("test", 0755);

Yes!
If mkdir("test") and chmod("test", 0755), the final permission will be 0755.

Why can't use mkdir("test", 0755) directly?
How and where can I change the default permission of mkdir() & imagejpeg()?
Thank you!
Reply With Quote
Sponsored Links
  #12  
Old 2nd April 2007, 06:47
catalyst catalyst is offline
Member
 
Join Date: Mar 2007
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I find out where to set the default permission when using mkdir() & imagejepg()

just vi /etc/suphp.conf
modify :
umask=0077

to
umask=0022

Then the mkdir() will create a folder with 0755
Reply With Quote
  #13  
Old 2nd April 2007, 06:53
catalyst catalyst is offline
Member
 
Join Date: Mar 2007
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Default

But there is another problem.
If I set chmod 0777 to a php script, I will get the following error.

500 error - Internal Server Error!

I need to set it back to 0755 to avoid this error.

Besides, can I modify the suphp.conf to avoid this error?
If yes, where should I modify it?

Thanks!

Last edited by catalyst; 2nd April 2007 at 21:24.
Reply With Quote
  #14  
Old 2nd April 2007, 07:01
catalyst catalyst is offline
Member
 
Join Date: Mar 2007
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by catalyst
But there is another problem.
If I set chmod 0777 to a php script, I will get the following error.

500 error - Internal Server Error!

I need to set it back to 0755 to avoid this error.

Besides, can I modify the suphp.conf to avoid this error?
If yes, where should I modify it?

Thanks!
I find it now :
Modify the Security Options :

allow_file_group_writeable = true
allow_file_group_others_writeable = ture
allow_directory_group_writeable = true
allow_directory_others_writeable = true

where _file_ is the security option of a file and _directory_ is the security option of a directory.

Last edited by catalyst; 2nd April 2007 at 21:23.
Reply With Quote
  #15  
Old 7th March 2010, 01:16
ethanlifka ethanlifka is offline
Junior Member
 
Join Date: Aug 2008
Posts: 29
Thanks: 0
Thanked 6 Times in 4 Posts
 
Default

Also See http://www.howtoforge.com/forums/sho...273#post221273

Hope this helps others.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Chroot SSH + ISPConfig Norman Installation/Configuration 27 26th March 2007 03:40
Dspam planet_fox General 6 20th January 2007 18:42
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 05:19
jamed up my table borders?? Boon-Dog-Danny Installation/Configuration 5 23rd September 2006 16:12


All times are GMT +2. The time now is 00:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.