Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th February 2010, 22:35
poisen poisen is offline
Member
 
Join Date: Jan 2007
Location: Chiemsee, Germany
Posts: 56
Thanks: 10
Thanked 1 Time in 1 Post
Send a message via Skype™ to poisen
Question ispconfig2 and webdav

Hey everybody,

I got a problem. I've been reading a lot about using webdav with ispconfig2, now I just setup a new web called "data.xyz.com" and tried making a connection to it. FTP is NOT enabled, I want to use the webdav to mount a network share and use it as some swap space for some of my files. Sadly, whatever I do, I just cannot get a connection to it. What am I doing wrong or is there anything else I have to watch out for? My user is Admin and webdav is for the user enabled.

I'd be happy to get some help.
Reply With Quote
Sponsored Links
  #2  
Old 26th February 2010, 09:18
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 525
Thanks: 10
Thanked 172 Times in 77 Posts
Default

1. Enable webdav for this site
2. Create a user and allow him to do webdav (by checking the webdav box)
3. connect by www.example.com/webdav

That should do it.
Reply With Quote
  #3  
Old 26th February 2010, 10:52
poisen poisen is offline
Member
 
Join Date: Jan 2007
Location: Chiemsee, Germany
Posts: 56
Thanks: 10
Thanked 1 Time in 1 Post
Send a message via Skype™ to poisen
Default

This is what I've been trying already like 1000 times and it doesn't work, when I enter www.example.com/webdav in the browser, I get a 404 error. When I try setting up a network drive in windows it keeps prompting me to enter a password.
Reply With Quote
  #4  
Old 26th February 2010, 11:06
poisen poisen is offline
Member
 
Join Date: Jan 2007
Location: Chiemsee, Germany
Posts: 56
Thanks: 10
Thanked 1 Time in 1 Post
Send a message via Skype™ to poisen
Default

I just tried using Webdrive to setup a connection, this is the error I got:

Connecting to site example.com
Connecting to example.com/webdav
Resolving url example.com to an IP address
Url resolved to IP address 12.12.12.12
Connecting to 12.12.12.12 on port 80
Connected successfully to the server on port 80
Testing directory listing ...

Unable to connect to server, error information below

Error: HTTP Error response received from server, erorr=405 (4516)
Operation: Connecting to server
Server Response: 405 Method Not Allowed
Reply With Quote
  #5  
Old 26th February 2010, 11:10
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 525
Thanks: 10
Thanked 172 Times in 77 Posts
Default

What is in your apache error logs?
Reply With Quote
  #6  
Old 26th February 2010, 11:20
poisen poisen is offline
Member
 
Join Date: Jan 2007
Location: Chiemsee, Germany
Posts: 56
Thanks: 10
Thanked 1 Time in 1 Post
Send a message via Skype™ to poisen
Default

[Fri Feb 26 11:19:32 2010] [error] [client 127.0.0.1] Directory index forbidden by Options directive: /srv/www/htdocs/
[Fri Feb 26 11:19:40 2010] [error] an unknown filter was not added: PHP

Those are errors that are from some other misconfiguration which I've just resolved ... otherwise there are no errors in the apache error_log when I am trying to connect using webdav and the connection fails.

Last edited by poisen; 26th February 2010 at 11:38. Reason: more info
Reply With Quote
  #7  
Old 1st March 2010, 09:15
poisen poisen is offline
Member
 
Join Date: Jan 2007
Location: Chiemsee, Germany
Posts: 56
Thanks: 10
Thanked 1 Time in 1 Post
Send a message via Skype™ to poisen
Unhappy

I've been trying many many times now to set up WebDAV Support in ISPConfig 2.2.35 but it just doesn't work.

This is part of the Apache access_log when I'm trying to connect through MacOSX
Quote:
95.90.xxx.xxx - - [01/Mar/2010:17:43:32 +0100] "OPTIONS /webdav HTTP/1.1" 200 - "-" "WebDAVLib/1.1"
95.90.xxx.xxx - - [01/Mar/2010:17:43:44 +0100] "OPTIONS /webdav HTTP/1.1" 200 - "-" "WebDAVLib/1.1"
95.90.xxx.xxx - - [01/Mar/2010:17:43:44 +0100] "OPTIONS /webdav/ HTTP/1.1" 200 - "-" "WebDAVFS/1.8 (01808000) Darwin/10.2.0 (i386)"
This is what comes up in the apache access_log when trying to connect with TeamDrive
Quote:
95.90.xxx.xxx - - [01/Mar/2010:18:02:15 +0100] "PROPFIND /webdav/WebDAVKompatibilitaetstest/ HTTP/1.1" 405 1210 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)"
95.90.xxx.xxx - - [01/Mar/2010:18:02:22 +0100] "DELETE /webdav/WebDAVKompatibilitaetstest/ HTTP/1.1" 405 1210 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)"
95.90.xxx.xxx - - [01/Mar/2010:18:02:23 +0100] "DELETE /webdav/WebDAVTestDatei HTTP/1.1" 405 1210 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)"
95.90.xxx.xxx - - [01/Mar/2010:18:02:24 +0100] "DELETE /webdav/WebDAVTestDatei_Ziel HTTP/1.1" 405 1210 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)"
95.90.xxx.xxx - - [01/Mar/2010:18:02:26 +0100] "DELETE /webdav/WebDAVTestDatei_Verschoben HTTP/1.1" 405 1210 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)"
95.90.xxx.xxx - - [01/Mar/2010:18:02:27 +0100] "PROPFIND /webdav/einkomplizierterlangername/ HTTP/1.1" 405 1210 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)"
95.90.xxx.xxx - - [01/Mar/2010:18:02:28 +0100] "MKCOL /webdav/WebDAVKompatibilitaetstest/ HTTP/1.1" 405 1210 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)"
95.90.xxx.xxx - - [01/Mar/2010:18:02:29 +0100] "PROPFIND /webdav/WebDAVKompatibilitaetstest/ HTTP/1.1" 405 1210 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)"
WebDav is activated for the reseller, this is the part out of the Vhosts_ispconfig.conf
Quote:
<VirtualHost 85.214.xxx.xxx:80>
ServerName data.example.de:80
ServerAdmin webmaster@example.de
DocumentRoot /srv/www/web102/web
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ErrorLog /srv/www/web102/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
php_admin_flag safe_mode Off
Alias /stats "/srv/www/web102/web/webalizer"
Alias /error/ "/srv/www/web102/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /srv/www/web102/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /srv/www/web102/user/$1/web/$3
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
RewriteRule .* - [F]
</IfModule>
<IfModule mod_dav.c>
Alias /webdav /srv/www/web102/web
<Location /webdav>
DAV On
AuthType Basic
AuthName "webdav"
AuthUserFile /srv/www/web102/passwd.dav
Require valid-user
</Location>
</IfModule>
</VirtualHost>
Can anybody else help me on this problem? It would be very very important for me to have this feature working.

Thanks a lot,

Eddie

Last edited by poisen; 1st March 2010 at 18:07. Reason: access_log data added, vhost config added
Reply With Quote
  #8  
Old 2nd March 2010, 16:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Try www.example.com:80/webdav when you connect from Windows (see http://www.howtoforge.com/how-to-set...ubuntu-9.10-p2 ).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 2nd March 2010, 16:44
poisen poisen is offline
Member
 
Join Date: Jan 2007
Location: Chiemsee, Germany
Posts: 56
Thanks: 10
Thanked 1 Time in 1 Post
Send a message via Skype™ to poisen
Default

Hi falko,

with entering the port in windows I get the error message that the entered folder is invalid and I should select a different folder.

:-(

The URL is entered correct, double checked that.


Quote:
Originally Posted by falko View Post
Try www.example.com:80/webdav when you connect from Windows (see http://www.howtoforge.com/how-to-set...ubuntu-9.10-p2 ).
Reply With Quote
  #10  
Old 3rd March 2010, 14:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

Are there any errors in the error log of that web site (in the /srv/www/web102/log folder)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WebDAV on an ISPConfig2 server Hans Tips/Tricks/Mods 0 27th December 2008 17:02


All times are GMT +2. The time now is 21:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.