Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 31st March 2007, 01:50
squirrel squirrel is offline
Junior Member
 
Join Date: Mar 2007
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Help - can't login to Postfix/Courier server (Ubuntu)

Hello - I have set up a mail server on my Ubuntu machine using the tutorial here on howtoforge. I have spent several long nights troubleshooting a problem and am wits end. Description:

I have a MySQL database that stores the username, password (encrypted) and a couple other attributes. DB is named 'mail'. Courier is set to authenticate against this database in it's "authdaemonrc" file and the details in "authmysqlrc" are accurate.

POP3 is responding properly when i do this:
Code:
telnet localhost pop3
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
+OK Hello there.
quit
+OK Better luck next time.
Connection closed by foreign host.
The mail server appears to listening properly and the right ports are open (for both SSL and non-SSL). This has been confirmed by running the mail server check at dnsreports.com.

Using Thunderbird on my laptop - if I create a POP3 account and try to connect to the mail server I get a password error both using SSL or not. Thunderbird error is:
Code:
Sending of password did not succeed. Mail server ******** responded: Temporary problem, please try again later.
Thunderbird is connecting and downloading the certificate and trying to login, but is failing there.

There is obviously a problem somewhere as I can't even get the IMAP server to respond. I've restarted all the applicable applications and the machine itself and checked and re-checked the config files multiple times.

I'm not a total noob to linux but am new to mail servers in general and these apps in specific.

Anyone have ideas where I should start digging to isolate the problem - I'm at a bit of a loss.

thanks,
squirrel

EDIT: Ok some log digging seems to indicate that Courier can't login to MySQL so obviously can't process the email account logins. It's got the correct user and password for the Database - any thoughts on where I should look for a cause?

Last edited by squirrel; 31st March 2007 at 03:21.
Reply With Quote
Sponsored Links
  #2  
Old 31st March 2007, 15:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
 
Default

Quote:
Originally Posted by squirrel
Hello - I have set up a mail server on my Ubuntu machine using the tutorial here on howtoforge. I have spent several long nights troubleshooting a problem and am wits end.
Wrong tutorial. This one is the right one for Ubuntu: http://www.howtoforge.com/virtual_po...er_ubuntu_edgy
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
php Apps email not going through palkat General 8 21st September 2011 06:35
Statistic not working mzo Installation/Configuration 49 20th April 2011 13:19
VMWare Server Howto and Ubuntu Questions crudolphy HOWTO-Related Questions 11 25th July 2006 21:11
Email - Ueb-Miau mazhar Installation/Configuration 5 21st December 2005 11:01
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 03:30


All times are GMT +2. The time now is 10:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.