#1  
Old 5th April 2007, 21:07
me2resh me2resh is offline
Junior Member
 
Join Date: Apr 2007
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix problem on ispconfig

Hi
i installed ispconfig on Centos 4
i followed the perfect setup tutorial here
after installation everything is working smoothly except the mail.
i cant send or recieve mails

when i send mails from webmail i get this message

It was not possible to send this e-mail

SMTP Error: Recipient not accepted. Verify your relay rules

Back

and i cant use outlook.
and when i send mail to myself, i still find my inbox empty

can anyone help me through this please ?
Reply With Quote
Sponsored Links
  #2  
Old 5th April 2007, 22:05
HeftiSchlumpf HeftiSchlumpf is offline
Junior Member
 
Join Date: Apr 2007
Posts: 19
Thanks: 4
Thanked 0 Times in 0 Posts
Unhappy Same Problem Here!

Dude. I have exactly the same problem.

At the Beginning it worked, but i had a problem with TLS-stuff. I wasnt able to send Emails.

No i cant receive them anymore too.
I also checked other topics about "Relay access denied"
A solution could be to verify that you have added a Co-domain correctly.
That means:
Code:
/etc/postfix/virtualusertable
has both:
Code:
user@domain.com      user
and!
user@www.domain.com      user


I already have this, but it still not works. So please, Falko, or anyone who knows the way out of this mess, help me.


I am using Ubuntu 6.06 with the perfect Howto.

this is my main.cf:

Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = myserver.mydomain.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = myserver.mydomain.com, localhost.mydomain.com, localhost
relayhost =
mynetworks = 127.0.0.0/8
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
mailbox_command =
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/
master.cf
Code:
#
# Postfix master process configuration file.  For details on the format
# of the file, see the Postfix master(5) manual page.
#
# ==========================================================================
# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (yes)   (never) (100)
# ==========================================================================
smtp      inet  n       -       -       -       -       smtpd
#submission inet n      -       -       -       -       smtpd
#       -o smtpd_etrn_restrictions=reject
#       -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#smtps    inet  n       -       -       -       -       smtpd
#  -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
#submission inet n      -       -       -       -       smtpd
#  -o smtpd_etrn_restrictions=reject
#  -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes
#628      inet  n       -       -       -       -       qmqpd
pickup    fifo  n       -       -       60      1       pickup
cleanup   unix  n       -       -       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
#qmgr     fifo  n       -       -       300     1       oqmgr
tlsmgr    unix  -       -       -       1000?   1       tlsmgr
rewrite   unix  -       -       -       -       -       trivial-rewrite
bounce    unix  -       -       -       -       0       bounce
defer     unix  -       -       -       -       0       bounce
trace     unix  -       -       -       -       0       bounce
verify    unix  -       -       -       -       1       verify
flush     unix  n       -       -       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
smtp      unix  -       -       -       -       -       smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay     unix  -       -       -       -       -       smtp
        -o fallback_relay=
#       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq     unix  n       -       -       -       -       showq
error     unix  -       -       -       -       -       error
discard   unix  -       -       -       -       -       discard
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       -       -       -       lmtp
anvil     unix  -       -       -       -       1       anvil
scache    unix  -       -       -       -       1       scache
#
# ====================================================================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# Many of the following services use the Postfix pipe(8) delivery
# agent.  See the pipe(8) man page for information about ${recipient}
# and other message envelope options.
# ====================================================================
#
# maildrop. See the Postfix MAILDROP_README file for details.
# Also specify in main.cf: maildrop_destination_recipient_limit=1
#
maildrop  unix  -       n       n       -       -       pipe
  flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
#
# See the Postfix UUCP_README file for configuration details.
#
uucp      unix  -       n       n       -       -       pipe
  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
#
# Other external delivery methods.
#
ifmail    unix  -       n       n       -       -       pipe
  flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp     unix  -       n       n       -       -       pipe
  flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
scalemail-backend unix  -       n       n       -       2       pipe
  flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
mailman   unix  -       n       n       -       -       pipe
  flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
  ${nexthop} ${user}
my virtualusertable has both adresses (with www and without)

Please help me! THX ALOT!
Reply With Quote
  #3  
Old 6th April 2007, 11:46
HeftiSchlumpf HeftiSchlumpf is offline
Junior Member
 
Join Date: Apr 2007
Posts: 19
Thanks: 4
Thanked 0 Times in 0 Posts
Default Finally!

Today at 3:00 in the morning i got it working like a charm.

I was just missing the lines in main.cf for adding virtualusertable and domains.
This occured by confused-version-renaming by myself of main.cf...
sofar it works now.
Reply With Quote
  #4  
Old 6th April 2007, 17:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Quote:
Originally Posted by HeftiSchlumpf
Dude. I have exactly the same problem.

At the Beginning it worked, but i had a problem with TLS-stuff. I wasnt able to send Emails.

No i cant receive them anymore too.
I also checked other topics about "Relay access denied"
A solution could be to verify that you have added a Co-domain correctly.
That means:
Code:
/etc/postfix/virtualusertable
has both:
Code:
user@domain.com      user
and!
user@www.domain.com      user


I already have this, but it still not works. So please, Falko, or anyone who knows the way out of this mess, help me.


I am using Ubuntu 6.06 with the perfect Howto.

this is my main.cf:

Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = myserver.mydomain.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = myserver.mydomain.com, localhost.mydomain.com, localhost
relayhost =
mynetworks = 127.0.0.0/8
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
mailbox_command =
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/
master.cf
Code:
#
# Postfix master process configuration file.  For details on the format
# of the file, see the Postfix master(5) manual page.
#
# ==========================================================================
# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (yes)   (never) (100)
# ==========================================================================
smtp      inet  n       -       -       -       -       smtpd
#submission inet n      -       -       -       -       smtpd
#       -o smtpd_etrn_restrictions=reject
#       -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#smtps    inet  n       -       -       -       -       smtpd
#  -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
#submission inet n      -       -       -       -       smtpd
#  -o smtpd_etrn_restrictions=reject
#  -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes
#628      inet  n       -       -       -       -       qmqpd
pickup    fifo  n       -       -       60      1       pickup
cleanup   unix  n       -       -       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
#qmgr     fifo  n       -       -       300     1       oqmgr
tlsmgr    unix  -       -       -       1000?   1       tlsmgr
rewrite   unix  -       -       -       -       -       trivial-rewrite
bounce    unix  -       -       -       -       0       bounce
defer     unix  -       -       -       -       0       bounce
trace     unix  -       -       -       -       0       bounce
verify    unix  -       -       -       -       1       verify
flush     unix  n       -       -       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
smtp      unix  -       -       -       -       -       smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay     unix  -       -       -       -       -       smtp
        -o fallback_relay=
#       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq     unix  n       -       -       -       -       showq
error     unix  -       -       -       -       -       error
discard   unix  -       -       -       -       -       discard
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       -       -       -       lmtp
anvil     unix  -       -       -       -       1       anvil
scache    unix  -       -       -       -       1       scache
#
# ====================================================================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# Many of the following services use the Postfix pipe(8) delivery
# agent.  See the pipe(8) man page for information about ${recipient}
# and other message envelope options.
# ====================================================================
#
# maildrop. See the Postfix MAILDROP_README file for details.
# Also specify in main.cf: maildrop_destination_recipient_limit=1
#
maildrop  unix  -       n       n       -       -       pipe
  flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
#
# See the Postfix UUCP_README file for configuration details.
#
uucp      unix  -       n       n       -       -       pipe
  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
#
# Other external delivery methods.
#
ifmail    unix  -       n       n       -       -       pipe
  flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp     unix  -       n       n       -       -       pipe
  flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
scalemail-backend unix  -       n       n       -       2       pipe
  flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
mailman   unix  -       n       n       -       -       pipe
  flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
  ${nexthop} ${user}
my virtualusertable has both adresses (with www and without)

Please help me! THX ALOT!
Do you use ISPConfig? If so, run
Code:
postconf -e 'virtual_maps = hash:/etc/postfix/virtusertable'
postconf -e 'mydestination = /etc/postfix/local-host-names'
/etc/init.d/postfix restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 6th April 2007, 18:07
HeftiSchlumpf HeftiSchlumpf is offline
Junior Member
 
Join Date: Apr 2007
Posts: 19
Thanks: 4
Thanked 0 Times in 0 Posts
Default

thats correct, i already did that.

any idea,why my apache2 does not reload/restart after a new site is added ?
cause there is a page telling about shared ip.
i always have to restart it by myself using apache2ctl restart
Reply With Quote
  #6  
Old 7th April 2007, 15:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Quote:
Originally Posted by HeftiSchlumpf
thats correct, i already did that.
And does it work now?
Quote:
Originally Posted by HeftiSchlumpf
any idea,why my apache2 does not reload/restart after a new site is added ?
cause there is a page telling about shared ip.
i always have to restart it by myself using apache2ctl restart
Go to the directory where Vhosts_ispconfig.conf is located. Are there other Vhosts_ispconfig.conf files that have a date appended to the file name? If so, your Apache is missing a module.
Any errors in /home/admispconfig/ispconfig/ispconfig.log? What's the output of
Code:
ls -la /root/ispconfig
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 10th April 2007, 11:58
HeftiSchlumpf HeftiSchlumpf is offline
Junior Member
 
Join Date: Apr 2007
Posts: 19
Thanks: 4
Thanked 0 Times in 0 Posts
Default Thx for your help.

2 Posts above i already said, that it works with the way you explained.

So this post is just about the apache2 restart thingy.



Quote:
root@hostname123:~# cd /etc/apache2/vhosts/Vhosts_ispconfig.conf
Vhosts_ispconfig.conf Vhosts_ispconfig.conf~
root@hostname123:~# ls -la /root/ispconfig
insgesamt 100
drwxr-xr-x 9 root root 4096 2007-04-06 13:32 .
drwxr-xr-x 21 root root 4096 2007-04-06 12:07 ..
-rwxr-xr-x 1 root root 33482 2007-04-05 16:35 cronolog
-rwxr-xr-x 1 root root 9673 2007-04-05 16:35 cronosplit
drwxr-xr-x 12 root root 4096 2007-04-05 16:21 httpd
drwxr-xr-x 14 root root 4096 2007-04-05 16:35 isp
-rw-r--r-- 1 root root 8 2007-04-06 13:32 .old_path_httpd_root
drwxr-xr-x 6 root root 4096 2007-04-05 15:52 openssl
drwxr-xr-x 6 root root 4096 2007-04-05 16:30 php
drwxr-xr-x 4 root root 4096 2007-04-05 16:35 scripts
drwxr-xr-x 4 root root 4096 2007-04-05 16:35 standard_cgis
drwxr-xr-x 2 root root 4096 2007-04-05 16:35 sv
-rwx------ 1 root root 9389 2007-04-05 16:35 uninstall
root@hostname123:~#
Und in der Log stehen nur Infos
Reply With Quote
  #8  
Old 11th April 2007, 16:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

What's the output of
Code:
ls -la /etc/apache2/vhosts
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 11th April 2007, 23:11
HeftiSchlumpf HeftiSchlumpf is offline
Junior Member
 
Join Date: Apr 2007
Posts: 19
Thanks: 4
Thanked 0 Times in 0 Posts
Default

The output is:
Quote:
drwxr-xr-x 2 root root 4096 2007-04-05 16:51 .
drwxr-xr-x 9 root root 4096 2007-04-06 02:15 ..
-rw-r--r-- 1 root root 4524 2007-04-11 19:15 Vhosts_ispconfig.conf
-rw-r--r-- 1 root root 4524 2007-04-11 19:15 Vhosts_ispconfig.conf~
Reply With Quote
  #10  
Old 12th April 2007, 18:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
 
Default

Looks ok.
Any errors in Apache's error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPconfig after installation cannot reach www.xyz.de:81 Figth4Linux Installation/Configuration 23 6th March 2008 23:38
ISPConfig Problem weslkers Installation/Configuration 3 20th May 2007 14:00
ISPConfig with postfix problem Chrisssssss General 30 21st January 2007 00:34
email/ftp problem after moving ispconfig mystix Installation/Configuration 3 14th September 2006 20:41
Postfix problem : read timeout DarkBen General 14 21st April 2006 13:39


All times are GMT +2. The time now is 10:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.