Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 21st November 2005, 14:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by Tenaka
g I am unsure about is this:lets say I do not use a dedicated NS instead I just let my webserver be a NS too, can I just use the servername like hxxxx.serverkompetenz.net (which resolves to my IP) instead of the usual naming convention aka ns.myserver.com ?
Yes, should be ok.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #12  
Old 25th November 2005, 11:37
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,259
Thanks: 76
Thanked 23 Times in 19 Posts
Default

I tried to test the DNS records of one of the domains I am offering NS for locally on my server at: http://www.dnsreport.com/
and it reported this error:

Quote:
ERROR: One or more of the NS records that your nameservers report are invalid:
81.169.163.106. is not a valid host name (it must be a host name, not an IP address)
81.169.163.104. is not a valid host name (it must be a host name, not an IP address)
when registering the domain I gave my hostname and IP as NS, which is ok so far, the above IPs are the nameservers I have set in the /etc/resolve.conf (I think this is the file where the nameservers for my server are listed...) should I enter their names there instead of the IPs?
Reply With Quote
  #13  
Old 25th November 2005, 12:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

81.169.163.106 and 81.169.163.104 are Strato name servers! When you register the domain, you have to set your own name servers as authoritative name servers for the domain!
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #14  
Old 25th November 2005, 12:21
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,259
Thanks: 76
Thanked 23 Times in 19 Posts
Default

I did that.
I set up hxxxx.serverkompetenz.net (my servername) as the authoritative NS for my domain. Still when doing the test I get the above error, the domain I am talking about is zice.ro (test it here: h**p://w*w.dnsreport.com/tools/dnsreport.ch?domain=zice.ro )
Reply With Quote
  #15  
Old 25th November 2005, 12:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

I did a
Code:
dig zice.ro
.
This doesn't look ok:
Code:
;; AUTHORITY SECTION:
zice.ro.                10800   IN      NS      zice.ro.
It's the hen <-> egg problem.

Please post your zone file. Under Debian it must be something like /etc/bind/pri.zice.ro.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #16  
Old 25th November 2005, 13:06
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,259
Thanks: 76
Thanked 23 Times in 19 Posts
Default

$TTL 86400
@ IN SOA 81.169.163.104. admin.zice.ro. (
2005112301 ; serial, todays date + todays serial #
28800 ; refresh, seconds
7200 ; retry, seconds
604800 ; expire, seconds
86400 ) ; minimum, seconds
;
NS 81.169.163.104. ; Inet Address of name server 1
NS 81.169.163.106. ; Inet Address of name server 2
;

MX 10 mail.

zice.ro. A 81.169.176.18
www A 81.169.176.18
mail A 81.169.176.18

;;;; MAKE MANUAL ENTRIES BELOW THIS LINE! ;;;;
Reply With Quote
  #17  
Old 25th November 2005, 17:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by Tenaka
$TTL 86400
@ IN SOA 81.169.163.104. admin.zice.ro. (
2005112301 ; serial, todays date + todays serial #
28800 ; refresh, seconds
7200 ; retry, seconds
604800 ; expire, seconds
86400 ) ; minimum, seconds
;
NS 81.169.163.104. ; Inet Address of name server 1
NS 81.169.163.106. ; Inet Address of name server 2
;

MX 10 mail.

zice.ro. A 81.169.176.18
www A 81.169.176.18
mail A 81.169.176.18

;;;; MAKE MANUAL ENTRIES BELOW THIS LINE! ;;;;
You have put the Strato name servers into that file instead of your hxxx.serverkompetenz.net server. Try to change that.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #18  
Old 25th November 2005, 19:26
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,259
Thanks: 76
Thanked 23 Times in 19 Posts
Default

sorry I don't understand that. I Have the strato NS inside its the ...104 and ...106 IPs, my hxxxx.serverkompetenz.net is nowhere inside this file as you can see.

except here, but its ok here as I have understood:
zice.ro. A 81.169.176.18
www A 81.169.176.18
mail A 81.169.176.18

You just left me with a big questionmark on my face???
Reply With Quote
  #19  
Old 26th November 2005, 17:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Your file should look like this:

Code:
$TTL 86400
@ IN SOA hxxx.serverkompetenz.net. admin.zice.ro. (
2005112301 ; serial, todays date + todays serial #
28800 ; refresh, seconds
7200 ; retry, seconds
604800 ; expire, seconds
86400 ) ; minimum, seconds
;
NS hxxx.serverkompetenz.net. ; Inet Address of name server 1
NS hxxx.serverkompetenz.net. ; Inet Address of name server 2
;

MX 10 mail.

zice.ro. A 81.169.176.18
www A 81.169.176.18
mail A 81.169.176.18

;;;; MAKE MANUAL ENTRIES BELOW THIS LINE! ;;;;
So somewhere in your ISPConfig settings you have entered the IP addresses of Strato's name servers instead of hxxx.serverkompetenz.net.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #20  
Old 26th November 2005, 22:36
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,259
Thanks: 76
Thanked 23 Times in 19 Posts
 
Default

*doh*
I was stupid ;-) got it working now, thx
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 09:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.