#1  
Old 7th November 2005, 10:11
phantomk phantomk is offline
Junior Member
 
Join Date: Nov 2005
Posts: 25
Thanks: 0
Thanked 1 Time in 1 Post
Default SSL with SMTP

I am trying to figure out why SSL is not working for my setup when I try to send email via a 3rd party application, such as Thunderbird. TLS and regular smtp through port 25 work perfectly, but whenever I try to use SSL on port 465, the port is open, I get a smtp server connection error.

I have used the Perfect Debian Sarge howto found in the howto directory, great howto by the way Any help is apprecieated in this puzzleing problem :S

Confused as can be,
PK
Reply With Quote
Sponsored Links
  #2  
Old 7th November 2005, 10:51
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,037
Thanks: 841
Thanked 5,659 Times in 4,466 Posts
Default

Plaese have a look at the mail log. (/var/log/mail.log) if you get any errors there when you connect on port 465.
Reply With Quote
  #3  
Old 7th November 2005, 19:48
phantomk phantomk is offline
Junior Member
 
Join Date: Nov 2005
Posts: 25
Thanks: 0
Thanked 1 Time in 1 Post
Default

Nothing appears inside any of the mail logs when I try to connect :S Odd, you think something might appear...

I checked:
/var/log/mail.err
/var/log/mail.info
/var/log/mail.log
/var/log/mail.warn

On a side note, how would I regenerate the SSL certificates to change the owner from "localhost" to "mail.my_domain.com" ?
Reply With Quote
  #4  
Old 8th November 2005, 10:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Quote:
Originally Posted by phantomk
Nothing appears inside any of the mail logs when I try to connect :S Odd, you think something might appear...

I checked:
/var/log/mail.err
/var/log/mail.info
/var/log/mail.log
/var/log/mail.warn
Is it maybe your firewall that blocks accesses to port 465?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 8th November 2005, 15:00
phantomk phantomk is offline
Junior Member
 
Join Date: Nov 2005
Posts: 25
Thanks: 0
Thanked 1 Time in 1 Post
Default

I made sure that the port is open, it was blocked the first time I tried it, but it turned out not to be the issue :S

Here is the result of "netstat -tap"
Quote:
Originally Posted by netstat -tap
debian:~# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:imaps *:* LISTEN 5942/couriertcpd
tcp 0 0 *:pop3s *:* LISTEN 5857/couriertcpd
tcp 0 0 localhost.localdo:10024 *:* LISTEN 4210/amavisd (maste
tcp 0 0 localhost.localdo:10025 *:* LISTEN 4320/master
tcp 0 0 localhost.localdo:mysql *:* LISTEN 2609/mysqld
tcp 0 0 *:pop3 *:* LISTEN 5800/couriertcpd
tcp 0 0 *:imap2 *:* LISTEN 5893/couriertcpd
tcp 0 0 *:www *:* LISTEN 6263/apache2
tcp 0 0 *:8181 *:* LISTEN 6263/apache2
tcp 0 0 mail.*******.com:domain *:* LISTEN 4873/named
tcp 0 0 debian.*******.c:domain *:* LISTEN 4873/named
tcp 0 0 localhost.locald:domain *:* LISTEN 4873/named
tcp 0 0 *:ssh *:* LISTEN 707/sshd
tcp 0 0 *:smtp *:* LISTEN 4320/master
tcp 0 0 localhost.localdoma:953 *:* LISTEN 4873/named
tcp 0 0 *:https *:* LISTEN 6263/apache2
tcp 0 300 debian.*******.com:ssh ***.***>**.**:4584 ESTABLISHED 24974/sshd
tcp 0 0 debian.*******.com:ssh ***.***>**.**:4585 ESTABLISHED 24978/sshd
Reply With Quote
  #6  
Old 8th November 2005, 16:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

There's nothing running on port 465...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 8th November 2005, 18:13
phantomk phantomk is offline
Junior Member
 
Join Date: Nov 2005
Posts: 25
Thanks: 0
Thanked 1 Time in 1 Post
Default

I thought The Perfect Setup - Debian Sarge (3.1) guide also setup a ssl smtp connection ?

How would I go about setting up a SSL connection for smtp ? Also how would I go about changeing the certificate owner, currently it reads:
Quote:
You have attempted to establish a connection with "mail.*****.com". However, the security certificate presented belonts to "localhost". etc ....
When I retrieve my e-mail through a pop3 or imap SSL connection.
Reply With Quote
  #8  
Old 8th November 2005, 20:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Quote:
Originally Posted by phantomk
I thought The Perfect Setup - Debian Sarge (3.1) guide also setup a ssl smtp connection ?
No, it's a TLS connection that uses port 25.

Quote:
Originally Posted by phantomk
How would I go about setting up a SSL connection for smtp ?
You can use TLS by telling your email client to use a secure connection.

Quote:
Originally Posted by phantomk
Also how would I go about changeing the certificate owner, currently it reads:

When I retrieve my e-mail through a pop3 or imap SSL connection.
To create other TLS certificates, simply re-run the steps from the tutorial.
To create new POP3/IMAP certificates, have a look here: http://www.howtoforge.com/forums/showthread.php?t=1168
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 8th November 2005, 22:52
phantomk phantomk is offline
Junior Member
 
Join Date: Nov 2005
Posts: 25
Thanks: 0
Thanked 1 Time in 1 Post
Default

Thanks The post you pointed me too solved the certificate problem

I thought TLS was less secure :S That's why I was asking about the SSL connection.
Reply With Quote
  #10  
Old 8th November 2005, 23:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
 
Default

Quote:
Originally Posted by phantomk
I thought TLS was less secure :S That's why I was asking about the SSL connection.
No, TLS is secure.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Relay access denied when using SMTP to external recipients Kamran Shah Installation/Configuration 111 14th May 2014 19:10
SMTP Auth problem maxx General 12 1st February 2006 03:48
Mail problems chrisesler Installation/Configuration 12 28th October 2005 18:56
Postfix SMTP Auth Configuration kisong Installation/Configuration 6 20th October 2005 02:06
smtp error misterm Installation/Configuration 2 29th September 2005 00:21


All times are GMT +2. The time now is 00:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.