Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th March 2007, 14:47
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,266
Thanks: 82
Thanked 24 Times in 20 Posts
Default how to verify if mails got sent?

hello,


I have a customer who has a very large member database. around 3000 ppl.
he tried to send a newsletter yesterday and it seems none of the mails arrived.

the tool he uses to send sends via sendmail comandline. it sends in batches of 100 and as he sends to his own address and the others as bcc he got 30 copies of his own mail, which indicates to me his mails got sent successull, yet none of the ppl. he asked about this received the newsletter. not even in their spam folders.

I had a look at my stats tools and neither the mailqueue graphs nor the requests graphs show anything abnormal. mailgraph did not show anything about a lot of mails being sent.
nothing interesting inside the mail logs, I did not get any warning mails, just nothing.

I am running debian 3.1 set up like the perfect debian sarge setup from howtoforge.com

what else can I check to ensure the problem is not serverside but rather on the clients side or maybe even on the recepients side?

10 minutes after he sent the newletter I checked with the mailq command and it showed me the queue was empty.
I was expecting to see a lot of entried there as I am sure he needs to "clean-up" his database, as last time I remember him sending out a newsletter there were a lot of dead addresses, but last time he sent with another tool.

I am open for any suggestions
Reply With Quote
Sponsored Links
  #2  
Old 26th March 2007, 16:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Are you sure your customer used your server for sending? Do you see anything in the mail log around the time he sent his newsletter?
Have you checked if your server is blacklisted? http://www.mxtoolbox.com/blacklists.aspx
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 26th March 2007, 22:06
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,266
Thanks: 82
Thanked 24 Times in 20 Posts
Default

- I am not blacklisted (just checked)
- like I said he said he sends in batches of 100 recepients, his own address is in the to field the other 100 are in the bcc field. All I found during the time he said he sent this newsletter were these entries:

- nothing relevant in mail.err
- in mail.log

Quote:
Mar 24 15:20:17 h898552 postfix/qmgr[32025]: 91FA2628175: from=<contact@hai-hui.eu>, size=622, nrcpt=2 (queue active)
Mar 24 15:20:18 h898552 postfix/pickup[20070]: 43086628188: uid=10003 from=<web2_info>
Mar 24 15:20:18 h898552 postfix/cleanup[25615]: 43086628188: message-id=<20070324142018.43086628188@h898552.serverkompe tenz.net>
Mar 24 15:20:18 h898552 postfix/qmgr[32025]: 43086628188: from=<web2_info@h898552.serverkompetenz.net>, size=413, nrcpt=1 (queue active)
Mar 24 15:20:18 h898552 postfix/local[25634]: 43086628188: to=<admispconfig@localhost.localdomain>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
Mar 24 15:20:18 h898552 postfix/qmgr[32025]: 43086628188: removed
Mar 24 15:20:19 h898552 postfix/smtp[25616]: 91FA2628175: to=<clientsaddress@yahoo.com>, relay=b.mx.mail.yahoo.com[66.196.97.250], delay=2, status=sent (250 ok dirdel)
seems like he sent a testmesage to himself or he has a forwarding on!?

he said he sent his newsletter aroung 18:30 so here I found roughly 30 or so entries like these:

Quote:
Mar 24 18:32:05 h898552 postfix/smtpd[13423]: connect from h898552.serverkompetenz.net[85.214.51.208]
Mar 24 18:32:05 h898552 postfix/smtpd[13423]: 8AD4D62819B: client=h898552.serverkompetenz.net[85.214.51.208], sasl_method=LOGIN, sasl_username=web2_info
Mar 24 18:32:05 h898552 postfix/cleanup[19436]: 8AD4D62819B: message-id=<4605609585e69_375320154bcc1724@h898552.serverk ompetenz.net.tmail>
Mar 24 18:32:05 h898552 postfix/qmgr[32025]: 8AD4D62819B: from=<contact@hai-hui.eu>, size=646, nrcpt=1 (queue active)
Mar 24 18:32:05 h898552 postfix/smtpd[13423]: disconnect from h898552.serverkompetenz.net[85.214.51.208]
Mar 24 18:32:05 h898552 postfix/smtpd[13423]: connect from h898552.serverkompetenz.net[85.214.51.208]
Mar 24 18:32:05 h898552 postfix/smtpd[13423]: CF3B662819F: client=h898552.serverkompetenz.net[85.214.51.208], sasl_method=LOGIN, sasl_username=web2_info
Mar 24 18:32:05 h898552 postfix/cleanup[19436]: CF3B662819F: message-id=<46056095cb8f0_375320154bcc18c1@h898552.serverk ompetenz.net.tmail>
Mar 24 18:32:05 h898552 postfix/qmgr[32025]: CF3B662819F: from=<contact@hai-hui.eu>, size=646, nrcpt=1 (queue active)
Mar 24 18:32:05 h898552 postfix/smtpd[13423]: disconnect from h898552.serverkompetenz.net[85.214.51.208]
Mar 24 18:32:05 h898552 postfix/smtpd[13423]: connect from h898552.serverkompetenz.net[85.214.51.208]
Mar 24 18:32:06 h898552 postfix/smtpd[13423]: E5C676281A0: client=h898552.serverkompetenz.net[85.214.51.208], sasl_method=LOGIN, sasl_username=web2_info
Mar 24 18:32:06 h898552 postfix/cleanup[19436]: E5C676281A0: message-id=<46056095df927_375320154bcc19bc@h898552.serverk ompetenz.net.tmail>
Mar 24 18:32:06 h898552 postfix/qmgr[32025]: E5C676281A0: from=<contact@hai-hui.eu>, size=646, nrcpt=1 (queue active)
Mar 24 18:32:06 h898552 postfix/smtpd[13423]: disconnect from h898552.serverkompetenz.net[85.214.51.208]
but it seems he is only sending to the TO addres, else I should see all other outgoing emails to those 100's of BCC recepients too, right?
Reply With Quote
  #4  
Old 27th March 2007, 16:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Hm... Maybe it's a problem with the tool your customer uses?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 27th March 2007, 21:28
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,266
Thanks: 82
Thanked 24 Times in 20 Posts
Default

yeah, I was just checking - I'll double check with him tomorrow...

one more addition, see atached file. those are excerpts from the logs....
Attached Files
File Type: txt logs.txt (40.3 KB, 234 views)

Last edited by Ovidiu; 27th March 2007 at 23:53.
Reply With Quote
  #6  
Old 28th March 2007, 16:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by Tenaka
one more addition, see atached file. those are excerpts from the logs....
What kind of emails were sent to the web2_info account? Bounce or error messages?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 28th March 2007, 20:08
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,266
Thanks: 82
Thanked 24 Times in 20 Posts
Default

like I said, he get 1 mail for every 100 BCC users, and he said he got his own newsletter roughly 30 times, no errors... so to me it looks like the newsletter tool, might have not sent to the bcc addresses but only to him?
Reply With Quote
  #8  
Old 29th March 2007, 14:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
 
Default

Maybe. The log looks ok.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sendmai can send mails but unable to receive mails satimis Server Operation 10 20th February 2007 17:10
Can't download or delete mails from account torusturtle Installation/Configuration 9 11th July 2006 10:58
FC5 - phpBB mails are stuck in /var/spool/mail yaniv.fer Server Operation 1 19th May 2006 16:17
How to send mails using php mail function outside domain pankaj Technical 1 19th December 2005 22:09
How to retrive mails from 2nd server dstme Server Operation 3 1st December 2005 18:28


All times are GMT +2. The time now is 19:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.