#1  
Old 28th March 2007, 12:32
Jshel Jshel is offline
Member
 
Join Date: Mar 2007
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default postfix Relay access denied

I have been reading posts all over the place and I just can't find one that seems to help. So if someone wont mind looking over this it would be a great help, thank you in advance. I'm running FC6 with postfix and dovecot I followed the LAMP installation tutorial mostly. The problem I am having is that i can send emails others If I'm on the server but if I'm out in town and login to send a message i get relay access denied.
_____________
Maillog
_____________
Sending from My mail server to yahoo
Mar 28 02:04:11 server dovecot: pop3-login: Login: user=<user>, method=PLAIN, rip=::ffff:24.113.34.192, lip=::ffff:192.168.1.104
Mar 28 02:04:13 server dovecot: POP3(user): Disconnected: Logged out top=0/0, retr=1/1261, del=1/1, size=1244
Mar 28 02:05:01 server postfix/anvil[5497]: statistics: max connection rate 1/60s for (smtp:69.147.74.240) at Mar 28 02:00:12
Mar 28 02:05:01 server postfix/anvil[5497]: statistics: max connection count 1 for (smtp:69.147.74.240) at Mar 28 02:00:12
Mar 28 02:05:01 server postfix/anvil[5497]: statistics: max cache size 1 at Mar 28 02:00:12
Mar 28 02:05:30 server postfix/smtpd[5700]: connect from unknown[192.168.1.2]
Mar 28 02:05:30 server postfix/smtpd[5700]: setting up TLS connection from unknown[192.168.1.2]
Mar 28 02:05:31 server postfix/smtpd[5700]: TLS connection established from
unknown[192.168.1.2]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits) Mar 28 02:05:31 server postfix/smtpd[5700]: 652467F6D6:
client=unknown[192.168.1.2]
Mar 28 02:05:31 server postfix/cleanup[5704]: 652467F6D6:
message-id=<200703280205.30597.user@domain.com>
Mar 28 02:05:31 server postfix/qmgr[5474]: 652467F6D6: from=<user@domain.com>, size=614, nrcpt=1 (queue active)
Mar 28 02:05:31 server postfix/smtpd[5700]: disconnect from unknown[192.168.1.2] Mar 28 02:05:32 server postfix/smtp[5705]: 652467F6D6: to=<ME@yahoo.com>, relay=f.mx.mail.yahoo.com[68.142.202.247]:25,
delay=1.1, delays=0.05/0.05/0.67/0.31, dsn=2.0.0, status=sent (250 ok dirdel)
Mar 28 02:05:32 server postfix/qmgr[5474]: 652467F6D6: removed
_______________________
sent from remote mail client
_______________________
Mar 28 02:06:31 server postfix/smtpd[5700]: warning: 24.113.34.192: hostname staticip-24-113-34-192.wavecable.com verification failed: Name or service not known
Mar 28 02:06:31 server postfix/smtpd[5700]: connect from unknown[24.113.34.192]
Mar 28 02:06:31 server postfix/smtpd[5700]: NOQUEUE: reject: RCPT from
unknown[24.113.34.192]: 554 5.7.1 <ME@yahoo.com>: Relay access denied; from=<user@domain.com> to=<ME@yahoo.com> proto=ESMTP helo=<laptop> Mar 28 02:06:34 server postfix/smtpd[5700]: disconnect from unknown[24.113.34.192]
________________________________
main.cf
________________________________
queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
mail_owner = postfix
myhostname = server.domain.com
mydomain = domain.com
myorigin = $mydomain
inet_interfaces = all
mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain, mail.
$mydomain, www.$mydomain, ftp.$mydomain
local_recipient_maps =
unknown_local_recipient_reject_code = 550
mynetworks = 192.168.1.0/24 127.0.0.0/8
#relay_domains = $mydestination
#relayhost = $mydomain
#relayhost = [gateway.my.domain]
#relayhost = [mailserver.isp.tld]
#relayhost = uucphost
#relayhost = [an.ip.add.ress]

alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
mail_spool_directory = /var/spool/mail
debug_peer_level = 2
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5 sendmail_path = /usr/sbin/sendmail.postfix newaliases_path = /usr/bin/newaliases.postfix mailq_path = /usr/bin/mailq.postfix setgid_group = postdrop html_directory = no manpage_directory = /usr/share/man sample_directory = /usr/share/doc/postfix-2.3.3/samples
readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES

#virtual_maps = hash:/etc/postfix/virtusertable

#mydestination = /etc/postfix/local-host-names smtpd_sasl_local_domain = smtpd_sasl_auth_enable = yes smtpd_sasl_security_options = noanonymous broken_sasl_auth_clients = yes smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem smtpd_tls_loglevel = 1 smtpd_tls_received_header = yes smtpd_tls_session_cache_timeout = 3600s tls_random_source = dev:/dev/urandom
__________________________________
well thats it thank you for taking your time to look over this mess it's been driving me carzy for a week now maybe longer.
jshel
Reply With Quote
Sponsored Links
  #2  
Old 29th March 2007, 14:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

You must enable "Server requires authentication." in your email client.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 29th March 2007, 19:49
Jshel Jshel is offline
Member
 
Join Date: Mar 2007
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks falko
I love when the answer is so easy you feel stupid, but hey it works LOL
thanks again
JShel
Reply With Quote
  #4  
Old 30th March 2007, 04:01
Jshel Jshel is offline
Member
 
Join Date: Mar 2007
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok this is not getting any better well maybe, I can send mail out now with the exception of hotmail (damn microsoft) but now i can't recive mail from any one they all get relay access denied i have tryed from my own yahoo and msn accounts and i get it also (GRRRRRRR) I don't know what happened at one point i could send mail to my server but i couldn't send mail out and now it switched on me. sorry i'm just venting but any sort of help would be great befor i pull on "Office Space" act on this server.
Reply With Quote
  #5  
Old 30th March 2007, 06:15
Jshel Jshel is offline
Member
 
Join Date: Mar 2007
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

OK got it working thanks for all the help,
JShel
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 16:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 16:36
ISPConfig Postfix ERROR (Relay access denied) burzumishi Installation/Configuration 1 3rd August 2006 10:47
Questions in regards to ISP-Server Setup - Ubuntu 5.10 "Breezy Badger" rbrantley HOWTO-Related Questions 16 10th April 2006 19:26
Bug? (postfix refuses mail, relay access denied) st2xo General 2 31st January 2006 17:00


All times are GMT +2. The time now is 17:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.