Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th March 2007, 21:39
bpmee bpmee is offline
Member
 
Join Date: Aug 2006
Posts: 86
Thanks: 3
Thanked 7 Times in 6 Posts
Unhappy Can't Login to /stats - Yes the stats have run, Yes, I'm using correct user/pass

Hi All,

I've searched all over the forum for a reply to my problem, but most posts only address about 1/2 the problem...So here goes:

When I try to login to: www.mysite.com/stats WITH the correct user: web5_username and correct password I get a 401 "Authorisation" error...

Yes - more than 24 hours have passed and the webalizer script has run. There is log data, so this is not the issue.

Yes - the crontab contains the correct calls for the log processing script and the webalizer script.

I'm on Fedora Core 5, ISPConfig 2.2.10

Note:

When I delete all .htaccess files in the /var/www/web5/web/stats folders, the problem goes away and I am not prompted for login credentials.

But, this means my stats are unprotected!

Also, I tried looking at ownership of my sites using the ls -l command, here is a sample, note I name my sites: web5_domain[com|net|us|biz etc]

Code:

drwxr-xr-x 9 web227_gocom                web227 4096 Mar  6 11:21 web227
drwxr-xr-x 8 web238_mynet             web238 4096 Mar  6 04:00 web238
drwxr-xr-x 9 web246_879com       web246 4096 Mar  6 04:00 web246
drwxr-xr-x 9 web254_afesnet             web254 4096 Mar 10 10:19 web254
drwxr-xr-x 8 apache                          web255 4096 Mar  8 11:19 web255
drwxr-xr-x 8 apache                          web256 4096 Mar  8 11:16 web256
drwxr-xr-x 8 apache                          web257 4096 Mar  8 11:20 web257
drwxr-xr-x 8 apache                          web258 4096 Mar  6 04:00 web258
Despite different ownerships, I still can't login so this may not be the problem!

Thanks...
Reply With Quote
Sponsored Links
  #2  
Old 11th March 2007, 13:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

Please have a look at the error log of the website, which error is logged there when you try to authenticate to the stats directory?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 12th March 2007, 19:33
bpmee bpmee is offline
Member
 
Join Date: Aug 2006
Posts: 86
Thanks: 3
Thanked 7 Times in 6 Posts
Question Found the error being created

Hi Till/Falko/others:

Here is the error that is being sent to my log:

Code:
[Mon Mar 12 10:28:55 2007] [error] [client 200.6.60.31] user web301_blogsnet: authentication failure for "/stats": Password Mismatch
[Mon Mar 12 10:29:01 2007] [error] [client 200.6.60.31] user web301_blogsnet: authentication failure for "/stats": Password Mismatch
Not sure what Password Mismatch means????
Reply With Quote
  #4  
Old 13th March 2007, 20:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Quote:
Originally Posted by bpmee
Not sure what Password Mismatch means????
You didn't use the correct password. You can try to set a new one in ISPConfig. But keep in mind that the .htpasswd file for the stats folder is updated only at 04.00h, so you won't be able to log in immediately.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
tom (30th March 2007)
  #5  
Old 14th March 2007, 20:20
bpmee bpmee is offline
Member
 
Join Date: Aug 2006
Posts: 86
Thanks: 3
Thanked 7 Times in 6 Posts
Default Thanks - will wait until tomorrow to test again

Hi Falko,

Thanks - I've changed some passwords, and will wait until tomorrow to see if they updated correctly.
Reply With Quote
  #6  
Old 30th March 2007, 14:06
tom tom is offline
Senior Member
 
Join Date: Apr 2006
Posts: 492
Thanks: 8
Thanked 8 Times in 7 Posts
Default

Quote:
Originally Posted by falko
You didn't use the correct password. You can try to set a new one in ISPConfig. But keep in mind that the .htpasswd file for the stats folder is updated only at 04.00h, so you won't be able to log in immediately.
If got the same situation. I've tried to run the script an 04.00h but still I cant log in the stats directory. This script I used:
Quote:
/root/ispconfig/scripts/shell/webalizer.php &> /dev/null
Reply With Quote
  #7  
Old 31st March 2007, 15:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
 
Default

Is there anything in the stats directory? You can check with
Code:
ls -la /path/to/stats
Also, stats are generated only if that web site has been accessed. If it hasn't been accessed, its access log is empty, and therefore no statistics are created.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to authenticate to SMTP server ashkev Installation/Configuration 15 6th February 2007 18:46
kann keine mails empfangen odin1 Installation/Configuration 5 6th July 2006 13:13
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 18:28


All times are GMT +2. The time now is 03:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.