Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th March 2007, 06:41
yurtboy yurtboy is offline
Junior Member
 
Join Date: Nov 2006
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default Drupal and TinyMCE and images...

On a non ispconfig server it worked like a snap...
But when I insert an image it just does not show up.
Both are clean installs.
All the same settings.....
Tried fck too
This server does Joomla and Egroupware great so I think it is just an .htaccess or other setting.
I followed the how to online for drupal and ispconfig.
Thanks
Al
Reply With Quote
Sponsored Links
  #2  
Old 27th March 2007, 07:20
yurtboy yurtboy is offline
Junior Member
 
Join Date: Nov 2006
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default Figured it out....

So I think drupal puts an .htaccess in the folder you choose for you files folder in
Administer --> Filesettings
I moved it to HTACCESS and then created a link to the one I was told to use in the turorial.
Maybe there is a better way?
Now I can insert pictures with Tinymce.
I'de be more excited if it was not 1:30 am and if I did not start at 10pm.
Al
Reply With Quote
  #3  
Old 18th November 2007, 22:46
yurtboy1 yurtboy1 is offline
Member
 
Join Date: May 2007
Posts: 77
Thanks: 4
Thanked 1 Time in 1 Post
Default NOPE still not sure here

Non-ispconfig sites it sets up easily.
With ISPConfig sites still have a but of trouble.
Full HTML is on with Drupal.
Preview and Edit show a broken image.
View / Save and it works fine.
Here is my .htaccess
Quote:
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ /index.php?q=$1 [L,QSA]
</IfModule>
RemoveHandler .html .htm
AddType application/x-httpd-php .php .htm .html
Here is the ISPConfig Settings
Quote:
<Directory /var/www/web1/web/drupal/>
Options +Includes +FollowSymlinks -Indexes
AllowOverride All
Order allow,deny
Allow from all
<Files ~ "^.ht">
Deny from all
</Files>
</Directory>
<Directory /var/www/web1/web/>
Options +Includes +FollowSymlinks -Indexes
AllowOverride All
Order allow,deny
Allow from all
<Files ~ "^.ht">
Deny from all
</Files>
</Directory>
<Directory /var/www/web1/web/files/>
Options +Includes +FollowSymlinks -Indexes
AllowOverride All
Order allow,deny
Allow from all
<Files ~ "^.ht">
Deny from all
</Files>
</Directory>
Alright so I am going to try some other settings that worked for other ISPConfig sites but any help would be appreciated.
Thansk
Reply With Quote
  #4  
Old 19th November 2007, 14:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Take a look at the end of your main Apache configuration file. At the end there should be a section added by the ISPConfig installer. Set AllowOverride to All and restart Apache.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 19th November 2007, 18:02
yurtboy1 yurtboy1 is offline
Member
 
Join Date: May 2007
Posts: 77
Thanks: 4
Thanked 1 Time in 1 Post
Default So line 424 of the main apache file

Quote:
###############ispconfig_log###############
LogFormat "%v||||%b||||%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent$
CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_$

<Directory /var/www/*/web>
Options +Includes -Indexes
AllowOverride All
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all
<Files ~ "^\.ht">
Deny from all
</Files>
</Directory>
So the AllowOverride All was AllowOverride None
Bu still edit mode only shows a broken image but Preview and regular view mode show fine.
ps..I am willing to pay to fix this since it gets me with every new site.
Al
Reply With Quote
The Following User Says Thank You to yurtboy1 For This Useful Post:
breauxlg (30th November 2009)
  #6  
Old 20th November 2007, 15:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Comment out the AllowOverride Indexes AuthConfig Limit FileInfo line and restart Apache.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 25th November 2007, 02:50
yurtboy1 yurtboy1 is offline
Member
 
Join Date: May 2007
Posts: 77
Thanks: 4
Thanked 1 Time in 1 Post
Default Same error, attached is that apache.conf

Done it all and same error (not at the console though)
I change many lines, maybe too many ( -:
Again this works on other sites on the same server.
Could it be a cache thing?
Attached Files
File Type: txt apache2.txt (13.8 KB, 163 views)
Reply With Quote
  #8  
Old 26th November 2007, 18:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Have you tried to clear your browser's cache?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 26th November 2007, 18:37
yurtboy1 yurtboy1 is offline
Member
 
Join Date: May 2007
Posts: 77
Thanks: 4
Thanked 1 Time in 1 Post
Default Using Firefox with disabled cache

http://rivervalleywebhosting.com/ledger/login.pl
Still no go
Reply With Quote
  #10  
Old 26th November 2007, 18:38
yurtboy1 yurtboy1 is offline
Member
 
Join Date: May 2007
Posts: 77
Thanks: 4
Thanked 1 Time in 1 Post
 
Default

Yes.
Using firefox and disable cache.
Same problem.
uhhg
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 14:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.