Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th March 2007, 09:36
teves teves is offline
Senior Member
 
Join Date: Oct 2006
Posts: 150
Thanks: 27
Thanked 15 Times in 10 Posts
Default Urgent! SMTP/SASL problem after Kernel update

Hello,

after updating the kernel on my Suse 10.1 perfect setup / ispconfig 2.28 server I cannot send mail anymore.

A
tail /var/log/messages
gives me
Mar 26 09:17:23 whitespace kernel: saslauthd[27570]: segfault at 00000000745dc280 rip 00002b3a74d1b6b0 rsp 00007fff36bd4528 error 4
Mar 26 09:17:24 whitespace kernel: saslauthd[27571]: segfault at 00000000745dc280 rip 00002b3a74d1b6b0 rsp 00007fff36bd4528 error 4
Mar 26 09:17:32 whitespace kernel: saslauthd[27572]: segfault at 00000000745dc280 rip 00002b3a74d1b6b0 rsp 00007fff36bd4528 error 4
Mar 26 09:17:32 whitespace kernel: saslauthd[27573]: segfault at 00000000745dc280 rip 00002b3a74d1b6b0 rsp 00007fff36bd4528 error 4


tail /var/log/mail.warn
results in
Mar 26 09:29:18 whitespace postfix/smtpd[27802]: warning: 203.210.253.236: hostname adsl.hnpt.com.vn verification failed: Name or service not known
Mar 26 09:30:21 whitespace postfix/smtpd[27847]: warning: SASL authentication failure: size read failed
Mar 26 09:30:21 whitespace postfix/smtpd[27847]: warning: SASL authentication failure: Password verification failed
Mar 26 09:30:21 whitespace postfix/smtpd[27847]: warning: p57A4C18A.dip0.t-ipconnect.de[87.164.193.138]: SASL PLAIN authentication failed
Mar 26 09:30:21 whitespace postfix/smtpd[27847]: warning: SASL authentication failure: size read failed


What has happened here? What can I do?
This is really urgent because I have ~150 Domains running here...

Thank you,
regards, Tom
Reply With Quote
Sponsored Links
  #2  
Old 26th March 2007, 09:41
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,388
Thanks: 833
Thanked 5,485 Times in 4,317 Posts
Default

Hi Tom,

did you reboot your server after installing the kernel?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 26th March 2007, 09:47
teves teves is offline
Senior Member
 
Join Date: Oct 2006
Posts: 150
Thanks: 27
Thanked 15 Times in 10 Posts
Default

Hallo,

yes I did (and did it once again now).

regards, Tom
Reply With Quote
  #4  
Old 26th March 2007, 09:52
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,388
Thanks: 833
Thanked 5,485 Times in 4,317 Posts
Default

Are there any sasl updates pending? Please amke sure that you have disabled apparmor, maybe it is enabled again after the kernel update.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 26th March 2007, 09:54
teves teves is offline
Senior Member
 
Join Date: Oct 2006
Posts: 150
Thanks: 27
Thanked 15 Times in 10 Posts
Default

Hello,

no I have the most actual sasl package.
apparmor is not running.
Would it be an option to downgrade the kernel to the old version?

regards, Tom
Reply With Quote
  #6  
Old 26th March 2007, 09:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,388
Thanks: 833
Thanked 5,485 Times in 4,317 Posts
Default

Quote:
Would it be an option to downgrade the kernel to the old version?
Maybe, but I'am not sure if this might cause other trouble. Can you select an older kernel in grub when you boot or does SuSE removes the older kernel after the update? Segfaults might also be caused by hardware problems, But its not so likely that your hardware gets problems at the same time you updated your kernel.

Maybe one of the other users has a good idea?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 26th March 2007, 10:09
teves teves is offline
Senior Member
 
Join Date: Oct 2006
Posts: 150
Thanks: 27
Thanked 15 Times in 10 Posts
Default

Hello,

well I will just take the risk now.
I need to find a solution NOW. In the worst case I will have to copy the status of yesterday back onto the first harddisk - I have two harddisks and did a dd from a to b before upgrading yesterday - but it would take a few hours at least.

Hm. It does not seem to work. I still get the segmentation fault.
I have also downgraded sasl now without success.
Any ideas?

regards, Tom
Reply With Quote
  #8  
Old 26th March 2007, 10:12
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,388
Thanks: 833
Thanked 5,485 Times in 4,317 Posts
Default

You can try to check your hardware with e.g. memcheck. Maybe its really a hardware problem, e.g. instable ram, that was triggered by the reboot.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 26th March 2007, 10:16
teves teves is offline
Senior Member
 
Join Date: Oct 2006
Posts: 150
Thanks: 27
Thanked 15 Times in 10 Posts
Default

Hi,

I cannot tell if it is a hardware problem, but I don't believe it. Everything worked perfectly until now, and at the moment everything else (only exception: sasl) works perfectly.
This would be a strange hardware problem. (Well ok, I've seen a lot. )

Anyway: I don't believe in a hardware problem.

Thank you,
Tom
Reply With Quote
  #10  
Old 26th March 2007, 10:24
teves teves is offline
Senior Member
 
Join Date: Oct 2006
Posts: 150
Thanks: 27
Thanked 15 Times in 10 Posts
 
Default

Hello,

testsaslauthd -u web**_info -p *******

gives me the message

size read failed

Any ideas?

regards, Tom
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
High Availability Samba cluster - DRBD + Heartbeat djalex Server Operation 58 25th May 2007 19:38
Xen 3.0.2 /3.0.3 | No Swap in DomU Merc HOWTO-Related Questions 10 27th March 2007 11:40
WG311v2 almost working with Edgy (w/o ndiswrapper) need help with the rest caudata Server Operation 11 13th November 2006 20:02
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 05:19
KErnel not showing all my memory Jorem Kernel Questions 8 13th April 2006 12:59


All times are GMT +2. The time now is 13:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.