Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 23rd March 2007, 17:16
polikarp polikarp is offline
Junior Member
 
Join Date: Mar 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Centos 4.4 ISPconfig I cant recive emails from out.

Hi;

I searc the forum but I can not find any answer or beter solutions for my problem.

I installed Centos 4.4 with ISPconfig all services are working good.

I have dinamic IP adress and I am using dyndns.org free domains.

my domain like "myname.ath.cx"

Server user can send and recive emails each others there is no problem. Like
user1@myname.at.cx can send and recive email from user2@myname.ath.cx
Even both are can send email to other emails like hotmail or yahoo.

My problem is;
I can not recieve emails from other mail providers like yahoo etc.
Mail log file have no any warning messages.

What can I do?

Thank you for your help.
Reply With Quote
Sponsored Links
  #2  
Old 23rd March 2007, 17:24
edge edge is online now
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,036
Thanks: 268
Thanked 153 Times in 133 Posts
Default

Sounds like a MX DNS problem.

Test your domain at www.dnsreport.com , and report back any errors / fails.
(enter your domain in the DNS report box)
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
  #3  
Old 23rd March 2007, 17:31
polikarp polikarp is offline
Junior Member
 
Join Date: Mar 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Edge thank you for quick reply;
I chcked and I that gat this message;
ERROR: The parent servers say that the domain myname.ath.cx does not have any NS records (although they may have some other information on that zone). I can not do a DNS report on a hostname (such as mail.example.com) or a domain name that does not have its own zone.]

How can I fix this or do you know can I do thhat with kind of free domain?
Thanks again.
Reply With Quote
  #4  
Old 23rd March 2007, 18:00
edge edge is online now
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,036
Thanks: 268
Thanked 153 Times in 133 Posts
Default

No MX, no mail.. The MX record of a DNS is telling other servers where the mail should go to..

You will need to creat a MX record in (your?) DNS server that is pointing to your mailserver.

If you run your own DNS server, all you will need to do is within ISPconfig go to DNS manager > the-domain > Records, and click on New under MX.
Enter in Host: @ and in Mailserver the 1st domain of your server**

** The one you set in Management > Server > Settings (the Domain)

Aftert this do the dnsreport test again, and see if it's any better.
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
  #5  
Old 23rd March 2007, 18:18
polikarp polikarp is offline
Junior Member
 
Join Date: Mar 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks again;
I tryed all what you say but still I am taking same messages.

I reboot to computer. But nothing changed.
Reply With Quote
  #6  
Old 23rd March 2007, 18:39
edge edge is online now
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,036
Thanks: 268
Thanked 153 Times in 133 Posts
Default

If you are using dyndns.org, than you are not using your own dns!
You will need to set the MX record at dyndns.org I think
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
  #7  
Old 23rd March 2007, 18:46
polikarp polikarp is offline
Junior Member
 
Join Date: Mar 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok thank you I will ask this them.
Reply With Quote
  #8  
Old 24th March 2007, 10:36
polikarp polikarp is offline
Junior Member
 
Join Date: Mar 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Again;
I talked with dyndns.org and they support mx recort free I seted neccessery install. Now I am accesing web site which before you gave me DNS report giving still problem but beside of that mail test giving exact report means that working.

Do I have wait for dns record for some times like 12, 24, 48 hours or it must be effect immediet? Because still I can't receive email from out.

Thanks again.
Reply With Quote
  #9  
Old 24th March 2007, 10:40
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,388
Thanks: 833
Thanked 5,486 Times in 4,318 Posts
Default

Please ask your provider if they block port 25 on your dsl or cable line where you host your server on.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 24th March 2007, 10:52
polikarp polikarp is offline
Junior Member
 
Join Date: Mar 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Till thank you for answer;
All neccesery ports are open and working. Include 110 and 25. And firewalls are turned off

Last edited by polikarp; 24th March 2007 at 11:22.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
LOTS of FTP timeouts (centos 4.4, perfect install, ispconfig) ThE-LyNX Server Operation 10 13th December 2006 20:41
ISPConfig 2.2.8 + Dynamic IP + CENTOS 4.4 error Installation/Configuration 3 7th December 2006 09:35
CentOS 4.4 - upgrade 2.2.6 -> 2.2.7 wiped ispconfig db jdell Installation/Configuration 2 12th October 2006 10:20
ISPConfig on CentOS 4.4 pkardono Installation/Configuration 2 8th September 2006 08:02
Install ISPConfig on CentOS Server, in brief gfts Tips/Tricks/Mods 11 4th April 2006 08:29


All times are GMT +2. The time now is 14:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.