#1  
Old 6th November 2005, 23:08
dmgeurts dmgeurts is offline
Junior Member
 
Join Date: Nov 2005
Location: Netherlands
Posts: 26
Thanks: 2
Thanked 0 Times in 0 Posts
Default mysql not working

Right I got my php and vhost thingy worked out then I find that info.php states that it hasn't got mysql while php4-mysql is installed and the site has it turned on in ispconfig. Any way I can troubleshoot this?

www.djerk.nl/info.php

'--without-mysql'


Should php.ini have mysql off globally? ";extension=mysql.so"

TIA

Last edited by dmgeurts; 6th November 2005 at 23:24.
Reply With Quote
Sponsored Links
  #2  
Old 7th November 2005, 09:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,717
Thanks: 820
Thanked 5,322 Times in 4,175 Posts
Default

This should not be commented out:

";extension=mysql.so"

When you have the mysql php extension installed. Try to remove the comment (;" and restart your apache webserver.
Reply With Quote
  #3  
Old 7th November 2005, 12:58
dmgeurts dmgeurts is offline
Junior Member
 
Join Date: Nov 2005
Location: Netherlands
Posts: 26
Thanks: 2
Thanked 0 Times in 0 Posts
Default

So unlike PHP which disabled by default and enabled per vhost, how is mysql denied per vhost then?

I did uncomment the line so I could install my site ) just wondering if it's the way it should be...
Reply With Quote
  #4  
Old 7th November 2005, 13:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

You have a check box in ISPConfig where you can enable/disable MySQL.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Installation failing on mysql benkong2 Installation/Configuration 1 5th November 2005 00:24
Problem installing ISPConfig, then with MySQL... ctroyp Installation/Configuration 7 26th September 2005 16:37
MySQL issue during install of ISPConfig ricbax Installation/Configuration 4 16th September 2005 09:41
Mysql ejs Installation/Configuration 5 12th August 2005 07:01
MySQL Privileges mcfly Server Operation 4 26th May 2005 19:00


All times are GMT +2. The time now is 10:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.