#1  
Old 23rd March 2007, 01:01
parkerj parkerj is offline
Member
 
Join Date: Feb 2007
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Default Perfect Ubuntu Mail Problems

I installed Ubuntu 6.06 and I am having trouble sending and receiving mail. This is the first time. When I was using Debian Etch, I did not have this trouble. Below is an excerpt of /var/log/mail.info
Quote:
Mar 22 23:39:32 securetrp imaplogin: LOGIN, user=web1_support, ip=[::ffff:127.0.0.1], protocol=IMAP
Mar 22 23:39:32 securetrp imaplogin: LOGOUT, user=web1_support, ip=[::ffff:127.0.0.1], headers=0, body=0, time=0
Mar 22 23:40:32 securetrp imaplogin: LOGIN, user=web1_support, ip=[::ffff:127.0.0.1], protocol=IMAP
Mar 22 23:40:32 securetrp imaplogin: LOGOUT, user=web1_support, ip=[::ffff:127.0.0.1], headers=0, body=0, time=0
Mar 22 23:41:32 securetrp imaplogin: LOGIN, user=web1_support, ip=[::ffff:127.0.0.1], protocol=IMAP
Mar 22 23:41:32 securetrp imaplogin: LOGOUT, user=web1_support, ip=[::ffff:127.0.0.1], headers=0, body=0, time=0
Please click here for my dns report. /etc/hosts contains
Quote:
64.79.209.234 server1.securetrp.com localhost localhost.localdomain
127.0.0.1 securetrp.com securetrp localhost localhost.localdomain
I can send email, but I cannot receive email. Thanks for your help.

Last edited by parkerj; 23rd March 2007 at 01:38.
Reply With Quote
Sponsored Links
  #2  
Old 23rd March 2007, 11:40
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

The above lines are from imap logins and not from sending a email. Please send a email and post the lines that appear then in the mail log.

/etc/hosts:

The line:

64.79.209.234 server1.securetrp.com localhost localhost.localdomain

must be:

64.79.209.234 server1.securetrp.com

You can not define localhost for 2 different IP addresses.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 23rd March 2007, 14:42
parkerj parkerj is offline
Member
 
Join Date: Feb 2007
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, I changed what you said in /etc/hosts and I sent an email. There was no message that occurred in mail.log, but below is what I get from mail.warn:
Quote:
Mar 23 00:27:56 securetrp postfix/trivial-rewrite[27941]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by$
Mar 23 00:27:56 securetrp postfix/trivial-rewrite[27941]: warning: inet_protocols: configuring for IPv4 support only
Mar 23 00:27:56 securetrp postfix/cleanup[27942]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
Mar 23 00:27:56 securetrp postfix/cleanup[27942]: warning: inet_protocols: configuring for IPv4 support only
Mar 23 00:33:23 securetrp postfix/smtpd[30511]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
Mar 23 00:33:23 securetrp postfix/smtpd[30511]: warning: inet_protocols: configuring for IPv4 support only
Mar 23 00:33:23 securetrp postfix/proxymap[30512]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protoc$
Mar 23 00:33:23 securetrp postfix/proxymap[30512]: warning: inet_protocols: configuring for IPv4 support only
Mar 23 00:33:23 securetrp postfix/trivial-rewrite[30513]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by$
Mar 23 00:33:23 securetrp postfix/trivial-rewrite[30513]: warning: inet_protocols: configuring for IPv4 support only
Mar 23 00:33:23 securetrp postfix/cleanup[30514]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
Mar 23 00:33:23 securetrp postfix/cleanup[30514]: warning: inet_protocols: configuring for IPv4 support only
Mar 23 00:33:24 securetrp postfix/smtp[30516]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
Mar 23 00:33:24 securetrp postfix/smtp[30516]: warning: inet_protocols: configuring for IPv4 support only
Mar 23 00:34:21 securetrp postfix/anvil[30632]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
Mar 23 00:34:21 securetrp postfix/anvil[30632]: warning: inet_protocols: configuring for IPv4 support only
Mar 23 00:34:22 securetrp postfix/smtp[30633]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
Mar 23 00:34:22 securetrp postfix/smtp[30633]: warning: inet_protocols: configuring for IPv4 support only
Mar 23 00:34:22 securetrp postfix/bounce[30634]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
Mar 23 00:34:22 securetrp postfix/bounce[30634]: warning: inet_protocols: configuring for IPv4 support only
Mar 23 02:04:24 securetrp postfix/pickup[13926]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
Mar 23 02:04:24 securetrp postfix/pickup[13926]: warning: inet_protocols: configuring for IPv4 support only
Reply With Quote
  #4  
Old 23rd March 2007, 18:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
Default

Please run
Code:
postconf -e 'inet_protocols = ipv4'
/etc/init.d/postfix restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 24th March 2007, 00:25
parkerj parkerj is offline
Member
 
Join Date: Feb 2007
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you. But I still cannot send email to myself. when I send email, I get back the following message:
Quote:
This is the Postfix program at host server1.securetrp.com.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to <postmaster>

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The Postfix program

<web1_support@server1.securetrp.com> (expanded from <support@securetrp.com>):
mail for server1.securetrp.com loops back to myself
Reply With Quote
  #6  
Old 24th March 2007, 10:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Please add the line:

server1.securetrp.com

at the end of the file /etc/postfix/local-host-names and restart postfix.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 25th March 2007, 01:34
parkerj parkerj is offline
Member
 
Join Date: Feb 2007
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Problem solved. Thank you.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix reject connections gabrix Server Operation 27 25th January 2007 08:37
postfix-tls sasl2 mysql courier-authmysql gabrix Server Operation 4 12th January 2007 22:09
About installing ddclient satimis Server Operation 32 21st December 2006 03:51
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 12:16
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 11:47


All times are GMT +2. The time now is 01:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.