#1  
Old 20th March 2007, 12:23
poba poba is offline
Junior Member
 
Join Date: Mar 2006
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default The Perfect Setup - Debian Sarge and MySQL 5!

Hi,

I'm trying to setup Debian Sarge server with MySQL 5. If I follow the "The Perfect Setup" instructions I get MySQL 4. I tryed to change this line
Code:
apt-get install mysql-server mysql-client libmysqlclient12-dev
during the setup, but without success. Then I changed the installation source and try to update MySQL4 to 5. Nothing.

Sorry for n00b question, but please help me.

Last edited by poba; 20th March 2007 at 21:23.
Reply With Quote
Sponsored Links
  #2  
Old 21st March 2007, 14:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Do you see any MySQL 5 packages when you run
Code:
apt-cache search mysql
? If not, you can try the packages from http://dotdeb.org/ .
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 21st March 2007, 17:07
poba poba is offline
Junior Member
 
Join Date: Mar 2006
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for reply.

First I checked if there are MySQL 5 packages. There were only MySQL 4 packages. So I added source in /etc/apt/sources.list

Code:
#deb file:///cdrom/ sarge main

deb http://dotdeb.pimpmylinux.org/ stable all
deb-src http://dotdeb.pimpmylinux.org/ stable all

deb http://ftp.si.debian.org/debian/ stable main
deb-src http://ftp.si.debian.org/debian/ stable main

deb http://security.debian.org/ stable/updates main
But now I get this! There is MySQL 5, but in the end it's "Checking for corrupt, not cleanly closed and upgrade needing tables."

Code:
debian:~# apt-get install mysql-server mysql-client libmysqlclient12-dev
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  libdbd-mysql-perl libdbi-perl libmysqlclient12 libmysqlclient14 libmysqlclient15off libnet-daemon-perl libplrpc-perl
  mysql-client-5.0 mysql-common mysql-server-5.0
Suggested packages:
  dbishell mysql-doc tinyca
Recommended packages:
  libmysqlclient14-dev
The following NEW packages will be installed:
  libdbd-mysql-perl libdbi-perl libmysqlclient12 libmysqlclient12-dev libmysqlclient14 libmysqlclient15off libnet-daemon-perl
  libplrpc-perl mysql-client mysql-client-5.0 mysql-common mysql-server mysql-server-5.0
0 upgraded, 13 newly installed, 0 to remove and 0 not upgraded.
Need to get 39.4MB of archives.
After unpacking 103MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ftp.si.debian.org stable/main libnet-daemon-perl 0.38-1 [46.0kB]
Get:2 http://dotdeb.pimpmylinux.org stable/all mysql-common 5.0.32-1.dotdeb.1 [51.9kB]
Get:3 http://ftp.si.debian.org stable/main libplrpc-perl 0.2017-1 [35.0kB]
Get:4 http://ftp.si.debian.org stable/main libdbi-perl 1.46-6 [606kB]
Get:5 http://dotdeb.pimpmylinux.org stable/all libmysqlclient14 4.1.15-0.dotdeb.4 [1206kB]
Get:6 http://ftp.si.debian.org stable/main libmysqlclient12 4.0.24-10sarge2 [297kB]
Get:7 http://ftp.si.debian.org stable/main libmysqlclient12-dev 4.0.24-10sarge2 [2922kB]
Get:8 http://dotdeb.pimpmylinux.org stable/all libdbd-mysql-perl 2.9007-0.dotdeb.0 [133kB]
Get:9 http://dotdeb.pimpmylinux.org stable/all libmysqlclient15off 5.0.32-1.dotdeb.1 [1774kB]
Get:10 http://dotdeb.pimpmylinux.org stable/all mysql-client-5.0 5.0.32-1.dotdeb.1 [7087kB]
Get:11 http://dotdeb.pimpmylinux.org stable/all mysql-server-5.0 5.0.32-1.dotdeb.1 [25.2MB]
Get:12 http://dotdeb.pimpmylinux.org stable/all mysql-client 5.0.32-1.dotdeb.1 [43.4kB]
Get:13 http://dotdeb.pimpmylinux.org stable/all mysql-server 5.0.32-1.dotdeb.1 [45.5kB]
Fetched 39.4MB in 1m53s (348kB/s)
Preconfiguring packages ...
Selecting previously deselected package mysql-common.
(Reading database ... 22341 files and directories currently installed.)
Unpacking mysql-common (from .../mysql-common_5.0.32-1.dotdeb.1_all.deb) ...
Selecting previously deselected package libnet-daemon-perl.
Unpacking libnet-daemon-perl (from .../libnet-daemon-perl_0.38-1_all.deb) ...
Selecting previously deselected package libplrpc-perl.
Unpacking libplrpc-perl (from .../libplrpc-perl_0.2017-1_all.deb) ...
Selecting previously deselected package libdbi-perl.
Unpacking libdbi-perl (from .../libdbi-perl_1.46-6_i386.deb) ...
Selecting previously deselected package libmysqlclient14.
Unpacking libmysqlclient14 (from .../libmysqlclient14_4.1.15-0.dotdeb.4_i386.deb) ...
Selecting previously deselected package libdbd-mysql-perl.
Unpacking libdbd-mysql-perl (from .../libdbd-mysql-perl_2.9007-0.dotdeb.0_i386.deb) ...
Selecting previously deselected package libmysqlclient15off.
Unpacking libmysqlclient15off (from .../libmysqlclient15off_5.0.32-1.dotdeb.1_i386.deb) ...
Selecting previously deselected package mysql-client-5.0.
Unpacking mysql-client-5.0 (from .../mysql-client-5.0_5.0.32-1.dotdeb.1_i386.deb) ...
Setting up mysql-common (5.0.32-1.dotdeb.1) ...
Selecting previously deselected package mysql-server-5.0.
(Reading database ... 22556 files and directories currently installed.)
Unpacking mysql-server-5.0 (from .../mysql-server-5.0_5.0.32-1.dotdeb.1_i386.deb) ...
Selecting previously deselected package libmysqlclient12.
Unpacking libmysqlclient12 (from .../libmysqlclient12_4.0.24-10sarge2_i386.deb) ...
Selecting previously deselected package mysql-client.
Unpacking mysql-client (from .../mysql-client_5.0.32-1.dotdeb.1_all.deb) ...
Selecting previously deselected package mysql-server.
Unpacking mysql-server (from .../mysql-server_5.0.32-1.dotdeb.1_all.deb) ...
Selecting previously deselected package libmysqlclient12-dev.
Unpacking libmysqlclient12-dev (from .../libmysqlclient12-dev_4.0.24-10sarge2_i386.deb) ...
Setting up libnet-daemon-perl (0.38-1) ...

Setting up libplrpc-perl (0.2017-1) ...

Setting up libdbi-perl (1.46-6) ...
Setting up libmysqlclient14 (4.1.15-0.dotdeb.4) ...

Setting up libdbd-mysql-perl (2.9007-0.dotdeb.0) ...
Setting up libmysqlclient15off (5.0.32-1.dotdeb.1) ...

Setting up mysql-client-5.0 (5.0.32-1.dotdeb.1) ...
Setting up mysql-server-5.0 (5.0.32-1.dotdeb.1) ...
Stopping MySQL database server: mysqld.
Starting MySQL database server: mysqld.
.
Checking for corrupt, not cleanly closed and upgrade needing tables.

Setting up libmysqlclient12 (4.0.24-10sarge2) ...

Setting up mysql-client (5.0.32-1.dotdeb.1) ...
Setting up mysql-server (5.0.32-1.dotdeb.1) ...
Setting up libmysqlclient12-dev (4.0.24-10sarge2) ...
Code:
debian:~# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 *:smtp                  *:*                     LISTEN     4712/exim4
tcp        1      1 debian.pc-storitv:32787 debian.camtp.uni-mb:www LAST_ACK   -
tcp6       0      0 *:ssh                   *:*                     LISTEN     4988/sshd
tcp6       0      0 *:smtp                  *:*                     LISTEN     4712/exim4
tcp6       0      0 ::ffff:192.168.1.10:ssh ::ffff:192.168.0.1:1098 ESTABLISHED5037/sshd: root@not
tcp6       0    148 ::ffff:192.168.1.10:ssh ::ffff:192.168.0.1:1097 ESTABLISHED5030/0
tcp6       0      0 ::ffff:192.168.1.10:ssh ::ffff:192.168.0.1:1124 ESTABLISHED5042/sshd: root@not
Reply With Quote
  #4  
Old 22nd March 2007, 18:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Quote:
Originally Posted by poba
But now I get this! There is MySQL 5, but in the end it's "Checking for corrupt, not cleanly closed and upgrade needing tables."
That's normal.
Please start MySQL:
Code:
/etc/init.d/mysql restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dspam planet_fox General 6 20th January 2007 18:42
Installation source problem skeigor Installation/Configuration 4 19th August 2006 13:59
adding an installation source dimas Installation/Configuration 4 4th August 2006 22:19
Upgrade from 2.2.0 to 2.2.1 successful but SSL and IMAP stopped working teleriddler Installation/Configuration 8 29th April 2006 14:25
ISPConfig Firewall and no sense MyLinux General 7 9th September 2005 17:35


All times are GMT +2. The time now is 22:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.