Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Closed Thread
 
Thread Tools Display Modes
  #11  
Old 7th November 2005, 19:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Looks ok, too.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Sponsored Links
  #12  
Old 8th November 2005, 00:36
Pelle Pelle is offline
Junior Member
 
Join Date: Sep 2005
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey,

I have increased it to be something with the postfix-mysql because it gives the same error if I just set the database up on another machine...

Should I remove the programs with the apt-get --purge remove atribute and start over or?
  #13  
Old 8th November 2005, 09:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Do you use Debian testing or unstable? Because in the tutorial I use Debian stable...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
  #14  
Old 8th November 2005, 20:20
Pelle Pelle is offline
Junior Member
 
Join Date: Sep 2005
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I use stable (sarge)
  #15  
Old 9th November 2005, 21:44
oaky oaky is offline
Junior Member
 
Join Date: Nov 2005
Location: Salzburg / Austria
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I think I have a similar problem, but I am not sure...

Code:
Nov  9 19:19:15 m34s12 courierpop3login: LOGIN FAILED, ip=[::ffff:62.47.187.132]
Nov  9 19:34:26 m34s12 authdaemond.mysql: failed to connect to mysql server (server=localhost, userid=mail_admin )
Nov  9 19:34:31 m34s12 courierpop3login: LOGIN FAILED, ip=[::ffff:62.47.187.132]
Nov  9 19:41:11 m34s12 authdaemond.mysql: failed to connect to mysql server (server=localhost, userid=mail_admin )
Nov  9 19:41:16 m34s12 courierpop3login: LOGIN FAILED, ip=[::ffff:62.47.187.132]
Nov  9 19:43:14 m34s12 authdaemond.mysql: failed to connect to mysql server (server=localhost, userid=mail_admin )
Nov  9 19:43:19 m34s12 courierpop3login: LOGIN FAILED, ip=[::ffff:62.47.187.132]
Nov  9 19:47:01 m34s12 authdaemond.mysql: failed to connect to mysql server (server=localhost, userid=mail_admin )
Nov  9 19:49:30 m34s12 authdaemond.mysql: failed to connect to mysql server (server=localhost, userid=mail_admin )
Nov  9 19:49:35 m34s12 courierpop3login: LOGIN FAILED, ip=[::ffff:62.47.187.132]
Nov  9 19:49:37 m34s12 authdaemond.mysql: failed to connect to mysql server (server=localhost, userid=mail_admin )
Nov  9 19:49:42 m34s12 courierpop3login: LOGIN FAILED, ip=[::ffff:62.47.187.132]
Nov  9 19:49:49 m34s12 authdaemond.mysql: failed to connect to mysql server (server=localhost, userid=mail_admin )
Nov  9 19:49:54 m34s12 courierpop3login: LOGIN FAILED, ip=[::ffff:62.47.187.132]
Nov  9 19:49:56 m34s12 authdaemond.mysql: failed to connect to mysql server (server=localhost, userid=mail_admin )
Nov  9 19:50:01 m34s12 courierpop3login: LOGIN FAILED, ip=[::ffff:62.47.187.132]
Nov  9 19:50:24 m34s12 authdaemond.mysql: failed to connect to mysql server (server=localhost, userid=mail_admin )
Nov  9 19:50:29 m34s12 courierpop3login: LOGIN FAILED, ip=[::ffff:62.47.187.132]
I was thinking if "server=localhost" could be the problem, because it should be "server=127.0.0.1"?!?!

But in my /etc/mysql/my.cnf the "bind-adress" should be ok.

Code:
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address            = 127.0.0.1
Could it be the problem? And if yes, how can I solve it?

Thanks

Michael
  #16  
Old 9th November 2005, 22:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,405
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Have a look in the table mysql.user and mysql.db. Is the host field of the user mail_admin set to "localhost" or "%"? Have you restarted the mysql server after changing the permissions and adding the mail_admin user?
  #17  
Old 10th November 2005, 00:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by oaky
I think I have a similar problem, but I am not sure...

Code:
Nov  9 19:19:15 m34s12 courierpop3login: LOGIN FAILED, ip=[::ffff:62.47.187.132]
Nov  9 19:34:26 m34s12 authdaemond.mysql: failed to connect to mysql server (server=localhost, userid=mail_admin )
Nov  9 19:34:31 m34s12 courierpop3login: LOGIN FAILED, ip=[::ffff:62.47.187.132]
Nov  9 19:41:11 m34s12 authdaemond.mysql: failed to connect to mysql server (server=localhost, userid=mail_admin )
Nov  9 19:41:16 m34s12 courierpop3login: LOGIN FAILED, ip=[::ffff:62.47.187.132]
Nov  9 19:43:14 m34s12 authdaemond.mysql: failed to connect to mysql server (server=localhost, userid=mail_admin )
Nov  9 19:43:19 m34s12 courierpop3login: LOGIN FAILED, ip=[::ffff:62.47.187.132]
Nov  9 19:47:01 m34s12 authdaemond.mysql: failed to connect to mysql server (server=localhost, userid=mail_admin )
Nov  9 19:49:30 m34s12 authdaemond.mysql: failed to connect to mysql server (server=localhost, userid=mail_admin )
Nov  9 19:49:35 m34s12 courierpop3login: LOGIN FAILED, ip=[::ffff:62.47.187.132]
Nov  9 19:49:37 m34s12 authdaemond.mysql: failed to connect to mysql server (server=localhost, userid=mail_admin )
Nov  9 19:49:42 m34s12 courierpop3login: LOGIN FAILED, ip=[::ffff:62.47.187.132]
Nov  9 19:49:49 m34s12 authdaemond.mysql: failed to connect to mysql server (server=localhost, userid=mail_admin )
Nov  9 19:49:54 m34s12 courierpop3login: LOGIN FAILED, ip=[::ffff:62.47.187.132]
Nov  9 19:49:56 m34s12 authdaemond.mysql: failed to connect to mysql server (server=localhost, userid=mail_admin )
Nov  9 19:50:01 m34s12 courierpop3login: LOGIN FAILED, ip=[::ffff:62.47.187.132]
Nov  9 19:50:24 m34s12 authdaemond.mysql: failed to connect to mysql server (server=localhost, userid=mail_admin )
Nov  9 19:50:29 m34s12 courierpop3login: LOGIN FAILED, ip=[::ffff:62.47.187.132]
I was thinking if "server=localhost" could be the problem, because it should be "server=127.0.0.1"?!?!

But in my /etc/mysql/my.cnf the "bind-adress" should be ok.

Code:
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address            = 127.0.0.1
Could it be the problem? And if yes, how can I solve it?

Thanks

Michael
Please check if your MySQL server is running.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
  #18  
Old 10th November 2005, 07:56
oaky oaky is offline
Junior Member
 
Join Date: Nov 2005
Location: Salzburg / Austria
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Code:
m34s12:~# mysql -u mail_admin -p
Enter password:
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 159 to server version: 4.0.24_Debian-10sarge1-log

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> SELECT * from mail.users;
+--------------------------+---------------+----------+
| email                    | password      | quota    |
+--------------------------+---------------+----------+
| michael@m34s12.vlinux.de | mne0b8lAMlBBw | 10485760 |
| markus@m34s12.vlinux.de  | Vh3YVzrrnNkRY | 10485760 |
+--------------------------+---------------+----------+
2 rows in set (0.00 sec)
Mysql is running and mail_admin has access to mail.users.
  #19  
Old 10th November 2005, 08:40
oaky oaky is offline
Junior Member
 
Join Date: Nov 2005
Location: Salzburg / Austria
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Have a look in the table mysql.user and mysql.db. Is the host field of the user mail_admin set to "localhost" or "%"? Have you restarted the mysql server after changing the permissions and adding the mail_admin user?
Before it was "localhost" and "localhost.localdomain". (howto)

I change it to "%" and stopped and restartet mysql.
  #20  
Old 10th November 2005, 09:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
 
Default

What's in /etc/courier/authmysqlrc? Do you have authmodulelist="authmysql" in /etc/courier/authdaemonrc?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota... killfrog HOWTO-Related Questions 3 25th September 2009 21:45
Problems with postfix vervem Installation/Configuration 5 27th March 2008 19:40
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs pontifex HOWTO-Related Questions 2 26th October 2005 17:54
Removed PostFix, Now MySql Problems!!! sapient Installation/Configuration 10 24th October 2005 07:11
postfix problems. jernis Installation/Configuration 2 16th September 2005 21:14


All times are GMT +2. The time now is 03:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.