Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th March 2007, 06:01
punto punto is offline
Member
 
Join Date: Jul 2006
Posts: 84
Thanks: 12
Thanked 2 Times in 1 Post
Default Change document root for one Vhost

Hello,
I am trying to install a CMS(Website Baker) for a client and I need to change the document root from /var/www/web41/web to /var/www/web41/wb
I need to change it for the install script to execute correctly.

I edited the Vhosts_ispconfig.conf file and changed the path for this Vhost, ran the script but then when apache restarts, the path for the document root in Vhosts_ispconfig.conf is set back to /var/www/web41/web which then causes the script to crash.

Also a new web directory is created under /var/www/web41 (with a new index page), even after I removed the original one and as such when I browse to www.web41.com I get the welcome page, that is presented when you first create a website. Everything is being reset back when apache restarts and all my changes lost!

How can I make this one change for this one Vhost stay permanent?

Regards

Matt
Reply With Quote
Sponsored Links
  #2  
Old 17th March 2007, 06:15
punto punto is offline
Member
 
Join Date: Jul 2006
Posts: 84
Thanks: 12
Thanked 2 Times in 1 Post
Default

I forgot to mention adding an entry into the apache directives doesnt help either as it just adds the entry to the Vhosts_ispconfig.conf file and doesnt overwrite it, so the original reference to the document root takes precedence.
Reply With Quote
  #3  
Old 17th March 2007, 17:11
brengo brengo is offline
Junior Member
 
Join Date: Mar 2007
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

How about a symlink?

1st solution (recommended as it leaves the /web directory including its subdirectories & files intact):
ln -s /var/www/web41/web /var/www/web41/wb
run the installer for the cms afterwards - it should run fine

2nd solution (the other way round - TAKE CARE, this will DELETE all your contents including Subdirectories and files of /var/www/web41/web !!!):
rm -r /var/www/web41/web
ln -s /var/www/web41/wb /var/www/web41/web
Reply With Quote
  #4  
Old 18th March 2007, 00:43
punto punto is offline
Member
 
Join Date: Jul 2006
Posts: 84
Thanks: 12
Thanked 2 Times in 1 Post
 
Default

Brengo,

Thank you for the suggestions, the second option worked a treat!

Your help is much appreciated

Kind Regards

Matt
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
monit howto Jamesk5 HOWTO-Related Questions 11 5th August 2008 16:10
index.html make eror planet_fox Installation/Configuration 46 28th March 2007 10:10
mod_proxy / rewrite rules KenKnight Server Operation 25 30th January 2007 23:21
Apache - Virtual hosts - ISPConfig Hans Server Operation 8 23rd April 2006 17:29
cannot connect to ispconfig guidovanh Installation/Configuration 22 3rd March 2006 20:52


All times are GMT +2. The time now is 15:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.