#1  
Old 16th March 2007, 10:15
cnavarro cnavarro is offline
Junior Member
 
Join Date: Sep 2006
Location: Forest Grove, OR
Posts: 9
Thanks: 9
Thanked 0 Times in 0 Posts
Default Perfect setup ubuntu 6.06

Hi,

This is my first post so I hope I do this right. I followed the perfect setup for Ubuntu Breezy a while back with GREAT success and I'm a big fan if ISPConfig. Even though I've taken every class on linux my community college has, I still consider myself a linux noob.

I recently wanted to upgrade to a webserver and decided on Dapper Drake with ISPConfig. The only problem I had during installation was a problem I've seen on the boards with the second mysqladmin command:

mysqladmin -h myserver.mydomain.com -u root password yourrootsqlpassword

which had to be run from 127.0.0.1 in order to be successful, possibly because my router was still pointing to the old server for the domain.

When I attempted to login to https:www.mydomain.com:81 (after repointing the router) there was no website IE could find. I attempted to connect via the local IP and that wasn't successful that way either. When I go directly to the machine's IP, I get the following:



and attempts to go to the ISPConfig admin page are unsuccessful. I hope I've given enough detail to be of some help. I'd really love to get this machine online...

Christine
Reply With Quote
Sponsored Links
  #2  
Old 16th March 2007, 11:01
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

What's the output of
Code:
netstat -tap
Reply With Quote
  #3  
Old 16th March 2007, 11:08
cnavarro cnavarro is offline
Junior Member
 
Join Date: Sep 2006
Location: Forest Grove, OR
Posts: 9
Thanks: 9
Thanked 0 Times in 0 Posts
Default

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:mysql *:* LISTEN 4442/mysqld
tcp 0 0 *:81 *:* LISTEN 4802/ispconfig_http
tcp 0 0 *:ftp *:* LISTEN 5054/proftpd: (acce
tcp 0 0 mnementh.nethoun:domain *:* LISTEN 5037/named
tcp 0 0 localhost.locald:domain *:* LISTEN 5037/named
tcp 0 0 localhost.localdoma:953 *:* LISTEN 5037/named
tcp 0 0 *:smtp *:* LISTEN 4995/master
tcp6 0 0 *:imaps *:* LISTEN 4316/couriertcpd
tcp6 0 0 *op3s *:* LISTEN 4350/couriertcpd
tcp6 0 0 *op3 *:* LISTEN 4331/couriertcpd
tcp6 0 0 *:imap2 *:* LISTEN 4296/couriertcpd
tcp6 0 0 *:www *:* LISTEN 4903/apache2
tcp6 0 0 *:ssh *:* LISTEN 4620/sshd
tcp6 0 0 ip6-localhost:953 *:* LISTEN 5037/named
tcp6 0 0 *:smtp *:* LISTEN 4995/master
tcp6 0 0 *:https *:* LISTEN 4903/apache2
tcp6 0 2076 mnementh.nethoundde:ssh ::ffff:192.168.1.:50829 ESTABLISHED6356/sshd: xxxxxxxxx

Christine
Reply With Quote
  #4  
Old 16th March 2007, 13:57
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Quote:
tcp 0 0 *:81 *:* LISTEN 4802/ispconfig_http
The ISPC server is listening oke.
Quote:
When I attempted to login to https:www.mydomain.com:81 (after repointing the router) there was no website IE could find.
Are you sure your router forwards port 81 to you server (behind the NAT)? It should be
Code:
https://www.mydomain.com:81
but I assume this is a typo in the posting on the forum.
What should work is
Code:
https://192.168.1.??:81
There's no need to obfuscate 192.168 addresses, as these addresses are not reachable from the Internet anyway. The image you attached when you go directly to the machine IP is the regular webserver for your websites and is complete independent from the ISPConfig webserver.
Reply With Quote
  #5  
Old 16th March 2007, 16:23
cnavarro cnavarro is offline
Junior Member
 
Join Date: Sep 2006
Location: Forest Grove, OR
Posts: 9
Thanks: 9
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by martinfst
The ISPC server is listening oke.Are you sure your router forwards port 81 to you server (behind the NAT)? It should be
Code:
https://www.mydomain.com:81
but I assume this is a typo in the posting on the forum.
Yes, that was a typo. Sorry.

Quote:
Originally Posted by martinfst
What should work is
Code:
https://192.168.1.??:81
There's no need to obfuscate 192.168 addresses, as these addresses are not reachable from the Internet anyway. The image you attached when you go directly to the machine IP is the regular webserver for your websites and is complete independent from the ISPConfig webserver.
I tried the direct IP address also. My old machine served up the "shared IP" page when I typed in the direct IP address and properly sends me to ISPConfig's admin area when I typed https://192.168.1.100:81. This machine doesn't. They are not sending me to the same directory.

Christine
Reply With Quote
  #6  
Old 16th March 2007, 16:59
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Have you configured a firewall on the machine that doesn't work? What's the output of
Code:
iptables -L
Reply With Quote
  #7  
Old 17th March 2007, 03:46
cnavarro cnavarro is offline
Junior Member
 
Join Date: Sep 2006
Location: Forest Grove, OR
Posts: 9
Thanks: 9
Thanked 0 Times in 0 Posts
Default

Here is the output:

iptables -L

Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
Reply With Quote
  #8  
Old 17th March 2007, 07:13
cnavarro cnavarro is offline
Junior Member
 
Join Date: Sep 2006
Location: Forest Grove, OR
Posts: 9
Thanks: 9
Thanked 0 Times in 0 Posts
Default solution!

I can't believe I didn't try this... I'm such a dweeb. The ISPConfig site answers at: http://www.nethounddesign.com:81 rather than at https, which is how I intended to set it up. Is there a way to change this setting so the ISPConfig tools come up on https instead? Or do I need to reinstall?

Christine
Reply With Quote
  #9  
Old 17th March 2007, 18:09
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,183
Thanks: 829
Thanked 5,414 Times in 4,257 Posts
 
Default

Please have a look here:

http://www.howtoforge.com/forums/showthread.php?t=10179
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
cnavarro (23rd September 2007)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How stable/secure is the server after the Perfect Setup (Ubuntu 6.06) install? carloscastaneda HOWTO-Related Questions 6 3rd February 2007 18:34
The Perfect Setup - Ubuntu 6.06 LTS Server and SPAM Virus Filtering WaveQam HOWTO-Related Questions 5 19th January 2007 22:18
Extreme n00b questions re: Ubuntu 6.06 Perfect Setup titbeak HOWTO-Related Questions 2 2nd September 2006 14:09
Perfect Setup Ubuntu 6.06 Server Damnation HOWTO-Related Questions 1 19th August 2006 13:49
Help with The Perfect Setup - Ubuntu 6.06 LTS Server LinuxNewb HOWTO-Related Questions 6 30th July 2006 13:43


All times are GMT +2. The time now is 11:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.