Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Closed Thread
 
Thread Tools Display Modes
  #1  
Old 14th March 2007, 14:47
gilas gilas is offline
Member
 
Join Date: Jun 2006
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Default where is the home directory for vhosts

Hi folks,
I used ISPConfig since 2.2.4 and now I installed the last version in a new server.

The vhosts home directory for the Older version is /home/www/<host-names>/web

now the latest version point to:

/var/www/<host-names>

could be the difference is irrilevant, but I suppose the previous is more secure.
Infact the new directory structure *doesn't requires* the use of open_basedir because /var/www is the root.

I don't know what happened before or if I configured something around to use /home/www or if there is something changed with the latest 2.2.10.

Could you help me?!?

Thanks in anticipation...
Sponsored Links
  #2  
Old 14th March 2007, 15:00
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

You may use any homedir with ISPConfig, you can set it when you use the expert installation mode.

If you update a existing ISPConfig, the homedir is not changed at all, only the preset for new installations has been changed from /home/www to /var/www because it is the default in most linux distributions.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
  #3  
Old 15th March 2007, 09:37
gilas gilas is offline
Member
 
Join Date: Jun 2006
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Default what about open_basedir?

I don't remember if I installed the previous version of ISPConfig using expert mode, but when I put within /home/www/ a folder with TYPO3 to share it with several sites I was forced to add some code in apache configuration (via web, ISPConfig admin panel) to grant the access to the folder.

Now using /var/www it is not the same and the access is free.

I suppose this happens because /var/www however is browsable and I think this is not good.

Then I ask you, thanking for your patience, how can I move my sites from /var/www to /home/www.

First I think to modify some lines in /etc/apache2/apache2.conf

changing the directory from /var/www to /home/www

but I don't know where ISPConfig is configured: maybe the only parameter I saw is stored in the table

isp_server, field: server_path_httpd_root (now is set to: /var/www)

If I change apache2.conf and modify the field and restart ISPConfig it is all OK?!?

Finally could be nice add an option within the admin control panel to set this...

thank you very much...

Last edited by gilas; 15th March 2007 at 10:00.
  #4  
Old 15th March 2007, 09:43
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Dont change this folder! /var/www is the correct location.

Anyway, ISPConfig is not mady that you put any CMS directly in /var/www or /home/www, you must install the cms in a subdirectory like /var/www/web[ID]/web/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
  #5  
Old 15th March 2007, 09:44
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Quote:
First I think to modify some lines in /etc/apache2/apache2.conf
My apache2.conf is modified, so /var/www is not browsable. Think this is a good suggestion. No index.<valid ext> = no access
  #6  
Old 15th March 2007, 10:26
gilas gilas is offline
Member
 
Join Date: Jun 2006
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Default CMS location

Could be that I can put my CMS within a folder as suggested,
but the best way is to use an area out of each domain to be shared beetwen the sites actived.

MARTINFST wrote:
"My apache2.conf is modified, so /var/www is not browsable. Think this is a good suggestion. No index.<valid ext> = no access"

Which changes you made in apache2.conf?!?
Thank you again...
  #7  
Old 15th March 2007, 11:00
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Code:
.....
<Directory /var/www/sharedip>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>
.......
I just added the -Indexes to the Options
  #8  
Old 15th March 2007, 11:41
gilas gilas is offline
Member
 
Join Date: Jun 2006
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Default are you sure?!?

I verified my configuration:

Code:
<Directory /var/www/sharedip>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>
it is the same of your code...!

-Indexes was yet configured.... are you sure?!?
  #9  
Old 15th March 2007, 11:45
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Sorry, I thought I remembered well, but apparently I did not. Just reviewed my personal installation guide and it says:
Code:
Edit /etc/apache2/sites-available/default and add the lines Options None above the exiting lines and remove from the existing line Indexes.
Code:
        <Directory /var/www/>
                Options None
                #Options Indexes FollowSymLinks MultiViews
                Options FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
                # Uncomment this directive is you want to see apache2's
                # default start page (in /apache2-default) when you go to /
                #RedirectMatch ^/$ /apache2-default/
        </Directory>
  #10  
Old 15th March 2007, 12:04
gilas gilas is offline
Member
 
Join Date: Jun 2006
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default something weird...

hofff!!!!
Something doesn't work as expected. I added the line you suggested and restarted ispconfig server and apache server with no results.

To be true this is a symlink that starts from my directory:


lrwxrwxrwx 1 root root 25 2007-03-14 12:54 typo3_src -> /var/www/typo3_src-4.0.5/

this points to /var/www/typo3_src-4.0.5

I have another server with the previous version. There until added the following lines I can't use the /var/www/typo3_src-4.0.5/ contents (admin cpanel, ISP site->base):

<IfModule sapi_apache2.c>
php_admin_flag engine on
php_admin_flag safe mode off
php_admin_value open_basedir '/home/www/site.domain.it/web/:/tmp:/home/www/typo3_src'
</IfModule>


In the new server this *not happens* and it is clear that /var/www is opened for all sites inside it...

Wainting for comments, thanx
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 18:17
64-bit Debian 3.1 Install Issue naruto Installation/Configuration 14 5th September 2006 05:12
Mysterious Install Problem tgansert Installation/Configuration 5 9th May 2006 16:35
Update to 2.2.0 question brianetilley Installation/Configuration 10 4th March 2006 18:02
ISP install problems Debian sarge 3.1 lerra Installation/Configuration 1 5th January 2006 17:37


All times are GMT +2. The time now is 02:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.