Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 11th November 2005, 09:56
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by senzapaura
Another hint may come from these messages I get when restarting apache:

amgsrv1:/etc/apache2/vhosts # /etc/init.d/apache2 restart
[Thu Nov 10 09:27:43 2005] [warn] NameVirtualHost 192.168.3.170:80 has no VirtualHosts
[Thu Nov 10 09:27:43 2005] [warn] NameVirtualHost 192.168.3.170:80 has no VirtualHosts
Syntax OK
Shutting down httpd2 (waiting for all children to terminate) done
Starting httpd2 (prefork) [Thu Nov 10 09:27:45 2005] [warn] NameVirtualHost 192.168.3.170:80 has no VirtualHosts
[Thu Nov 10 09:27:45 2005] [warn] NameVirtualHost 192.168.3.170:80 has no VirtualHosts
done
amgsrv1:/etc/apache2/vhosts #
That are just warnings, nothing serious, you can forget about them.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #12  
Old 5th December 2005, 02:55
zeuben zeuben is offline
Junior Member
 
Join Date: Nov 2005
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default include path and auto prepend

when i edit the vhost entry for one of my sites and add

php_admin_value include_path .:./include:/home/www/web5/web/include:/home/www/web5/shared
php_admin_value auto_prepend_file prepend.php


apache won't start.
i also tried .htaccess but still got the 500 server error when i enabled allowOverride All

any ideas?
Reply With Quote
  #13  
Old 5th December 2005, 09:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by zeuben
when i edit the vhost entry for one of my sites and add

php_admin_value include_path .:./include:/home/www/web5/web/include:/home/www/web5/shared
php_admin_value auto_prepend_file prepend.php


apache won't start.
First, don't change your Vhosts_ispconfig.conf file manually! Your changes will be overwritten by ISPConfig!

What does
Code:
httpd -t
show when you put in these directives?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #14  
Old 23rd December 2005, 16:09
newzen newzen is offline
Junior Member
 
Join Date: Dec 2005
Location: venezuela
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Can you give us the URL of your phpinfo.php script?

Might be a problem with PHP Safe Mode or register_globals, etc...
im traying to install OSCMAX ( similar OSCOMMERCE ) they have a install. when i try to run that escript, a have the follow message

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

im running ispconfig under fedora core 4.

Iwas found all php.ini on my machine and change

registers_globals = on

and still without working

Would your maind do give me some help.

Really a have no idea and a very newbird in ispconfig and linux fedora core 4 too

thanks in advantage.
Reply With Quote
  #15  
Old 23rd December 2005, 16:11
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,478
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

have you restated apache after enabling register globals in php.ini?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #16  
Old 23rd December 2005, 16:24
newzen newzen is offline
Junior Member
 
Join Date: Dec 2005
Location: venezuela
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
have you restated apache after enabling register globals in php.ini?
im restart the complete machine is that suficient?
Reply With Quote
  #17  
Old 23rd December 2005, 16:29
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,478
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

yes, restarting the machine restarts also the apache webserver.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #18  
Old 23rd December 2005, 16:48
newzen newzen is offline
Junior Member
 
Join Date: Dec 2005
Location: venezuela
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy

Quote:
Originally Posted by till
yes, restarting the machine restarts also the apache webserver.
im restart the machine, still without working, then i do the folowing

[root@dc9f8fe88 ~]# service httpd restart
Parando httpd: [ OK ]
Iniciando httpd: [Fri Dec 23 11:43:24 2005] [warn] NameVirtualHost 201.248.254.136:80 has no VirtualHosts
(98)Address already in use: make_sock: could not bind to address [::]:443
no listening sockets available, shutting down
Unable to open logs
[FALLÓ]
[root@dc9f8fe88 ~]# service httpd restart
Parando httpd: [FALLÓ]
Iniciando httpd: [Fri Dec 23 11:44:34 2005] [warn] NameVirtualHost 201.248.254.136:80 has no VirtualHosts

i dont now how to repair that! any idea? Thanks
Reply With Quote
  #19  
Old 24th December 2005, 12:37
newzen newzen is offline
Junior Member
 
Join Date: Dec 2005
Location: venezuela
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy

Quote:
Originally Posted by senzapaura
My thanks to Falko. It was the open_base_dir value, not the safe_mode setting. Apparently what I did not understand was the value of the open_base_dir must be in the pathe of the web site. example web10 /var/www/web10/... whatever.
did you found the solution for install oscmax? if, please post the step to do or step to configure all for make that work.

thanks a lot.
Reply With Quote
  #20  
Old 24th December 2005, 13:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Quote:
Originally Posted by newzen
[root@dc9f8fe88 ~]# service httpd restart
Parando httpd: [ OK ]
Iniciando httpd: [Fri Dec 23 11:43:24 2005] [warn] NameVirtualHost 201.248.254.136:80 has no VirtualHosts
(98)Address already in use: make_sock: could not bind to address [::]:443
no listening sockets available, shutting down
Unable to open logs
[FALLÓ]
[root@dc9f8fe88 ~]# service httpd restart
Parando httpd: [FALLÓ]
Iniciando httpd: [Fri Dec 23 11:44:34 2005] [warn] NameVirtualHost 201.248.254.136:80 has no VirtualHosts
There seems to some daemon listening on port 443. Please post the output of
Code:
netstat -tap
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Loading configuration file lance Kernel Questions 2 28th February 2007 20:40
ISPConfig pop3 problem mphayesuk General 21 31st October 2005 10:53
Several minor issues dahljh Installation/Configuration 2 30th October 2005 22:22
Mail Configuration mphayesuk General 1 12th September 2005 13:16
fetchmail configuration lola Installation/Configuration 1 11th May 2005 10:57


All times are GMT +2. The time now is 23:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.