Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th March 2007, 11:06
vertex2 vertex2 is offline
Junior Member
 
Join Date: Mar 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix multi domains multi users problem

I've setup everything according to the steps in "The perfect..." tutorial. then installed ISPconfig. I've been running one domain with no problem with multiple email users. I then added another domain and added a e-mail user to that domain. However, when i send to this new user the email gets forwarded to the administrator and doesnt arrive in the users mail box.

I've searched and checked through forums for days and haven't been able to find the solution.

Here is my main.cf file:

Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname
#smtp_host_lookup = native,dns

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname=sourceline.co.za
mydomain=mail.sourceline.co.za
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin=/etc/mailname
mydestination=/etc/postfix/local-host-names
relay_domains=/etc/postfix/local-host-names
virtual_maps=hash:/etc/postfix/virtusertable
relayhost =
mynetworks = 127.0.0.0/8
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
and here are the log entries when trying to send to the newly created email ccount on the different domain:

Code:
Mar  8 05:03:32 sourceline postfix/smtpd[9787]: connect from dsl-241-45-200.telkomadsl.co.za[41.241.45.200]
Mar  8 05:03:34 sourceline postfix/smtpd[9787]: 812B7C06F7: client=dsl-241-45-200.telkomadsl.co.za[41.241.45.200], sasl_method=LOGIN, sasl_username=web2_vertex
Mar  8 05:03:36 sourceline postfix/cleanup[9788]: 812B7C06F7: message-id=<00f501c76168$f2dea8c0$d89bfa40$@co.za>
Mar  8 05:03:36 sourceline postfix/qmgr[9444]: 812B7C06F7: from=<mare@sourceline.co.za>, size=2676, nrcpt=1 (queue active)
Mar  8 05:03:36 sourceline postfix/cleanup[9788]: 7522CC07DD: message-id=<00f501c76168$f2dea8c0$d89bfa40$@co.za>
Mar  8 05:03:36 sourceline postfix/qmgr[9444]: 7522CC07DD: from=<mare@sourceline.co.za>, size=2815, nrcpt=1 (queue active)
Mar  8 05:03:36 sourceline postfix/local[9789]: 812B7C06F7: to=<web2_admin@sourceline.co.za>, orig_to=<info@cptbff.co.za>, relay=local, delay=2, status=sent (forwarded as 7522CC07DD)
Mar  8 05:03:36 sourceline postfix/qmgr[9444]: 812B7C06F7: removed
Mar  8 05:03:36 sourceline postfix/pickup[9443]: 86898C0881: uid=10023 from=<web2_vertex>
Mar  8 05:03:36 sourceline postfix/cleanup[9788]: 86898C0881: message-id=<20070308100336.86898C0881@sourceline.co.za>
Mar  8 05:03:36 sourceline postfix/local[9790]: 7522CC07DD: to=<web2_vertex@sourceline.co.za>, orig_to=<info@cptbff.co.za>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
Mar  8 05:03:36 sourceline postfix/qmgr[9444]: 7522CC07DD: removed
Mar  8 05:03:36 sourceline postfix/qmgr[9444]: 86898C0881: from=<web2_vertex@sourceline.co.za>, size=385, nrcpt=1 (queue active)
Mar  8 05:03:36 sourceline postfix/local[9789]: 86898C0881: to=<admispconfig@localhost.localdomain>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
Mar  8 05:03:36 sourceline postfix/qmgr[9444]: 86898C0881: removed

any help would be much appreciated, totally stumped.
Reply With Quote
Sponsored Links
  #2  
Old 8th March 2007, 11:45
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Please have a look here:

http://www.howtoforge.com/faq/9_33_en.html
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 8th March 2007, 11:57
vertex2 vertex2 is offline
Junior Member
 
Join Date: Mar 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the response till.

I've changed my main.cf file to the following:

Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname
#smtp_host_lookup = native,dns

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

#myhostname=sourceline.co.za
myhostname=localhost
mydomain=localhost
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin=/etc/mailname
mydestination=/etc/postfix/local-host-names
relay_domains=/etc/postfix/local-host-names
virtual_maps=hash:/etc/postfix/virtusertable
relayhost =
mynetworks = 127.0.0.0/8
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
but still getting the exact same thing, any other suggestions?
Reply With Quote
  #4  
Old 9th March 2007, 07:30
vertex2 vertex2 is offline
Junior Member
 
Join Date: Mar 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Anybody have any ideas or suggestions?
Reply With Quote
  #5  
Old 9th March 2007, 11:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Is this correct: web2_vertex shall get the email but the email appears in the mailbox of web2_admin?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 9th March 2007, 11:23
vertex2 vertex2 is offline
Junior Member
 
Join Date: Mar 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The email is being sent to info@cptbff.co.za which is username: web9_info (the intended user). It doesnt go into the web9_info account but is instead forwarded to web2_admin (then to web2_vertex due to me having a forward on all admin emails to me)
Reply With Quote
  #7  
Old 9th March 2007, 11:29
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

If you added a forward, the behaviour of your system is correct. Whats the problem then?

1) You added a forward.
2) This forward is working properly as the mail is forwarded from account 1 to account 2.

By the way, you changed myhostname and mydomain in main.cf to localhost, thats a really bad idea as all external mailservers will deny your mail. What you need is a technical domain as described in the FAQ I posted above.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 9th March 2007, 11:36
vertex2 vertex2 is offline
Junior Member
 
Join Date: Mar 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I think you may be misunderstanding me, here is what is happening:

1. mail is being sent to info@cptbff.co.za which is user web9_info
2. the mail doesnt go into the web9_info mailbox and there is no forward defined for this email user
3. the mail is being forwarded to admin@sourceline.co.za for no apparent reason (this is the admin user on the system i.e admin box checked).
4. I have a forward on the admin user that forwards all mail to my account therefore at this point it is behaving correctly but admin should have never gotten the email to begin with

I realise the mydomain myhostname config is badd currently but until i get this going i'm not too worried.
Reply With Quote
  #9  
Old 9th March 2007, 11:39
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Has web9_admin catchall enabled? If yes, the reason for this behavour is fixed by following the advice in the FAQ.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 9th March 2007, 12:45
vertex2 vertex2 is offline
Junior Member
 
Join Date: Mar 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I'm not sure i understand, web9_admin does have catchall enabled but never sees the email. I've followed the advice in the faq as per my post above. Still the same thing happens. Are you refering to another faq?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Junk mail and spamassassin... sthompson Installation/Configuration 4 27th December 2006 16:11
Virtual Users And Domains With Postfix, Courier And MySQL wmrwl HOWTO-Related Questions 73 6th October 2006 23:06
Autoreply problem using Virtual Users And Domains With Postfix, Courier And MySQL triak HOWTO-Related Questions 1 19th May 2006 15:25
Problem with Virtual Users And Domains With Postfix, Courier And MySQL Howto fenix Server Operation 4 11th March 2006 02:53
Another Problem: Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP bluegrass Installation/Configuration 24 8th March 2006 01:41


All times are GMT +2. The time now is 12:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.