#1  
Old 10th March 2007, 16:14
xxdesmus xxdesmus is offline
Junior Member
 
Join Date: Mar 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Hosts file Problems

Here is my problem, I followed the steps in this tutorial...

Install Zimbra on Ubuntu

And when I go to install Zimba (sudo ./install.sh) I get an error that I need to fix my hosts file

Currently this is how it looks:

Code:
127.0.0.1       localhost   localhost
192.168.1.10   mail.MYNAME.dyndns.org      mail
What am I doing wrong? I've also tried just using MYNAME.dyndns.org as well and I still get the same error.

Thanks for any suggestions guys...I am still a little green when it comes to Linux. (especially with networking)
Reply With Quote
Sponsored Links
  #2  
Old 10th March 2007, 17:31
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Zimbra will be the MTA. Do not reference
Quote:
192.168.1.10 mail.MYNAME.dyndns.org mail
This is totally wrong. dyndns.org is an official name and I'm sure you're not the owner of dyndns.org. 192.168 is a local ip address and you should "invent" your own name for is. Call it something like mail.myhome.loc.

The /etc/hosts issue is discussed many, many times in the Zimbra forums. Maybe you should have a look there also?
Reply With Quote
  #3  
Old 10th March 2007, 18:58
xxdesmus xxdesmus is offline
Junior Member
 
Join Date: Mar 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

still have problems,

I changed my hosts file to this:
Code:
127.0.0.1       localhost       localhost
127.0.1.1       ubuntu          ubuntu
192.168.1.10    mail.ubuntu.local       mail

and I still get the error that I need to fix it ....I don't understand what I am doing wrong here. I was asking on this forum because the How To article specifically said "don't ask questions in the comments, ask in the forums"
Reply With Quote
  #4  
Old 11th March 2007, 19:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

IS there an MX record for mail.MYNAME.dyndns.org? You can check with
Code:
dig mx mail.MYNAME.dyndns.org
Zimbra needs a valid MX record.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 11th March 2007, 22:03
xxdesmus xxdesmus is offline
Junior Member
 
Join Date: Mar 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
IS there an MX record for mail.MYNAME.dyndns.org? You can check with
Code:
dig mx mail.MYNAME.dyndns.org
Zimbra needs a valid MX record.

This is the output.

Code:
; <<>> DiG 9.3.4 <<>> mx jupaine.dyndns.org
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61453
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;jupaine.dyndns.org.            IN      MX

;; AUTHORITY SECTION:
dyndns.org.             600     IN      SOA     ns1.dyndns.org. hostmaster.dyndns.org. 3414054541 600 300 604800 600

;; Query time: 46 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Sun Mar 11 17:01:49 2007
;; MSG SIZE  rcvd: 87
As far as I can tell, this does indicate that I have a mx record correct?

As you may have gathered, I am really quite clueless as to how to setup/config the hosts file ... This is what I have at the moment:

Code:
127.0.0.1       localhost       localhost
127.0.1.1       ubuntu          ubuntu
192.168.1.10    mail.ubuntu.local       mail
Do I need to include jupaine.dyndns.org any where in the hosts file?

Last edited by xxdesmus; 11th March 2007 at 22:05.
Reply With Quote
  #6  
Old 12th March 2007, 14:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Quote:
Originally Posted by xxdesmus
This is the output.

Code:
; <<>> DiG 9.3.4 <<>> mx jupaine.dyndns.org
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61453
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;jupaine.dyndns.org.            IN      MX

;; AUTHORITY SECTION:
dyndns.org.             600     IN      SOA     ns1.dyndns.org. hostmaster.dyndns.org. 3414054541 600 300 604800 600

;; Query time: 46 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Sun Mar 11 17:01:49 2007
;; MSG SIZE  rcvd: 87
As far as I can tell, this does indicate that I have a mx record correct?
No, there's no MX record. If there was an MX record, there would be an answer section in the dig output (now you have a question and an authority section).
Please create an MX record.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 05:19
jamed up my table borders?? Boon-Dog-Danny Installation/Configuration 5 23rd September 2006 16:12
Problems with Apache and Updating Jubalint Installation/Configuration 2 21st May 2006 19:50
ISP install problems Debian sarge 3.1 lerra Installation/Configuration 1 5th January 2006 16:37


All times are GMT +2. The time now is 11:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.