Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 15th March 2007, 19:58
rneilson rneilson is offline
Junior Member
 
Join Date: Mar 2007
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

.forward is this:

administrator@markanthonymedia.com
Reply With Quote
Sponsored Links
  #12  
Old 16th March 2007, 19:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Looks ok.
What's the output of
Code:
grep testing /etc/passwd
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 17th March 2007, 01:19
rneilson rneilson is offline
Junior Member
 
Join Date: Mar 2007
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

grep testing /etc/passwd :
testing:x:10058:10001:Testing:/srv/www/web1/user/testing:/bin/false
Reply With Quote
  #14  
Old 17th March 2007, 23:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Looks ok. And what's the output of
Code:
grep 10058 /etc/passwd
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 18th March 2007, 05:47
rneilson rneilson is offline
Junior Member
 
Join Date: Mar 2007
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

testing:x:10058:10001:Testing:/srv/www/web1/user/testing:/bin/false
Reply With Quote
  #16  
Old 19th March 2007, 14:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

I was thinking that maybe there are two or more users with the same user id in /etc/passwd, but this isn't the case. To be honest, I have no idea what's wrong with your system...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #17  
Old 20th March 2007, 03:36
rneilson rneilson is offline
Junior Member
 
Join Date: Mar 2007
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Beats me, too. The best I can figure out is that for local deliveries, ie between two email addresses on the same system, postfix isn't consulting the virtusertable at all, but just /etc/aliases, which of course doesn't include any of the aliases specified by ISPConfig. And I can't figure out a way to force it.

Any hints on configuring the fallback_transport option in postfix?
Reply With Quote
  #18  
Old 20th March 2007, 03:39
rneilson rneilson is offline
Junior Member
 
Join Date: Mar 2007
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry, I should also note that this is a big problem for me. I've got several sites with an info@blah.com address, which is used by online ordering forms for the site in question. I can get the sites to change that, and create blah.info@blah.com addresses (which won't collide in local delivery) and get the PHP programmers to use that, but it seems clumsy and hackish, and means one more thing to spell out for programmers doing work for any of my sites.
Reply With Quote
  #19  
Old 20th March 2007, 09:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,045
Thanks: 842
Thanked 5,661 Times in 4,468 Posts
Default

Quote:
The best I can figure out is that for local deliveries, ie between two email addresses on the same system, postfix isn't consulting the virtusertable at all,
I dont think that. Local delivery works perfectly on all my servers. ISPConfig uses a standard setup with system users that is used on many bon ISPConfig servewrs as well for years.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #20  
Old 20th March 2007, 22:41
rneilson rneilson is offline
Junior Member
 
Join Date: Mar 2007
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

My problem seems to be similar to the one in this thread. He's using opensuse 10.2, the same as me. And I've confirmed this behaviour with multiple accounts. If there is an entry in /etc/aliases for the username portion of the email address (i.e. a system username, not an alias set up in ISPConfig), then the mail is delivered. If the recipient is only in virtusertable, then email originating on another server is processed fine, but if the origin and destination are both hosted on my server, it will fail.

Maybe there's something missing from the default configuration of opensuse 10.2's postfix package? Do your servers have an entry for fallback_transport (or something related) in /etc/postfix/main.cf?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Email Delivery Problem sedat1903 HOWTO-Related Questions 2 22nd December 2008 12:19
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 16:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 16:36
Can't receive email for aliases sbecker Installation/Configuration 10 4th April 2006 17:51
Delivery failure when using aliases ggouts Server Operation 2 20th February 2006 10:17


All times are GMT +2. The time now is 14:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.