#1  
Old 8th March 2007, 11:15
smathaven smathaven is offline
Member
 
Join Date: Oct 2006
Posts: 48
Thanks: 1
Thanked 0 Times in 0 Posts
Default error in postfix

i have install a mail server using"Virtual Users And Domains With Postfix, Courier And MySQL ", and i get this message in mail.log when i try to send mail
"mailserver postfix/local[1787] 5760a390097: to <shannen@mailserver.nccmauritius.com> relay=local delay=no status = sent (delivered to command: procmail -a"$EXTENSION"

it does not recognize users which i inserted in the table "users" and nothing appears in the directory "home/vmail", but when i send mail using debian users, mail is sent but it is in the directory "/var/mail"

where is the problem?
Reply With Quote
Sponsored Links
  #2  
Old 9th March 2007, 16:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Does shannen@mailserver.nccmauritius.com exist in your database, or is it shannen@nccmauritius.com?
What's in /etc/postfix/main.cf (please strip out the comments)?
Is shannen a system user?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 14th March 2007, 11:36
smathaven smathaven is offline
Member
 
Join Date: Oct 2006
Posts: 48
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Shannen exists as a user on the system but not in the database. When i send mail from an outside mail, the user shannen receives the mail.
The error i get in syslog is "fatal: specify a password table via the "smtp_sasl_password_maps".
can u tell me where this file is?
I also get the message "usr/lib/postfix/smtp:bad command startup throttling"
Reply With Quote
  #4  
Old 15th March 2007, 14:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Quote:
Originally Posted by smathaven
Shannen exists as a user on the system but not in the database. When i send mail from an outside mail, the user shannen receives the mail.
System users receive their mails in /var/mail, virtual users in /home/vmail. If you want the mails to go to /home/vmail, please create the user in the users table.


Quote:
Originally Posted by smathaven
The error i get in syslog is "fatal: specify a password table via the "smtp_sasl_password_maps".
can u tell me where this file is?
I also get the message "usr/lib/postfix/smtp:bad command startup throttling"
What's in /etc/postfix/main.cf?
Please post the exact error messages from your mail log.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Issues with Postfix using "Virtual Users And Domains With Postfix, Courier And MySQL" Kyse HOWTO-Related Questions 15 6th January 2007 15:35
Occasional high load on the server. kanour General 5 21st November 2006 11:27
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36
postfix starts and stops why lhatle Installation/Configuration 2 21st December 2005 15:20


All times are GMT +2. The time now is 00:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.