#1  
Old 1st March 2007, 01:09
torusturtle torusturtle is offline
Senior Member
 
Join Date: Apr 2006
Posts: 296
Thanks: 21
Thanked 24 Times in 16 Posts
Send a message via ICQ to torusturtle Send a message via AIM to torusturtle
Default php memory limit

Hi

I wanted to use typo3. Problem is that I don't have enough memory allocated for php.

I edited in /etc/php.ini the line
Code:
memory_limit = 32MB
and restarted apache.

But still I only get 8MB for typo3.

Is there another place I have to change the settings?

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 1st March 2007, 07:00
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default

Within my howto http://www.howtoforge.com/typo3_on_ispconfig at STEP 10, you read what you can change/add within your ini.php for a good TYPO3 performance.

And after changing your php.ini file, do not forget to restart Apache!
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
  #3  
Old 1st March 2007, 07:43
torusturtle torusturtle is offline
Senior Member
 
Join Date: Apr 2006
Posts: 296
Thanks: 21
Thanked 24 Times in 16 Posts
Send a message via ICQ to torusturtle Send a message via AIM to torusturtle
Default

Thanks for the Link.

Still get this Error:
Quote:
Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 58368 bytes) in /var/www/web18/web/typo3/sysext/cms/tslib/class.tslib_content.php on line 1604
I also edited the /root/ispconfig/php.ini but didn't help either.

Restarted apache with
Code:
/etc/init.d/httpd restart
on FC4.
Reply With Quote
  #4  
Old 1st March 2007, 08:25
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,703
Thanks: 819
Thanked 5,320 Times in 4,173 Posts
Default

Quote:
I also edited the /root/ispconfig/php.ini but didn't help either.
PLease undo this! This file is not realtaed to your hosted websites at all!

You are editing the wrong php.ini file. To get the correct file, ,ake a script that contains the phpinfo() function from PHP, this function will print out the path to the php.ini used by php.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 1st March 2007, 09:25
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default

I do not know which Linux distribution you are running, but on Debian Linux the location of your php4 php.ini file is:
/etc/php4/apache2/

After you've changed that php.ini file, you can restart apache with:

/etc/init.d/apache2 restart
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
  #6  
Old 1st March 2007, 12:28
torusturtle torusturtle is offline
Senior Member
 
Join Date: Apr 2006
Posts: 296
Thanks: 21
Thanked 24 Times in 16 Posts
Send a message via ICQ to torusturtle Send a message via AIM to torusturtle
Default

Quote:
Originally Posted by till
You are editing the wrong php.ini file. To get the correct file, ,ake a script that contains the phpinfo() function from PHP, this function will print out the path to the php.ini used by php.
phpinfo() function says that the php.ini file is in /etc.
I find it very odd. I even restarted the whole server but didn't help either.

Could it be that there is another file with different settings?
Reply With Quote
  #7  
Old 1st March 2007, 12:32
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

If you allow Options to be set in your .htaccess files, you can also set this parameter in .htaccess.

Mind that the default ISPConfig setup disabled the possibility to modify Options in .htaccess, but I know some people have modified apache2.conf to allow for this.
Reply With Quote
  #8  
Old 2nd March 2007, 12:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by torusturtle
Could it be that there is another file with different settings?
Please check if there's an .htaccess file in the document root of the web site that sets the PHP memory limit.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 3rd March 2007, 08:43
torusturtle torusturtle is offline
Senior Member
 
Join Date: Apr 2006
Posts: 296
Thanks: 21
Thanked 24 Times in 16 Posts
Send a message via ICQ to torusturtle Send a message via AIM to torusturtle
Default

Quote:
Originally Posted by falko
Please check if there's an .htaccess file in the document root of the web site that sets the PHP memory limit.
No there is not.

En contraire if I set
Code:
php_value memory_limit = 64M
in .htaccess I get an error 500.
Reply With Quote
  #10  
Old 3rd March 2007, 09:46
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
 
Default

As Falko and Martinfst are suggessting:

Please check if there is an .htaccessfile within your var/www/web18/web/.
To avoid the internal error no. 500, you should remove that .htacces file with the command rm .htaccess
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Freebsd 6.1 support misterm Installation/Configuration 10 9th April 2009 09:29
Slightly Confused (DNS & Server Help) JohnnyBGoode Installation/Configuration 26 14th August 2007 09:54
VirtualHosts marra87 General 9 12th September 2006 04:09
Downgrade php5 to php4.4.2 llizards Installation/Configuration 4 13th March 2006 23:58
Ispconfig and Virtuemart shajazzi Installation/Configuration 7 21st February 2006 20:25


All times are GMT +2. The time now is 18:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.