Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th December 2007, 12:38
tellar tellar is offline
Member
 
Join Date: Jun 2006
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Default Apache Down and Wont Restart

After working for ages without problems everything is still working ispconfig is fine and online but Apache wont start

I have tried the command through ssh

root@server1:/# /etc/init.d/httpd restart
bash: /etc/init.d/httpd: No such file or directory
root@server1:/#

where is httpd ?

Are my sites gone?

HELP!
Reply With Quote
Sponsored Links
  #2  
Old 30th December 2007, 12:55
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default

Please try: /etc/init.d/apache2 restart
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
  #3  
Old 30th December 2007, 13:46
tellar tellar is offline
Member
 
Join Date: Jun 2006
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Default ok done that

have run the command and apache tries to restart.

apache gives the error that allow override is not allowed on line 368 in the virtualhost file

have commented ot this line and in the other files now I get the message that there are no virual hosts
"
[Sun Dec 30 13:46:00 2007] [warn] NameVirtualHost "My IP" has no VirtualHosts"
Reply With Quote
  #4  
Old 30th December 2007, 14:08
tellar tellar is offline
Member
 
Join Date: Jun 2006
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Default httpd (no pid file) not running

httpd (no pid file) not running

this message is also being given

apache is running but sites are not available
Reply With Quote
  #5  
Old 30th December 2007, 16:06
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,453
Thanks: 813
Thanked 5,222 Times in 4,092 Posts
Default

please run:

httpd -t

and post the error message.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 30th December 2007, 17:18
tellar tellar is offline
Member
 
Join Date: Jun 2006
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Default Results

root@server1:/etc/apache2/vhosts# httpd -t
[Sun Dec 30 17:04:27 2007] [warn] NameVirtualHost 80.69.93.79:80 has no VirtualHosts
Syntax OK


(I have made a new folder /vtmp and copied all files from hosts there then made a change in ispconfig site settings and duplicated the new ispconfighosts file as Vhosts)


there is still access to the sites but apache starts
Reply With Quote
  #7  
Old 30th December 2007, 17:57
tellar tellar is offline
Member
 
Join Date: Jun 2006
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default [problem solved]

Ok it works again,

with ispconfig open I deleted the files in /etc/apache2/vhosts

mkdir /vtmp (make a new directory to store the backup files in)

then copied all the files from /etc/apache2/vhosts there

cp Vhosts /vtmp/Vhosts.bak
cp vhosts /vtmp/Vhosts.bak

I deleted the files in /etc/apache2/vhosts

rm Vhosts
rm vhosts

then added # in one of the sites directives in the controll pannel for that site

then removed it

ispconfig writes a new virtual hosts file and it came back online
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 17:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.