Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th February 2007, 13:58
dragon67 dragon67 is offline
Junior Member
 
Join Date: Feb 2007
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default 500 error - Internal Server Error Problems

Hi,

I have an Problem with my htaccess file

This is the file:

AddType image/jpeg .jpeg
AddType image/jpeg .jpg
AddType image/gif .gif
ErrorDocument 404 /xboxgc/xboxrel.php
Options -Indexes

when i use it i get

500 error - Internal Server Error Problems


At the error log i can only find this

[Tue Feb 27 13:29:34 2007] [alert] [client 192.168.0.1] /var/www/web3/web/xboxgc/.htaccess: Options not allowed here

How can i fix this ???

Thank You

Reiner
Reply With Quote
Sponsored Links
  #2  
Old 27th February 2007, 16:53
dragon67 dragon67 is offline
Junior Member
 
Join Date: Feb 2007
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok,

i think i have found the problem, i need mod_autoindex

but how can i install and activate the mod_autoindex

found it here:

http://httpd.apache.org/docs/2.0/mod/mod_autoindex.html

but not how to install and activate the mod_autoindex

i hope someone can give me an tip

Ciao

Reiner
Reply With Quote
  #3  
Old 27th February 2007, 17:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

The problem is not a missing mod_autoindex module. The problem is that it is not allowed to use "Options -Indexes" in a .htaccess file for security reasons.

Either you put the content of the .htaccess file in the apache directives field of the website and delete the .htaccess file or you allow the setting of options and AddTypes by changing the AllowOverride directive for the web directories to e.g. "AllowOverride All" in your httpd configuration file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 27th February 2007, 17:48
dragon67 dragon67 is offline
Junior Member
 
Join Date: Feb 2007
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

???

Sorry ich versuche es einfach mal in deutsch

Ich benutze ISPConfig Appliance fr VMWare

und die httpd.conf ist leer

Dort ist aber die apache2.conf von der aus auf die Vhosts_ispconfig.conf verwiesen wird

mod_autoindex habe ich nicht gefunden und in welche der conf Dateien ich nun was eintragen muss weiss ich auch nicht


Aber fr Hilfe wre ich dankbar

Reiner

Last edited by dragon67; 27th February 2007 at 17:53.
Reply With Quote
  #5  
Old 27th February 2007, 18:13
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,035
Thanks: 267
Thanked 153 Times in 133 Posts
Default

Quote:
Originally Posted by dragon67
???

Sorry ich versuche es einfach mal in deutsch

Ich benutze ISPConfig Appliance fr VMWare

und die httpd.conf ist leer

Dort ist aber die apache2.conf von der aus auf die Vhosts_ispconfig.conf verwiesen wird

mod_autoindex habe ich nicht gefunden und in welche der conf Dateien ich nun was eintragen muss weiss ich auch nicht


Aber fr Hilfe wre ich dankbar

Reiner
ワシントン――イラク駐留米軍に撤退期限を設けることに、米国民の半数以上が賛成していることが、26日発 表された米紙ワシントン・ポストとABCテレビの世論調査で明らかになった。この調査で期限設定への賛成が 過半数に達したのは初めて

Keep it in English please!
__________________
Never execute code written on a Friday or a Monday.

Last edited by edge; 27th February 2007 at 18:17.
Reply With Quote
  #6  
Old 27th February 2007, 19:42
dragon67 dragon67 is offline
Junior Member
 
Join Date: Feb 2007
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok,

When i put the content of the .htaccess file in the Vhosts_ispconfig.conf and delete the .htaccess i get
500 error - Internal Server Error Problems


When i set "AllowOverride All" in the Vhosts_ispconfig.conf and use an .htaccess i get too

500 error - Internal Server Error Problems
Reply With Quote
  #7  
Old 27th February 2007, 19:48
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

You should not edit Vhosts_ispconfig.conf; it will change with every new website you make or every change you apply.

Edit the /etc/apache2/apache2.conf file and somewhere at the end make it look like:
Code:
<snipped>........
###############ispconfig_log###############
LogFormat "%v||||%b||||%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig

<Directory /home/ispwww/*/web>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo Options
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>

<Directory /home/ispwww/*/user/*/web>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
.....
<snipped rest of file>
Reply With Quote
  #8  
Old 27th February 2007, 20:02
dragon67 dragon67 is offline
Junior Member
 
Join Date: Feb 2007
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you

I have set now AllowOverride All at the apache2.conf file

But the error is still the same

http://xlt-clan.net/xboxgc/dragontec.fci.gif
Reply With Quote
  #9  
Old 27th February 2007, 20:54
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

What's in the error log:
Code:
<ispc webdir>/webnn/log/error.log
now? Did you remove the offending Options from your .htaccess file?
Reply With Quote
  #10  
Old 27th February 2007, 22:58
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
 
Default

Additionally, had you restarted your webserver after you changed the apache2.conf file?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
php Apps email not going through palkat General 8 21st September 2011 05:35
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
ispconfig and mambo shajazzi Installation/Configuration 70 28th March 2006 19:29
Email - Ueb-Miau mazhar Installation/Configuration 5 21st December 2005 10:01
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 02:30


All times are GMT +2. The time now is 09:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.