#1  
Old 27th February 2007, 21:02
lunardi lunardi is offline
Member
 
Join Date: Dec 2006
Location: Brazil
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Skype™ to lunardi
Default error in uebimiau with big mail

hy all,

I need help.

I'm receive an big mail (4237 Kb) and open show message:


Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 1314754 bytes) in /home/admispconfig/ispconfig/web/webmail/inc/class.uebimiau.php on line 621


In file, I'm not identify error.
Thanks
__________________
Lunardi
Reply With Quote
Sponsored Links
  #2  
Old 27th February 2007, 21:06
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Increase the memory setting in php.ini. The default is 16M.
Reply With Quote
  #3  
Old 27th February 2007, 21:18
lunardi lunardi is offline
Member
 
Join Date: Dec 2006
Location: Brazil
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Skype™ to lunardi
Default

Hy again,

But in squirrelmail not show error, just in uebimiau !

The line to change in php.ini is memory_limit = 8M ?

Thanks again
__________________
Lunardi
Reply With Quote
  #4  
Old 27th February 2007, 21:27
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Attachments are encoded. Squirrel and uebimiau may use different encoding techniques (don't know, just guessing).

Encoding almost always at least doubles the required memory, especisally during the composing phase of emails.

Yes, upgrade memory_limit to 16M or 32M
Reply With Quote
  #5  
Old 27th February 2007, 21:41
lunardi lunardi is offline
Member
 
Join Date: Dec 2006
Location: Brazil
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Skype™ to lunardi
Default

Hy,

I'm change to 16, 32 and 64.

Restart with command:
/etc/init.d/apache2 restart

Nothing, continue same error...

Some idea ?

Thanks
__________________
Lunardi
Reply With Quote
  #6  
Old 27th February 2007, 22:01
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Did you pick the right php.ini? You can search your server with
Code:
locate php.ini
. Also, there is no .htaccess file in either your webdir or the uebimiau install directory? If you want to know which php.ini file is used, create a small program in your webroot: phpinfo.php. Contents of this file:
Code:
<?php

// Show all information, defaults to INFO_ALL
phpinfo();

?>
Remember to remove this file on a public server.
Reply With Quote
  #7  
Old 27th February 2007, 22:29
lunardi lunardi is offline
Member
 
Join Date: Dec 2006
Location: Brazil
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Skype™ to lunardi
Default

Hy,

I'm change the files:

/etc/php5/apache2/php.ini
/etc/php5/cli/php.ini
/root/ispconfig/php/php.ini

In all files, upgrade for 64M and now OK.

Thanks
__________________
Lunardi
Reply With Quote
  #8  
Old 28th February 2007, 09:10
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
 
Default

As you apparently use the packages, changing /root/ispconfig/php/php.ini would be all you need to do. I could have said that earlier, I guess
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix & mail forwarding loop varnik Server Operation 21 9th December 2008 15:13
Postfix reject connections gabrix Server Operation 27 25th January 2007 08:37
postfix-tls sasl2 mysql courier-authmysql gabrix Server Operation 4 12th January 2007 22:09
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 12:16
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 11:47


All times are GMT +2. The time now is 01:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.