#1  
Old 26th February 2007, 23:07
ctpaba ctpaba is offline
Junior Member
 
Join Date: Feb 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default ispconfig & alias squirrelmail

hello
I have ISPCONFIG on Debian Sarge with SquirrelMail and all work great, access at webmails in http://mydomain.tld:81/squirrelmail/src/login.php work good.
I wish to create alias in /etc/apache2/apache2.conf for access with next url http://mydomain.tld/webmail adding a line Alias /webmail /home/admispconfig/ispconfig/web/squirrelmail normaly this work but i have next error message

Warning: Unknown(): open_basedir restriction in effect. File(/home/admispconfig/ispconfig/web/squirrelmail/index.php) is not within the allowed path(s): (/home/www/web12/) in Unknown on line 0

Warning: Unknown(/home/admispconfig/ispconfig/web/squirrelmail/index.php): failed to open stream: Operation not permitted in Unknown on line 0

Warning: (null)(): Failed opening '/home/admispconfig/ispconfig/web/squirrelmail/index.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in Unknown on line 0


any idea ?

P.S. sry for my bad english
Reply With Quote
Sponsored Links
  #2  
Old 27th February 2007, 08:28
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,070
Thanks: 826
Thanked 5,396 Times in 4,240 Posts
Default

Your PHP installation has a open basedir restriction set, thats why it cant include the php files from ISPConfig.

If this is a website created in ISPCOnfig, then you will have to disable the php safemode checkbox for it.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 28th February 2007, 00:08
ctpaba ctpaba is offline
Junior Member
 
Join Date: Feb 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

in my php.ini "open_basedir" was comment for disabled this option. I was try to uncomment and set "open_basedir = /" but I have allready same error.

in my server I have 3 php.ini :
/etc/php4/cli/php.ini
/etc/php4/apache2/php.ini
/root/ispconfig/php/php.ini

this parameter was changed in all php.ini files

10x
Reply With Quote
  #4  
Old 28th February 2007, 08:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,070
Thanks: 826
Thanked 5,396 Times in 4,240 Posts
 
Default

If there was a comment sign, this function was already deactivated. Please undo your changes in the php.ini files. Please bever edit the file /root/ispconfig/php/php.ini if you wont break ISPConfig!

As open_basedir was disbled already, please do waht I posted above:

Quote:
If this is a website created in ISPCOnfig, then you will have to disable the php safemode checkbox for it.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPconfig after installation cannot reach www.xyz.de:81 Figth4Linux Installation/Configuration 23 6th March 2008 22:38
SquirrelMail on IspConfig: Can't send ai_77 Installation/Configuration 8 27th February 2007 08:39
squirrelmail and ispconfig munika Installation/Configuration 4 31st January 2007 21:01
Squirrelmail and Serversidefilter with ISPConfig Schmickers Tips/Tricks/Mods 2 29th August 2006 20:34
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 15:16


All times are GMT +2. The time now is 00:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.