Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd November 2005, 15:43
rayit rayit is offline
Member
 
Join Date: Nov 2005
Posts: 93
Thanks: 0
Thanked 2 Times in 2 Posts
Question webmail URL problems

I have 3 servers now 2 42go servers and 1 ispconfig server.

ns1.rayit.com
ns2.rayit.com
ns3.rayit.com

If I go to https://ns1.rayit.com:81/webmail

It changes to https://rayit.com:81/webmail/ and this is the other server (ns2.rayit.com) not the ns1.
So I can not login with users from ns1.

Is there a way to solve this ?

many thanks


Raymond
Reply With Quote
Sponsored Links
  #2  
Old 2nd November 2005, 16:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Does ns1.rayit.com resolve correctly to the right system?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 2nd November 2005, 16:25
rayit rayit is offline
Member
 
Join Date: Nov 2005
Posts: 93
Thanks: 0
Thanked 2 Times in 2 Posts
Default resolv

If I do a ping ns1 resolves to the right system, alse there are no problems with using ISPConfig.

H:\>ping ns1.rayit.com

Pinging ns1.rayit.com [80.100.251.30] with 32 bytes o

Reply from 80.100.251.30: bytes=32 time=112ms TTL=42
Reply from 80.100.251.30: bytes=32 time=115ms TTL=42

H:\>nslookup ns1.rayit.com
Server: castor.krk.medt
Address: 144.15.73.31

Non-authoritative answer
Name: ns1.rayit.com
Address: 80.100.251.30
Reply With Quote
  #4  
Old 2nd November 2005, 18:56
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

What's in /root/42go/httpd/conf/httpd.conf as ServerName? Is it ns1.rayit.com?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 2nd November 2005, 20:57
rayit rayit is offline
Member
 
Join Date: Nov 2005
Posts: 93
Thanks: 0
Thanked 2 Times in 2 Posts
Default Solved!

Changed Servername to ns1 and works ok now!!!

Many thanks

<VirtualHost _default_:81>

# General setup for the virtual host
DocumentRoot "/home/admispconfig/ispconfig/web"
ServerName ns1.rayit.com
ServerAdmin root@rayit.com
ErrorLog /root/ispconfig/httpd/logs/error_log
TransferLog /root/ispconfig/httpd/logs/access_log
Reply With Quote
  #6  
Old 2nd November 2005, 21:27
rayit rayit is offline
Member
 
Join Date: Nov 2005
Posts: 93
Thanks: 0
Thanked 2 Times in 2 Posts
Default Now problem users can not login.

Not possible to login to webmail .

I saw same problem in other topic, tried serveral but still can not login with email address and password

See logs below, do you have suggestions???



Nov 2 21:14:36 ns3 ipop3d[1219]: pop3 service init from 127.0.0.1
Nov 2 21:14:36 ns3 ipop3d[1219]: Command stream end of file while reading line user=??? host=localhost.localdomain [127.0.0.1]

ns3:/home/www/web1# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
220 localhost ESMTP Postfix (Debian/GNU)
ehlo localhost
250-localhost
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
Reply With Quote
  #7  
Old 2nd November 2005, 21:36
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,395
Thanks: 833
Thanked 5,490 Times in 4,322 Posts
Default

Have you send an email to the user before you tried to login? The Maildir or mbox is created when the first email arrives.
Reply With Quote
  #8  
Old 3rd November 2005, 21:52
rayit rayit is offline
Member
 
Join Date: Nov 2005
Posts: 93
Thanks: 0
Thanked 2 Times in 2 Posts
Default ah, mail does not deliver wright!!

AS you can see in the log file below he does
if I send mail to rmarx@rayit.com on the ns1.rayit.com it changes it to
web2_rmarx@ns3.rayit.com!! why I do not know.!!


ns1:/var/spool/mail# mail rmarx@rayit.com
Subject: test
test
Cc:
ns1:/var/spool/mail# mailq
-Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
6BEBB372717* 2303 Thu Nov 3 22:21:55 MAILER-DAEMON
root@ns3.rayit.com??????


A ping to mail.rayit.com gives ns1 ip address.

Do you know where to search...


Nov 3 21:48:38 localhost postfix/smtp[9356]: 4F6CB372715: to=<web2_rmarx@ns3.rayit.com>, orig_to=<rmarx@rayit.com>, relay=ns3.rayit.com[80.100.12.206], delay=1, status=bounced (host ns3.rayit.com[80.100.12.206] said: 550 <web2_rmarx@ns3.rayit.com>: Recipient address rejected: User unknown in local recipient table (in reply to RCPT TO command))

Last edited by rayit; 3rd November 2005 at 22:23.
Reply With Quote
  #9  
Old 3rd November 2005, 22:36
rayit rayit is offline
Member
 
Join Date: Nov 2005
Posts: 93
Thanks: 0
Thanked 2 Times in 2 Posts
Default solved partly

/etc/mailname !!!! had the wrong entry do not ask me how it got there!!

changed that..

now trying to solve remote mailing..

Think DNS problem

changed rayit.com from ns2 to ns1 and mail still goes to NS2 ...

Last edited by rayit; 3rd November 2005 at 22:44.
Reply With Quote
  #10  
Old 3rd November 2005, 22:49
rayit rayit is offline
Member
 
Join Date: Nov 2005
Posts: 93
Thanks: 0
Thanked 2 Times in 2 Posts
 
Default YES i am getting mail on ns1 BUT

The webmail and pop3 login still does not work ...
The account web2_rmarx has mails in it.
But can not login webmail with rmarx@rayit.com
or with pop3

Nov 3 22:47:13 localhost ipop3d[12976]: pop3 service init from 127.0.0.1
Nov 3 22:47:13 localhost ipop3d[12976]: Command stream end of file while reading line user=??? host=localhost.localdomain [127.0.0.1]


Nov 3 22:52:04 localhost ipop3d[13163]: pop3 service init from 80.100.12.206
Nov 3 22:52:04 localhost ipop3d[13163]: Command stream end of file while reading line user=??? host=dsl206-12-100.fastxdsl.nl [80.100.12.206]


please help

Raymond
RayIT

Last edited by rayit; 3rd November 2005 at 22:54.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with groups/grpconv linuxfast General 28 21st April 2008 09:35
webmail url trailing slash hairydog2 Installation/Configuration 4 2nd November 2005 21:39
E-mail send and recieve problem thebigfing Installation/Configuration 14 25th August 2005 15:58
webmail m u r Installation/Configuration 4 21st August 2005 16:49
Webmail access from different address? maxx General 1 30th July 2005 12:22


All times are GMT +2. The time now is 04:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.