Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd November 2005, 11:42
Genghis Genghis is offline
Junior Member
 
Join Date: Nov 2005
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default DNS allow-transfer for secundary NS

Hi,

I'm trying to add a new domain to my dedicated box using ispconfig.
I'm using that box as the primary nameserver, and I would like to use a secondary nameserver at some free dns hoster.
Now, the problem is, that I need a "allow-transfer" part in my /etc/bind/named.conf , but it seems there is no option @ ispconfig like that...

I tried commenting out the original zone in named.conf (generated by ispconfig) and add a new zone in the "//// MAKE MANUAL ENTRIES BELOW THIS LINE! ////" zone, having allow-transfer as an option for that domain.
It works fine untill I edit or make a new entry for that domain using ispconfig, since ispconfig is generating a new zone for that domein, and is reloading Bind, wich wont startup due to duplicate zone in named.conf.

Here are my configs:

//ORIGINAL CREATED BY ISPCONFIG named.conf

zone "example.com" {
type master;
file "pri.example.com";
};

// I deleted the above and made a new entry manually:

//// MAKE MANUAL ENTRIES BELOW THIS LINE! ////

zone "example.com" {
type master;
file "pri.example.com";
allow-transfer {
192.168.0.1;
};
};

That works fine, untill I make a change to the domain using ISPCONFIG.

Anyone had the same prob and found a solution?

Thanks in advance,
Genghis
Reply With Quote
Sponsored Links
  #2  
Old 2nd November 2005, 11:58
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,958
Thanks: 825
Thanked 5,362 Times in 4,209 Posts
Default

You have to edit the master template for the named.conf in /root/ispconfig/isp/conf/named.conf.master instead of the named.conf file itself.

But i dont think it is nescessary, Iam using ISPCOnfig in a setup with primary and secondary NS incl. zonetransfers and dont have to change anything in the default setup.
Reply With Quote
  #3  
Old 2nd November 2005, 12:01
Genghis Genghis is offline
Junior Member
 
Join Date: Nov 2005
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
You have to edit the master template for the named.conf in /root/ispconfig/isp/conf/named.conf.master instead of the named.conf file itself.

But i dont think it is nescessary, Iam using ISPCOnfig in a setup with primary and secondary NS incl. zonetransfers and dont have to change anything in the default setup.
Do you care to share how you did it without having to change anything in the default setup?

Thanks,
Genghis
Reply With Quote
  #4  
Old 2nd November 2005, 12:05
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,958
Thanks: 825
Thanked 5,362 Times in 4,209 Posts
Default

Have you tried a zone transfer?
Reply With Quote
  #5  
Old 2nd November 2005, 12:56
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

The zone transfers should work out of the box. Have you tried to set up a secondary DNS record at your DNS hoster?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 2nd November 2005, 13:40
Genghis Genghis is offline
Junior Member
 
Join Date: Nov 2005
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by falko
The zone transfers should work out of the box. Have you tried to set up a secondary DNS record at your DNS hoster?
so you mean just setting it up using ISPCONFIG without specifying the allow transfer or anything related?

[edit]
Ok, I'm gonna shoot myself, trying to find a solution for something that works out of the box LOL
Maybe adding 1 line to the documentation would be handy:
"Note: There is no need to mess with allow-transfer, setting a secundary nameserver will do that by default"


Thanks for the fast replies guy's
Genghis
[/edit]

Last edited by Genghis; 2nd November 2005 at 14:02.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Support for apache vhost transfer limits till Feature Requests 2 25th September 2005 00:42


All times are GMT +2. The time now is 11:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.