#1  
Old 2nd November 2005, 01:18
hairydog2 hairydog2 is offline
Senior Member
 
Join Date: Oct 2005
Posts: 196
Thanks: 9
Thanked 3 Times in 2 Posts
Default webmail url trailing slash

All seems to be working well with ISPConfig - but I have noticed an odd thing with the webmail login.

https://www.domain.com:81/webmail fails to do anything but
https://www.domain.com:81/webmail/ works. I thought that apache added the missing / if it was needed, so why not here?

I've also noticed that on one of the hosted websites, there is a directory whose index page is index.php but going to that directory doesn't open the index page, even thought index.php is listed as an index file name.

I wonder if these two are linked problems. Whether or not, I'd appreciate any suggestions!
Reply With Quote
Sponsored Links
  #2  
Old 2nd November 2005, 10:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Does www.domain.com resolve to your ISPConfig system?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 2nd November 2005, 19:10
hairydog2 hairydog2 is offline
Senior Member
 
Join Date: Oct 2005
Posts: 196
Thanks: 9
Thanked 3 Times in 2 Posts
Default

Yes. I have ao add more words here to make the message save, but the answer is just "yes".
Reply With Quote
  #4  
Old 2nd November 2005, 19:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

What's in /root/ispconfig/httpd/conf/httpd.conf as ServerName? Is it www.domain.com?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:

Last edited by falko; 2nd November 2005 at 19:55.
Reply With Quote
  #5  
Old 2nd November 2005, 22:39
hairydog2 hairydog2 is offline
Senior Member
 
Join Date: Oct 2005
Posts: 196
Thanks: 9
Thanked 3 Times in 2 Posts
 
Default

I think you may have identified the problem.

The actual address I'm using is https://hosting.hairydog.co.uk:81/webmail

There is no site at http://hosting.hairydog.co.uk yet, just the default index.html

The plan is to have a completely different site at http://hairydog.co.uk and the same at http://www.hairydog.co.uk (though the DNS for that points somewhere else at present)

The ServerName was set as hairydog.co.uk but I've changed it to hosting.hairydog.co.uk - and that seems to have fixed the problem.

Thank you for your help.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Support for other Webmail programs (HORDE) pontifex Feature Requests 14 1st December 2005 17:57
Best webmail interface? mike Server Operation 7 8th September 2005 19:54
webmail is using the 'wrong' email .. :( hagel General 3 16th August 2005 21:16
webmail and pop3 quicklinux General 8 9th August 2005 01:15
Webmail access from different address? maxx General 1 30th July 2005 13:22


All times are GMT +2. The time now is 08:04.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.