Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd February 2007, 16:49
compner compner is offline
Junior Member
 
Join Date: Feb 2007
Posts: 4
Thanks: 0
Thanked 3 Times in 2 Posts
Default Webmail problems with only one domain?

Hello,

I am running ispconfig on centos 4.4 with postfix and dovecot. I currently am hosting 16 domains and everything is working nicely, except for one single domain. I cannot get webmail to work with this one domain. I have tried squirrelmail, roundcube, and uebimiau. All of these packages work just fine for all of my domains, but none of these will work properly for this one domain.
I have also tried openwebmail, which actually does work for everybody including this problem domain, except that I cannot get any icons to show?? (i have followed threads for that problem but none solved that problem for me)

Anyways back to this one domain. The mail account itself works fine, I can connect with thunderbird and send/receive no problem. Also openwebmail it works fine, apart from the icons.

When I log in using Squirrelmail, it shows this error:

ERROR: Connection dropped by IMAP server.
Query: CAPABILITY

Not one of my other domains has this problem with Squirrelmail.

When I log in with Uebimiau, it will not display the inbox. I can send mail no problem through uebimiau, but it will not display any messages in the inbox. Again, not one of my other domains has this problem.

When I log in with roundcube, all I get is a blank page. Other domains work fine.

I have deleted and recreated this domain 3 times now, and always have the same issue. I can add another domain and it will work fine. Php scripts and mysql are enabled, just like the other accounts. What's driving me nuts is that the domain's email account works fine, but why these errors on only this domain even after wiping and recreating it? I will try and figure out the openwebmail icon problem and get them using that, but there is obviously an underlying issue here that I need to resolve to prevent future problems.

Help?
Reply With Quote
The Following User Says Thank You to compner For This Useful Post:
AbannyvabVask (14th December 2013)
Sponsored Links
  #2  
Old 23rd February 2007, 17:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Any errors in the mail log and Apache's error log?
What's the domain name? Can you post the vhost configuration here?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 23rd February 2007, 18:32
compner compner is offline
Junior Member
 
Join Date: Feb 2007
Posts: 4
Thanks: 0
Thanked 3 Times in 2 Posts
Default

Actually the problem has now progressed, this morning I went to check my email with thunderbird and was unable to log in, seems all my domains now have a new problem!

I am getting this error in the logs:


dovecot: chroot directory no included in valid_chroot_dirs: /var/www/web2

I have not touched my dovecot.conf file, it has this line commented out:

#valid_chroot_dirs =

but until yesterday things were working fine. Should I now set this value to something? Googling did not help, I tried setting this to /var/mail and /var/www and restarting dovecot but that did not help either.

I got openwebmail working yesterday (got the icons to finally show) but now the dovecot problem, only I did not change this. Help?
Reply With Quote
The Following 2 Users Say Thank You to compner For This Useful Post:
AbannyvabVask (18th December 2013), badizzycgoogltay2190 (9th October 2012)
  #4  
Old 24th February 2007, 12:22
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,487
Thanks: 835
Thanked 5,524 Times in 4,345 Posts
Default

Never seen this problem before. Can you disable chrooting in dovecot.conf file?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 8th January 2008, 03:41
Chip Chip is offline
Junior Member
 
Join Date: Nov 2007
Posts: 12
Thanks: 3
Thanked 2 Times in 1 Post
Default

I have a simmilar problem, error: capability when trying to use squirrelmail, I don't quite know what to do or where to start looking for errors.
Reply With Quote
The Following 2 Users Say Thank You to Chip For This Useful Post:
AbannyvabVask (19th December 2013), robertoshulze2257 (16th October 2014)
  #6  
Old 8th January 2008, 19:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Any errors in your mail log (in /var/log)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 5th February 2008, 18:38
Chip Chip is offline
Junior Member
 
Join Date: Nov 2007
Posts: 12
Thanks: 3
Thanked 2 Times in 1 Post
Default

The following error shows up when I try to login via sentimail:


Quote:
.: There were errors :.

There were errors in the process

Please login again

System message: Error connecting to the server

Code:
Feb  5 16:29:28 server dovecot: imap-login: imap-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:29:28 server dovecot: imap-login: imap-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:29:28 server dovecot: pop3-login: pop3-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:29:28 server last message repeated 2 times
Feb  5 16:29:28 server dovecot: child 29165 (login) returned error 127
Feb  5 16:29:28 server dovecot: child 29166 (login) returned error 127
Feb  5 16:29:28 server dovecot: child 29167 (login) returned error 127
Feb  5 16:29:28 server dovecot: child 29168 (login) returned error 127
Feb  5 16:29:28 server dovecot: child 29169 (login) returned error 127
Feb  5 16:29:28 server dovecot: imap-login: imap-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:29:28 server dovecot: child 29170 (login) returned error 127
Feb  5 16:30:28 server dovecot: imap-login: imap-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:30:28 server last message repeated 2 times
Feb  5 16:30:28 server dovecot: pop3-login: pop3-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:30:28 server last message repeated 2 times
Feb  5 16:30:28 server dovecot: child 29286 (login) returned error 127
Feb  5 16:30:28 server dovecot: child 29287 (login) returned error 127
Feb  5 16:30:28 server dovecot: child 29288 (login) returned error 127
Feb  5 16:30:28 server dovecot: child 29289 (login) returned error 127
Feb  5 16:30:28 server dovecot: child 29290 (login) returned error 127
Feb  5 16:30:28 server dovecot: child 29291 (login) returned error 127


Feb  5 16:31:28 server dovecot: pop3-login: pop3-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:31:28 server last message repeated 2 times
Feb  5 16:31:28 server dovecot: child 29343 (login) returned error 127
Feb  5 16:31:28 server dovecot: child 29344 (login) returned error 127
Feb  5 16:31:28 server dovecot: child 29345 (login) returned error 127
Feb  5 16:31:28 server dovecot: imap-login: imap-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:31:28 server dovecot: child 29346 (login) returned error 127
Feb  5 16:31:28 server dovecot: imap-login: imap-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:31:28 server dovecot: child 29348 (login) returned error 127
Feb  5 16:31:28 server dovecot: imap-login: imap-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:31:28 server dovecot: child 29347 (login) returned error 127
And when I try to use squirrelmail:

Quote:
ERROR:
ERROR: Connection dropped by IMAP server.
Query: CAPABILITY
Code:
Feb  5 16:35:28 server dovecot: pop3-login: pop3-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:35:28 server dovecot: pop3-login: pop3-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:35:28 server dovecot: child 29713 (login) returned error 127
Feb  5 16:35:28 server dovecot: child 29714 (login) returned error 127
Feb  5 16:35:28 server dovecot: child 29716 (login) returned error 127
Feb  5 16:35:28 server dovecot: imap-login: imap-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:35:28 server dovecot: pop3-login: pop3-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:35:28 server dovecot: child 29715 (login) returned error 127
Feb  5 16:35:28 server dovecot: imap-login: imap-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:35:28 server dovecot: child 29717 (login) returned error 127
Feb  5 16:35:28 server dovecot: imap-login: imap-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:35:28 server dovecot: child 29718 (login) returned error 127

Feb  5 16:36:28 server dovecot: pop3-login: pop3-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:36:28 server last message repeated 2 times
Feb  5 16:36:28 server dovecot: child 29841 (login) returned error 127
Feb  5 16:36:28 server dovecot: child 29842 (login) returned error 127
Feb  5 16:36:28 server dovecot: child 29843 (login) returned error 127
Feb  5 16:36:28 server dovecot: imap-login: imap-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:36:28 server dovecot: imap-login: imap-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:36:28 server dovecot: child 29844 (login) returned error 127
Feb  5 16:36:28 server dovecot: imap-login: imap-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:36:28 server dovecot: child 29846 (login) returned error 127
Feb  5 16:36:28 server dovecot: child 29845 (login) returned error 127


Feb  5 16:37:28 server dovecot: imap-login: imap-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:37:28 server dovecot: pop3-login: pop3-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:37:28 server last message repeated 2 times
Feb  5 16:37:28 server dovecot: child 29972 (login) returned error 127
Feb  5 16:37:28 server dovecot: child 29973 (login) returned error 127
Feb  5 16:37:28 server dovecot: child 29974 (login) returned error 127
Feb  5 16:37:28 server dovecot: child 29975 (login) returned error 127
Feb  5 16:37:28 server dovecot: imap-login: imap-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:37:28 server dovecot: child 29976 (login) returned error 127
Feb  5 16:37:28 server dovecot: imap-login: imap-login: error while loading shared libraries: libsepol.so.1: failed to map segment from shared object: Cannot allocate memory
Feb  5 16:37:28 server dovecot: child 29977 (login) returned error 127

If required I can attach a longer maillog message.
Reply With Quote
  #8  
Old 6th February 2008, 10:10
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,487
Thanks: 835
Thanked 5,524 Times in 4,345 Posts
Default

Is this a virtual server? If yes, ask your ISP to add more memory to your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 6th February 2008, 22:05
Chip Chip is offline
Junior Member
 
Join Date: Nov 2007
Posts: 12
Thanks: 3
Thanked 2 Times in 1 Post
Default

Hi,

No, it is a dedicated server, maintained by us, with 4GB ram

-bash-3.1$ free
total used free shared buffers cached
Mem: 4031828 3781196 250632 0 43292 2406028
-/+ buffers/cache: 1331876 2699952
Swap: 2031608 3568 2028040

from ISPConfig

Cached: 2396416 kB
SwapCached: 388 kB
Active: 2671696 kB
Inactive: 688704 kB
HighTotal: 0 kB
HighFree: 0 kB
LowTotal: 4031828 kB
LowFree: 486636 kB
SwapTotal: 2031608 kB
SwapFree: 2028040 kB
Dirty: 9392 kB
Writeback: 0 kB
AnonPages: 921036 kB
Mapped: 51276 kB
Slab: 85876 kB
PageTables: 70132 kB
NFS_Unstable: 0 kB
Bounce: 0 kB
CommitLimit: 4047520 kB
Committed_AS: 2158268 kB
VmallocTotal: 34359738367 kB
VmallocUsed: 263860 kB
VmallocChunk: 34359474327 kB
HugePages_Total: 0
HugePages_Free: 0
HugePages_Rsvd: 0
Hugepagesize: 2048 kB
Reply With Quote
  #10  
Old 7th February 2008, 12:54
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,487
Thanks: 835
Thanked 5,524 Times in 4,345 Posts
 
Default

Please have a look here:

http://www.cyberciti.biz/tips/rhel-d...libraries.html
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following 2 Users Say Thank You to till For This Useful Post:
AbannyvabVask (15th December 2013), Chip (8th February 2008)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail problems when more than one site exists for a single domain james@thereidsonline.com Installation/Configuration 1 5th January 2007 11:59
Problems with webmail logins and POP3 Spaetzle General 11 24th November 2006 17:05
Change of URL in Webmail in second domain jofranco General 1 8th May 2006 01:37
Problems with domain and host name ispconfig 2.1.1 grantdutoit Installation/Configuration 8 6th April 2006 22:53
Bind, Postfix and possibly more problems from "http://" domain entry LunarNexus Installation/Configuration 5 5th April 2006 16:50


All times are GMT +2. The time now is 18:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.