Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st February 2007, 16:31
coder09 coder09 is offline
Junior Member
 
Join Date: Feb 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Install Error on CentOS 64bit.. Go Figure

Ok, I've searched up and down, read every thread relating to the error PHP throws during configure about not being able to find the OpenSSL libraries. I've spent hours on this, and 25+ build attempts later, nothing.

Unlike most others, where PHP says it can't find the libraries and references <env.h>, I get no reference to a specific file.

Background... long long time FreeBSD user that's used to building exclusively from source, so working with package managers that actually work are a bit new to me.

So anyways, I've manually hacked the compile_aps/compile file with every thing I can think of as well as everything mentioned regarding pointing --with-openssl=XYZ, hardcoding the plain --with-openssl, using --with-openssl-dir=XYZ, etc, etc.

Everything compiles fine up until the execution of the php configure file. I have the "normal" Apache with PHP5 already compiled and installed with OpenSSL with no problem.

The only thing I have not been able to try as some have hinted is using the 32bit version of openssl-devel. I have manually fetched that RPM (so I believe), but it won't install because a slew of other packages depend on the libs from the 64bit version. If you feel the key lies in this, could you walk me through with a command line verbatim example of how to make the 64bit coexist with the 32bit?

Secondly, I removed the --with-openssl altogether just to see what would happen. I got the zlib is old security issue error message. So I updated zlib via Yum. Now when it goes to compile PHP I get a zlib error now also.

I've went as far as hacking up setup2 and compile to basically omit PHP as I planned on adding the module after the fact from my good build, but the whole thing kinda went kablewy at the end.

So my two issues are OpenSSL, and once that is fixed I will obviously have to deal with the zlib issue.

Help please!!

Here is the output:

Doing ./setup (no mods to anything) -------
Configuring extensions
checking whether to enable LIBXML support... no
checking libxml2 install dir... no
checking for OpenSSL support... yes
checking for Kerberos support... no
checking for DSA_get_default_method in -lssl... yes
checking for pkg-config... no
configure: error: Cannot find OpenSSL's libraries
ERROR: Could not configure PHP
cd: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
mv: cannot stat `binaries/aps.tar.gz': No such file or directory
mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
mv: cannot stat `binaries/cronolog': No such file or directory
mv: cannot stat `binaries/cronosplit': No such file or directory
mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
mv: cannot stat `binaries/zip': No such file or directory
mv: cannot stat `binaries/unzip': No such file or directory
tar: spamassassin.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `spamassassin': No such file or directory
tar: uudeview.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `uudeview': No such file or directory
tar: clamav.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `clamav': No such file or directory
tar: aps.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
./setup2: line 860: ispconfig_tmp/php/bin/php: No such file or directory
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!


Output After Removing --with-openssl: --------

/bin/sh /root/install_ispconfig/compile_aps/php-5.2.1/libtool --silent --preserve-dup-deps --mode=link gcc -I/usr/include -g -O2 -rpath /root/install_ispconfig/compile_aps/php-5.2.1/libs -avoid-version -module -L/usr/local/lib/mysql/lib -R /usr/local/lib/mysql/lib
...
Zend/zend_ini.lo Zend/zend_qsort.lo Zend/zend_multibyte.lo Zend/zend_ts_hash.lo Zend/zend_stream.lo Zend/zend_iterators.lo Zend/zend_interfaces.lo Zend/zend_exceptions.lo Zend/zend_strtod.lo Zend/zend_objects.lo Zend/zend_object_handlers.lo Zend/zend_objects_API.lo Zend/zend_default_classes.lo Zend/zend_execute.lo sapi/apache/sapi_apache.lo sapi/apache/mod_php5.lo sapi/apache/php_apache.lo main/internal_functions.lo -lcrypt -lcrypt -lrt -lmysqlclient -lz -lresolv -lm -ldl -lnsl -lcrypt -lcrypt -o libphp5.la
/usr/bin/ld: /usr/lib/gcc/x86_64-redhat-linux/3.4.6/../../../../lib64/libz.a(compress.o): relocation R_X86_64_32 against `a local symbol' can not be used when making a shared object; recompile with -fPIC
/usr/lib/gcc/x86_64-redhat-linux/3.4.6/../../../../lib64/libz.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make: *** [libphp5.la] Error 1
ERROR: Could not make PHP
cd: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Reply With Quote
Sponsored Links
  #2  
Old 21st February 2007, 16:35
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,216 Times in 4,089 Posts
Default

First, removing --with-openssl wont help you as the resulting PHP binary would not be able to run ISPCOnfig anymore.

Have you installed your system according to the perfect setup guide for centos?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 21st February 2007, 17:52
coder09 coder09 is offline
Junior Member
 
Join Date: Feb 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes, I should have clarified. This was a fresh CentOS 4.4 dedicated server from a colo.

I followed the "Perfect Server - Centos 64bit" guide from the moment I first logged in. There was some packages installed already and pre-config'd, so I had removed any that were not current and installed by the guide copy/paste.

I guess why I am so baffled is I can install via RPM/Yum PHP fine with Openssl, but the build from source in ISPConfig fails.

I'm plenty familiar with troublesome builds. Normally I would just set ENV and LD paths, or explicitly define header locations on FreeBSD and you can make it work. I just can't seem to get the PHP configure file to listen to what I am telling it.

What specific libs or headers is PHP is looking for and exactly where?

Thanks!
Reply With Quote
  #4  
Old 21st February 2007, 21:16
coder09 coder09 is offline
Junior Member
 
Join Date: Feb 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Anyone have any clues?
Reply With Quote
  #5  
Old 22nd February 2007, 21:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
 
Default

Maybe this link helps you? http://www.howtoforge.com/forums/sho...on+R_X86_64_32
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
install Net::DNS chrno Installation/Configuration 4 5th September 2006 17:01
Install ISPConfig on CentOS Server, in brief gfts Tips/Tricks/Mods 11 4th April 2006 08:29
Mandriva 10.2 Perfect Setup Install Problems... ctroyp Installation/Configuration 12 30th December 2005 16:04
Notes for CentOS 4.1 install felipegeek Installation/Configuration 6 19th December 2005 10:21
Trouble install on CentOS 4.2 feppa Installation/Configuration 3 12th December 2005 15:23


All times are GMT +2. The time now is 05:22.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.