Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st February 2007, 10:17
gripner gripner is offline
Junior Member
 
Join Date: Oct 2006
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default 553 You have a reverse DNS problem

Hi

Have DNS set up on a ISPconfig box

tryin to send mail to a person and i get this error msg back
553 You have a reverse DNS problem

Dont understand why tho, my dns config looks like this:
> set type=any
>
> ctisystems.se
Server: ns1.ctisystems.se
Address: 195.178.169.153

ctisystems.se
primary name server = ns1.ctisystems.se
responsible mail addr = support.ctisystems.se
serial = 2007022101
refresh = 3600 (1 hour)
retry = 1800 (30 mins)
expire = 604800 (7 days)
default TTL = 600 (10 mins)
ctisystems.se nameserver = sbs.ctisystems.se
ctisystems.se nameserver = ns1.ctisystems.se
ctisystems.se MX preference = 10, mail exchanger = sbs.ctisystems.se
ctisystems.se internet address = 195.178.169.153
ns1.ctisystems.se internet address = 195.178.169.153
sbs.ctisystems.se internet address = 195.178.169.154


And if i do a PTR lookup on sbs.ctisystems.se wich should be what needs to have a PTR right ? it looks like this :
> set type=PTR
> 195.178.169.154
Server: ns1.ctisystems.se
Address: 195.178.169.153

154.169.178.195.in-addr.arpa name = server1.ctisystems.se
154.169.178.195.in-addr.arpa name = sbs.ctisystems.se
169.178.195.in-addr.arpa nameserver = ns1.ctisystems.se
ns1.ctisystems.se internet address = 195.178.169.153
>



Anyone have any bright ideas?
Reply With Quote
Sponsored Links
  #2  
Old 21st February 2007, 11:30
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

If you enter your domain at dnsstuff.com for testing (http://www.dnsstuff.com/tools/dnsrep...=ctisystems.se) you see at least part of your problems
Code:
FAIL	Missing (stealth) nameservers
FAIL: You have one or more missing (stealth) nameservers. 
The following nameserver(s) are listed (at your nameservers) as nameservers
for your domain, but are not listed at the parent nameservers (therefore, they 
may or may not get used, depending on whether your DNS servers return them 
in the authority section for other requests, per RFC2181 5.4.1). You need to 
make sure that these stealth nameservers are working; if they are not 
responding, you may have serious problems! The DNS Report will not query 
these servers, so you need to be very careful that they are working properly.

sbs.ctisystems.se.
This is listed as an ERROR because there are some cases where nasty problems 
can occur (if the TTLs vary from the NS records at the root servers and the NS 
records point to your own domain, for example).
Why you're getting a reverse DNS reject, I don't know (yet). There must be someting more wrong, because trying to resolve the IP addresses gives a servfail, which means rDNS is not setup at all:
Code:
:~$ dig -x 195.178.169.154

; <<>> DiG 9.3.2 <<>> -x 195.178.169.154
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 32056
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;154.169.178.195.in-addr.arpa.  IN      PTR

;; ANSWER SECTION:
154.169.178.195.in-addr.arpa. 86399 IN  CNAME   154.128-25.169.178.195.in-addr.arpa.

;; Query time: 12 msec
;; SERVER: 172.16.3.254#53(172.16.3.254)
;; WHEN: Wed Feb 21 11:28:17 2007
;; MSG SIZE  rcvd: 71

~$ dig -x 195.178.169.153

; <<>> DiG 9.3.2 <<>> -x 195.178.169.153
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 42826
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;153.169.178.195.in-addr.arpa.  IN      PTR

;; ANSWER SECTION:
153.169.178.195.in-addr.arpa. 86399 IN  CNAME   153.128-25.169.178.195.in-addr.arpa.

;; Query time: 12 msec
;; SERVER: 172.16.3.254#53(172.16.3.254)
;; WHEN: Wed Feb 21 11:28:45 2007
;; MSG SIZE  rcvd: 71
Reply With Quote
  #3  
Old 21st February 2007, 16:05
gripner gripner is offline
Junior Member
 
Join Date: Oct 2006
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I fixed some of the problems tht dnsstuff showed,

Stil gt the same problem tho, any more ideas?
Reply With Quote
  #4  
Old 22nd February 2007, 20:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

I'm having difficulties to understand what exactly the problem is. Could you rephrase it?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 23rd February 2007, 08:23
gripner gripner is offline
Junior Member
 
Join Date: Oct 2006
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The problem is:

When i try to send an email via our server to a customers email hes server replies with
553 You have a reverse DNS problem!
ANd dont accept any mail.
Reply With Quote
  #6  
Old 23rd February 2007, 08:30
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

You have not fixed your DNS problems
Code:
~$ dig -x 195.178.169.154

; <<>> DiG 9.3.2 <<>> -x 195.178.169.154
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 42787
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;154.169.178.195.in-addr.arpa.  IN      PTR

;; ANSWER SECTION:
154.169.178.195.in-addr.arpa. 86399 IN  CNAME   154.128-25.169.178.195.in-addr.arpa.

;; Query time: 12 msec
;; SERVER: 172.16.3.254#53(172.16.3.254)
;; WHEN: Fri Feb 23 08:29:15 2007
;; MSG SIZE  rcvd: 71
Your server is not responding. Blocked port 53? Is it not authoritative for this address range?
Reply With Quote
  #7  
Old 28th February 2007, 11:05
gripner gripner is offline
Junior Member
 
Join Date: Oct 2006
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

doubt port 53 is blocked since its not behind a FW atm, and the server should respond since it responds to dns queries. also responds to PTR queries
Reply With Quote
  #8  
Old 28th February 2007, 11:20
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

A fresh "dig" a minute ago still gives a SERVFAIL, so your server is not working. There must be a configuration problem.
Reply With Quote
  #9  
Old 28th February 2007, 15:40
gripner gripner is offline
Junior Member
 
Join Date: Oct 2006
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

its most likely something wierd in the config, dunno what tho. kinda thought ISPConfig setss up PTR record correct when you add our DNS stuff
Reply With Quote
  #10  
Old 28th February 2007, 15:44
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 265
Thanked 152 Times in 132 Posts
 
Default

You will need to ask your ISP to set the reverse DNS, but I do not think that this is the main problem.
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS Configuration Problems VMartins Installation/Configuration 10 24th July 2007 14:40
DNS problem wrender Server Operation 2 25th November 2006 16:57
DNS Default TTL and Reverse Zone WEX General 2 16th June 2006 00:46
Reverse DNS disasm General 3 13th January 2006 19:43
DNS issue and user's alias problem rosa hsiao General 3 2nd November 2005 10:03


All times are GMT +2. The time now is 20:51.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.