Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 31st October 2005, 19:00
nagual nagual is offline
Junior Member
 
Join Date: Oct 2005
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default postfix/courier IMAP problems

I followd the guide on howto forge to set up and ubuntu server with ISP config. Everything went ok, however I cannot send or recieve emails. Anybody wanna point me in the right direction to start troubleshooting this thing?
Reply With Quote
Sponsored Links
  #2  
Old 31st October 2005, 19:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

You have to be a little bit more detailed.
Which distribution do you use, which mailserver (Postfix or Sendmail), which POP3 daemon, ...
What's in the mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 31st October 2005, 19:56
nagual nagual is offline
Junior Member
 
Join Date: Oct 2005
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am using ubuntu 5.04, and postfix with courier Imap. here is the postfix mail log
It seems it is a login problem with Imap. Where can I edit the users and passwords for Imap? I am trying to use one of the system users and passwords.

Oct 31 11:28:31 mailweb postfix/master[8826]: daemon started -- version 2.1.5
Oct 31 11:31:07 mailweb postfix/master[8826]: terminating on signal 15
Oct 31 11:31:11 mailweb postfix/master[9144]: daemon started -- version 2.1.5
Oct 31 11:35:00 mailweb courierpop3login: Connection, ip=[::ffff:127.0.0.1]
Oct 31 11:35:01 mailweb postfix/smtpd[9501]: connect from localhost.localdomain[127.0.0.1]
Oct 31 11:35:01 mailweb postfix/smtpd[9501]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Oct 31 11:35:01 mailweb postfix/smtpd[9501]: disconnect from localhost.localdomain[127.0.0.1]
Oct 31 12:55:21 mailweb imaplogin: Connection, ip=[::ffff:192.168.1.101]
Oct 31 12:55:21 mailweb imaplogin: couriertls: connect: error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number
Oct 31 12:55:21 mailweb imaplogin: Connection, ip=[::ffff:192.168.1.101]
Oct 31 12:55:34 mailweb imaplogin: LOGIN FAILED, ip=[::ffff:192.168.1.101]
Oct 31 12:55:38 mailweb imaplogin: LOGOUT, ip=[::ffff:192.168.1.101]
Oct 31 12:55:38 mailweb imaplogin: Connection, ip=[::ffff:192.168.1.101]
Oct 31 12:55:38 mailweb imaplogin: couriertls: connect: error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number
Oct 31 12:55:38 mailweb imaplogin: Connection, ip=[::ffff:192.168.1.101]
Oct 31 12:55:39 mailweb imaplogin: LOGOUT, ip=[::ffff:192.168.1.101]
Reply With Quote
  #4  
Old 31st October 2005, 22:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Can you run
Code:
telnet localhost 25
and then issue
Code:
ehlo localhost
? What's the output?
Also, can you post /etc/postfix/main.cf and the ouput of
Code:
netstat -tap
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 31st October 2005, 23:58
nagual nagual is offline
Junior Member
 
Join Date: Oct 2005
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here is netstat output

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:mysql *:* LISTEN 8261/mysqld
tcp 0 0 *:netbios-ssn *:* LISTEN 3896/smbd
tcp 0 0 *:81 *:* LISTEN 8707/ispconfig_http
tcp 0 0 *:ftp *:* LISTEN 9168/proftpd: (acce
tcp 0 0 mailweb.nagual.h:domain *:* LISTEN 8860/named
tcp 0 0 localhost.locald:domain *:* LISTEN 8860/named
tcp 0 0 *:smtp *:* LISTEN 9144/master
tcp 0 0 localhost.localdoma:953 *:* LISTEN 8860/named
tcp 0 0 *:microsoft-ds *:* LISTEN 3896/smbd
tcp 0 0 mailweb.na:microsoft-ds 192.168.1.104:4196 ESTABLISHED9450/smbd
tcp6 0 0 *:imaps *:* LISTEN 3701/couriertcpd
tcp6 0 0 *op3s *:* LISTEN 3738/couriertcpd
tcp6 0 0 *:2222 *:* LISTEN 3920/sshd
tcp6 0 0 *op3 *:* LISTEN 3717/couriertcpd
tcp6 0 0 *:imap2 *:* LISTEN 3680/couriertcpd
tcp6 0 0 *:www *:* LISTEN 8750/apache2
tcp6 0 0 *:smtp *:* LISTEN 9144/master
tcp6 0 0 ip6-localhost:953 *:* LISTEN 8860/named
tcp6 0 0 *:https *:* LISTEN 8750/apache2
tcp6 0 0 ::ffff:192.168.1.10:www ip221.lincolnplati:1144 TIME_WAIT -
tcp6 0 52 ::ffff:192.168.1.1:2222 ip221.lincolnplati:1130 ESTABLISHED13473/1
tcp6 0 0 ::ffff:192.168.1.1:2222 ::ffff:192.168.1.:58112 ESTABLISHED10496/0

and /etc/postfix/main.cf

# See /usr/share/postfix/main.cf.dist for a commented, more complete version

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

myhostname = themadelexperience.homedns.org
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
#mydestination = themadelexperience.homedns.org, nagual.homelinux.net, mailweb
relayhost =
mynetworks = 127.0.0.0/8
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/
mailbox_command =

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names
Reply With Quote
  #6  
Old 1st November 2005, 00:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Looks ok. What about telnet?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 1st November 2005, 01:10
nagual nagual is offline
Junior Member
 
Join Date: Oct 2005
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

telnet localhost 25 says

connected to localhost.localdomain.
Escape character is '^]'.
220 themadelexperience.homedns.org ESMTP Postfix (Ubuntu)

could it be because I have localhost.localdomain, instead of my dyndns name combined with the server name?

Last edited by nagual; 1st November 2005 at 03:00.
Reply With Quote
  #8  
Old 1st November 2005, 09:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

You have to type
Code:
ehlo localhost
after the line 220
Code:
themadelexperience.homedns.org ESMTP Postfix (Ubuntu)
What do you see then?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 1st November 2005, 17:25
nagual nagual is offline
Junior Member
 
Join Date: Oct 2005
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

this is what it says.

250-themadelexperience.homedns.orgil.log
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
Reply With Quote
  #10  
Old 1st November 2005, 18:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
 
Default

Quote:
Originally Posted by nagual
this is what it says.

250-themadelexperience.homedns.orgil.log
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
Looks ok. This is what I get:
Code:
telnet themadelexperience.homedns.org 25
Trying 69.23.134.83...
telnet: Unable to connect to remote host: Connection timed out
So I guess your server is in a local network, and you haven't configured your router to forward port 25 to your ISPConfig server...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with groups/grpconv linuxfast General 28 21st April 2008 09:35
Cyrus IMAP Configuration ?? kisong Installation/Configuration 20 26th October 2005 17:15
Problems getting through the installation klausagnoletti Installation/Configuration 4 26th September 2005 12:23
Courier IMAP - when does it delete deleted messages?? hagel Server Operation 3 18th August 2005 23:52
Little problems setting up the ISPConfig Luciano Installation/Configuration 1 15th August 2005 20:17


All times are GMT +2. The time now is 02:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.