Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th February 2007, 20:21
mejborn mejborn is offline
Junior Member
 
Join Date: Feb 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Beginners problem with Postfix.

Hey, my first postin theese forums, so please correct me if iam doing anything wrong.

And by the way, great site!

I've have followed this Howto:
http://howtoforge.com/virtual_postfi..._quota_courier

But I ran into a wall somewhere in the configuration. I've completed the how to, and there was no errors in the setup (i guess).

But when i try to login, the users don't exists (i am trying with telnet host 110/25/143).

My log files contains the following:

compark:/var/log# cat mail.err

Feb 14 16:47:03 compark imaplogin: LOGIN FAILED, ip=[::ffff:127.0.0.1]
Feb 14 16:48:27 compark postfix/smtp[16935]: fatal: unexpected command-line argument: 127.0.0.1:10025
Feb 14 17:10:50 compark postfix/smtp[16950]: fatal: unexpected command-line argument: 127.0.0.1:10025
Feb 14 17:44:10 compark postfix/smtp[17087]: fatal: unexpected command-line argument: 127.0.0.1:10025
Feb 14 18:50:50 compark postfix/smtp[17107]: fatal: unexpected command-line argument: 127.0.0.1:10025
compark:/var/log#

compark:/var/log# cat mail.info
Feb 14 18:50:50 compark postfix/qmgr[16506]: 031B6B89E: from=<root@compark.dk>, size=279, nrcpt=1 (queue active)
Feb 14 18:50:50 compark postfix/smtp[17107]: fatal: unexpected command-line argument: 127.0.0.1:10025
Feb 14 18:50:51 compark postfix/qmgr[16506]: warning: premature end-of-input on private/amavis socket while reading input attribute name
Feb 14 18:50:51 compark postfix/qmgr[16506]: warning: private/amavis socket: malformed response
Feb 14 18:50:51 compark postfix/master[16503]: warning: process /usr/lib/postfix/smtp pid 17107 exit status 1
Feb 14 18:50:51 compark postfix/master[16503]: warning: /usr/lib/postfix/smtp: bad command startup -- throttling
Feb 14 18:50:51 compark postfix/qmgr[16506]: 031B6B89E: to=<mathias@compark.dk>, relay=none, delay=7345, status=deferred (delivery temporarily suspended: mail transport unavailable)

mail.log contains the same errors as mail.info, the same goes for mail.warn.

The only place where i doesn't follow the how to is in:

2 Apply Quota Patch To Postfix

Can these errors have anything to do with this?

I hope some of you can guide me through the setup

Regards
Mejborn
Reply With Quote
Sponsored Links
  #2  
Old 14th February 2007, 21:40
mejborn mejborn is offline
Junior Member
 
Join Date: Feb 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is what i am getting from the ehlo localhost:

Connected to localhost.
Escape character is '^]'.
220 compark.dk ESMTP Postfix (Debian/GNU)
ehlo localhost
250-compark.dk
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
Reply With Quote
  #3  
Old 14th February 2007, 23:10
mejborn mejborn is offline
Junior Member
 
Join Date: Feb 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Now i got a little bit longer.

I've chanced the mysql-virtual_domains.cf
So the select_field = 'domain' instead of 'virtual' as it was in the howto.

Then i manually added the directories in /home/vmail and did a chown, i followed a users comment to the howto it now looks like this:

compark:/home/vmail/compark.dk/mathias/Maildir# ls -l
totalt 12
drwx------ 2 vmail vmail 4096 2007-02-14 21:50 cur
drwx------ 2 vmail vmail 4096 2007-02-14 21:50 new
drwx------ 2 vmail vmail 4096 2007-02-14 21:50 tmp

now when is do a telnet localhost pop3 i get the following:

compark:/home/vmail/compark.dk/mathias/Maildir# telnet localhost pop3
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
+OK Hello there.
user mathias@compark.dk
+OK Password required.
pass XXXXX
-ERR Maildir invalid (no 'cur' directory)
Connection closed by foreign host.
compark:/home/vmail/compark.dk/mathias/Maildir#

Anyone that can help me?
Reply With Quote
  #4  
Old 15th February 2007, 20:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Have you compared all your configuration files with those from the tutorial? Maybe you made a typo somewhere?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 16th February 2007, 10:28
mejborn mejborn is offline
Junior Member
 
Join Date: Feb 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey falko.

Yes I have compared my configurations files with thosefrom the howto, but maybe I'll should do it again.
The "funny" thing is that now i am able to login with imap, but still not with pop3 (i stille get the same error as described earlier). But with imap it looks like this:

compark@compark:~$ telnet localhost 143
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
* OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION STARTTLS] Courier-IMAP ready. Copyright 1998-2004 Double Precision, Inc. See COPYING for distribution information.
a login mathias@compark.dk XXXX
a OK LOGIN Ok.
a logout
* BYE Courier-IMAP server shutting down
a OK LOGOUT completed
Connection closed by foreign host.
compark@compark:~$

I think it's strange that imap does not complain about the "cur" directory when pop3 does. But I will check my configurations files again.
Reply With Quote
  #6  
Old 17th February 2007, 18:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

What's the output of
Code:
netstat -tap
?
Please make sure your /etc/courier/authmysqlrc (especially the formatting) looks like the one from the tutorial.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 17th February 2007, 18:22
mejborn mejborn is offline
Junior Member
 
Join Date: Feb 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The output from netstat -tap:

compark:/home/compark# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 localhost:10024 *:* LISTEN 3133/amavisd (maste
tcp 0 0 *:714 *:* LISTEN 3500/rpc.statd
tcp 0 0 localhost:mysql *:* LISTEN 3311/mysqld
tcp 0 0 *:sunrpc *:* LISTEN 2999/portmap
tcp 0 0 compark.dk:www *:* LISTEN 3463/rinetd
tcp 0 0 *:smtp *:* LISTEN 3457/master
tcp6 0 0 *:imaps *:* LISTEN 3224/couriertcpd
tcp6 0 0 *op3s *:* LISTEN 3244/couriertcpd
tcp6 0 0 localhost:8005 *:* LISTEN 3682/java
tcp6 0 0 *:8009 *:* LISTEN 3682/java
tcp6 0 0 *:15051 *:* LISTEN 3484/sshd
tcp6 0 0 *op3 *:* LISTEN 3232/couriertcpd
tcp6 0 0 *:imap2 *:* LISTEN 3200/couriertcpd
tcp6 0 0 *:8180 *:* LISTEN 3682/java
tcp6 0 0 *:smtp *:* LISTEN 3457/master
tcp6 0 48 compark.dk:15051 50A2F0EC.flatrate:52835 ESTABLISHED4740/sshd: compark
tcp6 0 0 compark.dk:49848 efnet.pte.hu:ircd ESTABLISHED3551/java
compark:/home/compark#

My /etc/courier/authmysqlrc:

YSQL_SERVER localhost
MYSQL_USERNAME mail_admin
MYSQL_PASSWORD XXXX
MYSQL_PORT 0
MYSQL_DATABASE mail
MYSQL_USER_TABLE users
MYSQL_CRYPT_PWFIELD password
#MYSQL_CLEAR_PWFIELD password
MYSQL_UID_FIELD 5000
MYSQL_GID_FIELD 5000
MYSQL_LOGIN_FIELD email
MYSQL_HOME_FIELD "/home/vmail"
MYSQL_MAILDIR_FIELD CONCAT(SUBSTRING_INDEX(email,'@',-1),'/',SUBSTRING_INDEX(email,'@',1),'/')
#MYSQL_NAME_FIELD
MYSQL_QUOTA_FIELD quota

I am using nano is there anyway that I can check for newlines in this configuration file (newlines is not allowed right?).

Or can mc (midnight commander) or any other editor show me this?
Reply With Quote
  #8  
Old 18th February 2007, 20:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Quote:
Originally Posted by mejborn
I am using nano is there anyway that I can check for newlines in this configuration file (newlines is not allowed right?).
Newlines (aka linebreaks) are allowed, otherwise you'd have everything in one line. What is not allowed are Windows linebreaks. When you open a file with Windows linebreaks in vi or nano, each line has something like ^M at the end. If you use Unix linebreaks, the line should look ok.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 18th February 2007, 20:21
mejborn mejborn is offline
Junior Member
 
Join Date: Feb 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok but i copy/pasted the hole howto, into nano and saved it. So it should be ok. Was my authmysqlrc fine?
Reply With Quote
  #10  
Old 19th February 2007, 16:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
 
Default

Quote:
Originally Posted by mejborn
Was my authmysqlrc fine?
Yes, looks ok.
Please double-chack all configuration files, maybe there's a typo somewhere.

Do you still get this -ERR Maildir invalid (no 'cur' directory) error? What's the output of
Code:
ls -la /home/vmail/compark.dk/mathias/Maildir
now?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 18:58
Postfix Configuration Problem Shahryar Installation/Configuration 1 8th December 2006 16:19
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 16:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 16:36
Perfect Setup - Fedora Core 4 - postfix problem Median Installation/Configuration 7 2nd February 2006 13:21


All times are GMT +2. The time now is 15:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.