Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 15th February 2007, 22:16
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 265
Thanked 151 Times in 131 Posts
Default

man man.. it's not my day
Quote:
permit_sasl_authentic ated,reject
should be
Quote:
permit_sasl_authenticated,reject
Reply With Quote
Sponsored Links
  #12  
Old 15th February 2007, 22:48
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 265
Thanked 151 Times in 131 Posts
Default

Quote:
Originally Posted by martinfst
I assume this is a type in the forum post? (Watch the extra space between 'tic' and 'ated')
Yes I just found out :-)

Anyway.. It looked that all is working fine, but it kept asking for a username and password.

When I use it the normal way, the username an password are okay, but when I try "your trick", it's a no go with the username and password for that user.

I've tired about every combination possible with Outlook.

Then I got it.. It needed "Log on to incoming mail server before sending mail"
After I enabled that option, the Password problem was gone...

BUT... Now when I send an email to any user (on the server system or not) I get a "554 Recipient address rejected: Access denied" error..

mail.log

Quote:
Feb 15 22:42:01 host postfix/smtpd[14424]: NOQUEUE: reject: RCPT from a66-66-6-666.adsl.cistrun.nl[66.66.6.666]: 554
<info@mydomain.com>: Recipient address rejected: Access denied; from=<info@myotherdomain.com> to=<info@mydomain.com> proto=ESMTP helo=<XEON>

Last edited by edge; 15th February 2007 at 22:50.
Reply With Quote
  #13  
Old 16th February 2007, 13:53
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 265
Thanked 151 Times in 131 Posts
 
Default

Okay.. Got it working.

I needed to remove the 2nd n from the submission inet option (it's the "CHROOT" option).

This is what I have now, and it's working.. (not sure if all is okay now with the removed n for CHROOT)
Code:
submission inet n - - - - smtpd
 -o smtpd_sasl_auth_enable=yes
 -o smtpd_use_tls=yes
 -o smtpd_recipient_restrictions=permit_sasl_authenticated,reject
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
Getting e-mail working hansoffate Installation/Configuration 29 13th August 2008 16:33
Ask: ASSP -> between SMTP Destination & Listen Port abadi HOWTO-Related Questions 3 18th December 2006 14:15
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 22:40


All times are GMT +2. The time now is 15:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.