Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th February 2007, 23:49
codesmith codesmith is offline
Junior Member
 
Join Date: Feb 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Successful install on FC5 but no web admin available

Hi,

Just installed ISPConfig on a remote Fedora Core 5 server that was just set up by our web provider. (They installed FC5). ISPConfig install was successful and can restart just fine using:
/etc/init.d/ispconfig_server restart

I set it up for ip address (first of 4 on the machine) access (no entry for host name during install, ip address for domain). I go to http://ipaddress:81 and nothing happens. I don't think there's a firewall installed. I see folks want to see the output of netstat -tap so here's that:

Code:
[ ~]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name   
tcp        0      0 *:mysql                     *:*                         LISTEN      30835/mysqld        
tcp        0      0 *:sunrpc                    *:*                         LISTEN      1700/portmap        
tcp        0      0 *:hosts2-ns                 *:*                         LISTEN      29819/ispconfig_htt 
tcp        0      0 customer-reverse-ent:domain *:*                         LISTEN      29929/named         
tcp        0      0 customer-reverse-ent:domain *:*                         LISTEN      29929/named         
tcp        0      0 customer-reverse-ent:domain *:*                         LISTEN      29929/named         
tcp        0      0 customer-reverse-ent:domain *:*                         LISTEN      29929/named         
tcp        0      0 145008-29200.your-do:domain *:*                         LISTEN      29929/named         
tcp        0      0 localhost.localdomai:domain *:*                         LISTEN      29929/named         
tcp        0      0 *:34422                     *:*                         LISTEN      1718/rpc.statd      
tcp        0      0 localhost.localdomain:ipp   *:*                         LISTEN      4439/cupsd          
tcp        0      0 localhost.localdomain:rndc  *:*                         LISTEN      29929/named         
tcp        0      0 localhost.localdomain:smtp  *:*                         LISTEN      29880/sendmail: acc 
tcp        0      0 *:http                      *:*                         LISTEN      29842/httpd         
tcp        0      0 *:ssh                       *:*                         LISTEN      1962/sshd           
tcp        0      0 *:https                     *:*                         LISTEN      29842/httpd         
tcp        0   1872 145008-29200.your-domai:ssh adsl-69-109-111-111.d:56219 ESTABLISHED 25884/0
Reply With Quote
Sponsored Links
  #2  
Old 14th February 2007, 10:22
mphayesuk mphayesuk is offline
Senior Member
 
Join Date: Sep 2005
Location: UK, East Midlands
Posts: 517
Thanks: 1
Thanked 3 Times in 3 Posts
Send a message via MSN to mphayesuk
Default

One small thing which might be a typo, the control panel is accessed by https://ipadd:81 and not http://ipadd:81 (use the secure http)

Hope this helps
Reply With Quote
  #3  
Old 14th February 2007, 19:43
codesmith codesmith is offline
Junior Member
 
Join Date: Feb 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry - mistype on my part. I am trying to go to https://xxx.xxx.xxx.xxx:81/

Any other ideas?
Reply With Quote
  #4  
Old 14th February 2007, 20:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,730 Times in 2,568 Posts
Default

Are you using a public IP address?
Also, what's the output of
Code:
iptables -L
? Is SELinux disabled?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 14th February 2007, 20:23
codesmith codesmith is offline
Junior Member
 
Join Date: Feb 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the reply.

1) Yes, using a public accessible IP address. I can go to port 80 of the IP address and see the Fedora Test page

2)

Code:
[ ~]# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         
DROP       all  --  anywhere             anywhere            state INVALID 
ACCEPT     all  --  anywhere             anywhere            state RELATED,ESTABLISHED 
ACCEPT     all  --  anywhere             anywhere            
ACCEPT     icmp --  anywhere             anywhere            
ACCEPT     tcp  --  anywhere             anywhere            tcp dpt:http 
ACCEPT     tcp  --  anywhere             anywhere            tcp dpt:https 
ACCEPT     tcp  --  anywhere             anywhere            tcp dpt:ssh 
DROP       tcp  --  anywhere             anywhere            tcp dpts:tcpmux:65535 
DROP       udp  --  anywhere             anywhere            udp dpts:tcpmux:65535 

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
3) SeLinux looks like it's disabled:
Code:
[ ~]#  /usr/sbin/sestatus -v
SELinux status:                 disabled
Reply With Quote
  #6  
Old 15th February 2007, 09:42
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,245 Times in 4,111 Posts
Default

You have the fedora firewall enabled and this firewall blocks port 81. Please disable or customize the firewall as described in the perfect setup.

http://www.howtoforge.com/perfect_se...dora_core_5_p3

ISPConfig has its own firewall that can be enabled in the ISPConfig interface under management.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 15th February 2007, 21:17
codesmith codesmith is offline
Junior Member
 
Join Date: Feb 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Disabling Fedora's built-in firewall was the ticket. Just FYI this was done by:

service iptables stop

Thanks!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
problem install perl modules Cirox Installation/Configuration 10 16th May 2007 16:04
get thousands of "Mailsize" mails from own server torusturtle Installation/Configuration 20 24th December 2006 14:51
Rename folder -> create new folder equals contents of old folder BlueStream General 20 15th December 2006 03:32
install Net::DNS chrno Installation/Configuration 4 5th September 2006 17:01
install problem on FC5 PortMan Installation/Configuration 2 27th June 2006 12:07


All times are GMT +2. The time now is 11:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.