Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th February 2007, 00:08
martini martini is offline
Junior Member
 
Join Date: Feb 2007
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default sasl issue with postfix

Hi, (first post here)

I'm having spam relaying issues on my server so i've tried my best to make it harder for them by using SASL and adding the following to /etc/postfix.main.cf

maps_rbl_domains =
sbl.spamhaus.org
relays.ordb.org
cbl.abuseat.org
bl.spamcop.net
pbl.spamhaus.org
xbl.spamhaus.org

smtpd_client_restrictions =
reject_rbl_client sbl.spamhaus.org
reject_rbl_client relays.ordb.org
reject_rbl_client cbl.abuseat.org
reject_rbl_client bl.spamcop.net
reject_rbl_client pbl.spamhaus.org
reject_rbl_client xbl.spamhaus.org

This has sorted out the spam from being relayed from my box but now when i try and send email from Thunderbird I get the following message

Feb 12 21:32:02 postfix/smtpd[29163] NOQUEUE: reject: RCPT from hostXX-XXX-XXX-XXX.rangeXX-XXX.btcentralplus.com[XXX.XXX.XXX.XXX]: 554 Service unavailable; Client host [XX.XXX.XXX.XXX] blocked using pbl.spamhaus.org; http://www.spamhaus.org/query/bl?ipXX.XXX.XXX.XXX; from=<myemail@mydomain.com> to=<external-test-email@gmail.com> proto=ESMTP helo=<[192.168.2.88]>
Feb 12 21:32:02 postfix/smtpd[29163] warning: XXX.XXX.XXX.XX.relays.ordb.org: RBL lookup error: Host or domain name not found. Name service error for name=XXX.XXX.XXX.X.relays.ordb.org type=A: Host not found, try again
Feb 12 21:31:53 postfix/smtpd[29163] connect from hostXX-XX-XXX-XXX.rangeXX-XXX.btcentralplus.com[xx.xxx.x.xx.xx]

Without the smtpd_client_restrictions, maps_rbl_domains settings it works fine so i know that i've got the sasl password working in thunderbird. I would like to be able to use both stop spam.

Any help please?

Kind regards

Dan
Reply With Quote
Sponsored Links
  #2  
Old 13th February 2007, 10:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,717
Thanks: 840
Thanked 5,593 Times in 4,404 Posts
Default

What is the output of:

postconf -n | grep mynetworks
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 13th February 2007, 20:12
martini martini is offline
Junior Member
 
Join Date: Feb 2007
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

hi till,

I get the following from

#./postconf -n | grep mynetworks
mynetworks_style = host
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination

does this help?

cheers

Dan
Reply With Quote
  #4  
Old 14th February 2007, 20:44
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by martini
Feb 12 21:32:02 postfix/smtpd[29163] warning: XXX.XXX.XXX.XX.relays.ordb.org: RBL lookup error: Host or domain name not found. Name service error for name=XXX.XXX.XXX.X.relays.ordb.org type=A: Host not found, try again
There seems to be a DNS lookup problem. Have you checked if
Code:
dig XXX.XXX.XXX.X.relays.ordb.org
works on your system? Do you have valid nameservers in /etc/resolv.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 14th February 2007, 23:12
martini martini is offline
Junior Member
 
Join Date: Feb 2007
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Falko,

Thanks for the help.

11.222.333.444 = my ip address of my home pc that i'm trying to send mail from. The domain i'm sending it from is Domain2.com

55.555.555.555 = my server ip address. has a main domain of Domain1.com I have multiple domains on this server.

log snippett

Feb 12 21:32:02 postfix/smtpd[29163] warning: 444.333.222.11.relays.ordb.org: RBL lookup error: Host or domain name not found. Name service error for name=444.333.222.11.relays.ordb.org type=A: Host not found, try again

Console

$ dig 11.222.333.444

; <<>> DiG 9.3.4 <<>> 11.222.333.444
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 1890
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;11.222.333.444. IN A

;; AUTHORITY SECTION:
. 86400 IN SOA A.ROOT-SERVERS.NET. NSTLD.VERISIGN-GRS.COM. 2007021400 1800 900 604800 86400

;; Query time: 15 msec
;; SERVER: 55.555.555.555 #53(55.555.555.555 )
;; WHEN: Wed Feb 14 20:45:13 2007
;; MSG SIZE rcvd: 107


when I look in /etc/resolv.conf I only see the main domain name for my server, Domain1.com. I do not see the domain name for the domain from which i am trying to send the mail from, Domain2. My server has multiple domains on it. Could this be the problem?

$more /etc/resolv.conf
nameserver 55.555.555.555
search Domain1.com
domain Domain1.com


Hope this makes sense. I'm only starting out and find this help really useful.

cheers

Dan
Reply With Quote
  #6  
Old 15th February 2007, 20:30
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Put this into /etc/resolv.conf and try again:
Code:
nameserver 145.253.2.75
nameserver 193.174.32.18
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 15th February 2007, 22:13
martini martini is offline
Junior Member
 
Join Date: Feb 2007
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Falko,

Who's does those ip addresses belong to?

What will this do?

Many thanks in advance

Dan
Reply With Quote
  #8  
Old 16th February 2007, 13:58
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,042
Thanks: 269
Thanked 154 Times in 133 Posts
Default

Both IP's are from 'open' name servers that are located in Germany.

Lot's of people use them.
Reply With Quote
  #9  
Old 18th February 2007, 18:27
martini martini is offline
Junior Member
 
Join Date: Feb 2007
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

I've added the those ip addresses to my /etc/resolv.conf but still get the message from spamhaus.org saying that my ip address is being blocked by them as it is on their pbl list.

"An error occured while sending mail. The mail server responded:Service unavailable; Client host [my home ip address] block using pbl.spamhaus.org;
http://www.spamhaus.org/query/bl?ip="my home ip address". Please verify that your email adddress is correct in you Mail prerences and try again"

I went to spamhaus and "my home ip address" is on their list. I have turned on smtp authentication on thunderbird but it still doesn't let me send mail with spamhaus turned on. Annoyingly spamhaus only provides instructions for other email clients not thunderbird.

any ideas?

Many thanks

Dan
Reply With Quote
  #10  
Old 19th February 2007, 16:10
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

You can ask spamhaus to remove your IP address, but I doubt they will do it if you have a dynamic IP address.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix: smtpd --> SASL LOGIN authentication failed tom General 25 2nd February 2010 18:43
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 16:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 16:36
SASL AUTH with postfix on Sarge keulu Server Operation 6 31st August 2006 23:49
Ubuntu + postfix + sasl trouble twinspop Server Operation 6 14th July 2006 13:16


All times are GMT +2. The time now is 01:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.