Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th February 2007, 23:05
ambiz_x ambiz_x is offline
Junior Member
 
Join Date: Feb 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to ambiz_x
Question Problem with upload.php (Apache2 ubuntu6.10)

I get this message:

Warning: Unknown: failed to open stream: Permission denied in Unknown on line 0

Warning: Unknown: Failed opening '/var/www/pic/upload.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in Unknown on line 0

Line 0? and there is no pear directory, in the /usr/share/ directory.

What to do?

ambiz_x
Reply With Quote
Sponsored Links
  #2  
Old 13th February 2007, 09:52
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

I guess you're trying to install some kind of web application that needs the PEAR extensions? When does this error show?
Reply With Quote
  #3  
Old 13th February 2007, 18:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Are you referring to this tutorial? http://www.howtoforge.com/scan_virus..._php_clamavlib
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 13th February 2007, 20:51
ambiz_x ambiz_x is offline
Junior Member
 
Join Date: Feb 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to ambiz_x
Default

No I'am referring to this tutorial. http://www.howtoforge.com/scan_virus...p_clamavlib_p2

I had it working as it is at above page, but when I changed directory to
/var/www/pic the problem started.

Command: chown www-data:www-data /var/www/pic
and change in script:upload to pic

message:
Warning: Unknown: failed to open stream: Permission denied in Unknown on line 0

Warning: Unknown: Failed opening '/var/www/pic/upload.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in Unknown on line 0

and when I tray to do it, as it as describe at above page. I get same message, and it worked before.


Hoooping for a solution. ambiz_x
Reply With Quote
  #5  
Old 14th February 2007, 19:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by ambiz_x
No I'am referring to this tutorial. http://www.howtoforge.com/scan_virus...p_clamavlib_p2
That's page 2 of the same tutorial...

Quote:
Originally Posted by ambiz_x
I had it working as it is at above page, but when I changed directory to
/var/www/pic the problem started.
Did you replace all occurrences of /var/www/upoads with /var/www/pic?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 15th February 2007, 10:01
ambiz_x ambiz_x is offline
Junior Member
 
Join Date: Feb 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to ambiz_x
Default

Yes I did.
Reply With Quote
  #7  
Old 15th February 2007, 10:08
ambiz_x ambiz_x is offline
Junior Member
 
Join Date: Feb 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to ambiz_x
Default

But not this line:
<form method="post" action="upload.php" name="fileupload" enctype="multipart/form-data">

The up load page name is upload.php.
Reply With Quote
  #8  
Old 15th February 2007, 19:51
ambiz_x ambiz_x is offline
Junior Member
 
Join Date: Feb 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to ambiz_x
 
Default

I'am gona handle this problem, as it is winXP. Format reinstall.
Solution for all computer problemes.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
Problem with Tomcat5 and Apache2 with Virtual Hosts using mod_jk llokas HOWTO-Related Questions 1 17th January 2007 18:32
Access Problem with Apache2 Alias Heinz Installation/Configuration 3 18th November 2006 15:19
Big problem with apache2 on Ubuntu piratta Installation/Configuration 2 18th January 2006 17:29


All times are GMT +2. The time now is 00:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.