Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Kernel Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th February 2007, 17:03
pier17 pier17 is offline
Junior Member
 
Join Date: Jan 2007
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default Please help! error "/etc/sudoers is mode 0666, should be 0440"

Hi all,

on ubuntu server, I got this message "/etc/sudoers is mode 0666, should be 0440" when I try to do some configurations.

then I got into the recovery mode and put " chmod -R 0440 /etc"
when it boots normally I got ;

(none)login:

when I put any user password it doesnt accept even root user..

what should I do???

thanks in advance!
Reply With Quote
Sponsored Links
  #2  
Old 13th February 2007, 17:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,732 Times in 2,569 Posts
Default

Quote:
Originally Posted by pier17
then I got into the recovery mode and put " chmod -R 0440 /etc"
That was a really bad idea! You should have done a
Code:
chmod 0440 /etc/sudoers
but you chmod'ed all files and directories in /etc to 0440 recursively.
I think all you can do is a clean re-install (unless you have a backup of a working /etc directory).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 13th February 2007, 19:13
pier17 pier17 is offline
Junior Member
 
Join Date: Jan 2007
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

thank you for helping..

if I put ubuntu live cd and boot from it and then mount my hard drive to other location..

would it work?
Reply With Quote
  #4  
Old 14th February 2007, 12:54
zcworld zcworld is offline
Senior Member
 
Join Date: Jul 2006
Location: South Australia
Posts: 329
Thanks: 2
Thanked 37 Times in 37 Posts
Send a message via MSN to zcworld Send a message via Skype™ to zcworld
 
Default

as long as you can mount the hard drive
and it should work
__________________
Shane Ebert :: Facebok
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gallery2 Safe mode Issues grazman General 10 29th August 2008 13:34
High Availability Samba cluster - DRBD + Heartbeat djalex Server Operation 58 25th May 2007 19:38
Php Safe Mode DBoon Installation/Configuration 1 15th June 2006 21:45
Active Mode Problem snooopy Installation/Configuration 1 23rd December 2005 09:55
Proftpd Passive Mode Problem snooopy Installation/Configuration 1 22nd December 2005 09:49


All times are GMT +2. The time now is 22:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.