#41  
Old 25th March 2007, 04:12
planet_fox planet_fox is offline
Senior Member
 
Join Date: Jun 2006
Location: Munic
Posts: 308
Thanks: 14
Thanked 8 Times in 6 Posts
Send a message via Skype™ to planet_fox
Default

Ok I have on this night Apache2 new install and suphp . All ok and than I have restart the same error . I dp stop ispconfig and remove in apache.conf the ispconfig vhosts. I restart the apache . I see the Apache is on my server running . I think apache is korect and only when I do the ispconfig vhost to apache.conf became the error. I search Google and hundred foren and I find problem from a other user with my error

Code:
directory index forbidden by rule
and a post says make this in your vhost

Code:
DirectoryIndex index.php index.phtml index.php3 index.php4 index.html index.htm default.htm Index.htm
ok I do this in my apache.conf

Code:
<Directory /home/times/*/web>
      Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    DirectoryIndex index.php index.phtml index.php3 index.php4 index.html index.htm default.htm Index.htm
 <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>
and I have restart the server amd the html sites runs and the php sites .
I hope you can me give a answhere why i must set this in apche.conf
Reply With Quote
Sponsored Links
  #42  
Old 25th March 2007, 19:19
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,678
Thanks: 819
Thanked 5,318 Times in 4,171 Posts
Default

Please post the exact DirectoryIndex from the vhost the problem occurs from the Vhost_ispconfig.conf file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #43  
Old 26th March 2007, 10:00
planet_fox planet_fox is offline
Senior Member
 
Join Date: Jun 2006
Location: Munic
Posts: 308
Thanks: 14
Thanked 8 Times in 6 Posts
Send a message via Skype™ to planet_fox
Default

Code:
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
this is in all Vhosts in /etc/apache2/vhosts/Vhostsconfig.conf

mean you that ?
Reply With Quote
  #44  
Old 26th March 2007, 10:05
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,678
Thanks: 819
Thanked 5,318 Times in 4,171 Posts
Default

Quote:
Originally Posted by planet_fox
Code:
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
this is in all Vhosts in /etc/apache2/vhosts/Vhostsconfig.conf

mean you that ?
Yes, and it contains the relevant entries, thats really strange...

What is the exact name of your index page. Plesae post the name in with the eaxt upper and lower letters then it appears on your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #45  
Old 26th March 2007, 10:52
planet_fox planet_fox is offline
Senior Member
 
Join Date: Jun 2006
Location: Munic
Posts: 308
Thanks: 14
Thanked 8 Times in 6 Posts
Send a message via Skype™ to planet_fox
Default

Code:
 index.html
Reply With Quote
  #46  
Old 26th March 2007, 11:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,678
Thanks: 819
Thanked 5,318 Times in 4,171 Posts
Default

I really have no idea? What you edited and what solved your problem contains the both the index.html in the DirectoryIndex directive, just added in two different parts of the apache configuration, And declaring this directive in a vhost is definately valid and shoild even override the directive that you defined
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #47  
Old 28th March 2007, 09:10
planet_fox planet_fox is offline
Senior Member
 
Join Date: Jun 2006
Location: Munic
Posts: 308
Thanks: 14
Thanked 8 Times in 6 Posts
Send a message via Skype™ to planet_fox
 
Default

I have this add in apache2.conf

Code:
DirectoryIndex index.php index.phtml index.php3 index.php4 index.html index.htm default.htm Index.htm
and the html error Problem was finish

Code:
<Directory /home/times/*/web>
      Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    DirectoryIndex index.php index.phtml index.php3 index.php4 index.html index$
 <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cpan> install DB_File make error Nu2Linux HOWTO-Related Questions 6 13th April 2012 22:06
make rpm fails digen Kernel Questions 3 17th December 2006 21:28
clamav spamassassin with simscan @ debian Shamael Anwar Installation/Configuration 2 15th December 2006 20:06
install Net::DNS chrno Installation/Configuration 4 5th September 2006 17:01
FC3 Perfect Installation Make Errors solderboy HOWTO-Related Questions 3 2nd October 2005 16:55


All times are GMT +2. The time now is 05:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.